You are not logged in.

#1 2007-09-07 16:40:40

Registered: 2007-04-29
Posts: 272

local keyboard layout?

I am trying to turn on my local keyboard layout.
And bumped into problems,

At first Iinstaled as my friend said xxkb. but it shows only UK flag and nothing more.
Then I tired to find config files of xxkb but with no suces. -> Where are they?
So I gave up with xxkb I learned from google about command:
setxkbmap -layout lt
It makes difference. Useless symbols instead numbers. Ahhh.
So now I am totaly confused what have I do now?
Yeh I was lazy to do this carefully and check everything at install moment. But if I remember right before tons of updates it worked by editing xorg.conf, but i needed numbers more than all my native letters so I used us for long time.
Strage thing that with Firefox everything ok: lt layout works but not with abiword?

Last edited by ProzacR (2007-09-07 16:53:00)


#2 2007-09-08 18:06:25

From: Stockholm/Sweden
Registered: 2006-01-11
Posts: 70

Re: local keyboard layout?

What you should need to do to get UK layout is to add the follwing in your xorg.conf:

Option "XkbLayout" "uk"

Make sure that your keyboard model (XkbModel) is set correctly too as it can mess stuff up too!
If you havn't set the locale in rc.conf correctly i guess it could pose a problem too, but usually keymap and locale is just for console based stuff and not X stuff.

Swedish Archlinux Mirror Administrator -


Board footer

Powered by FluxBB