You are not logged in.

#26 2004-03-01 23:51:48

Guest
Guest

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

(One of these days i'll get around to registering)

Hardware: ATI Radeon 9600 XT running on an Athlon XP 2500+ and a Gigabyte board of some kind (can't remember the model off the top of my head)
Kernel:  2.6.3
Patches: Both the general one and the amd done, as said in the instructions.

#27 2004-03-02 00:01:13

punkrockguy318
Member
From: New Jersey
Registered: 2004-02-15
Posts: 706
Website

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

I think this post deserves a sticky.  Or maybe if it was refined and bug fixed it could go in the docs  big_smile That would be a great addition!  It worked for me!
Card: ATI Radeoin 9600 Sapphire
Kernel: 2.6.3 (without DRI)
Processor: Pentium 4
It worked when I used tasslehoff's PKGBUILD.  Great  big_smile


If I have the gift of prophecy and can fathom all mysteries and all knowledge, and if I have a faith that can move mountains, but have not love, I am nothing.   1 Corinthians 13:2

Offline

#28 2004-03-02 00:04:16

punkrockguy318
Member
From: New Jersey
Registered: 2004-02-15
Posts: 706
Website

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

Also:  I'm using the built-in AGP module, not AGPGart


If I have the gift of prophecy and can fathom all mysteries and all knowledge, and if I have a faith that can move mountains, but have not love, I am nothing.   1 Corinthians 13:2

Offline

#29 2004-03-04 03:14:28

punkrockguy318
Member
From: New Jersey
Registered: 2004-02-15
Posts: 706
Website

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

Ah!  My 3d accel stopped working!!  Look at my other post for my problem!  sad  sad I'm very displeased with ATI's linux support:  Next time for sure I'm going nVidia.  I'm about to swap my 256MB ATI Card with my 32MB nVidia card, just so I can actually get it to work!  nVidia has beter linux drivers I hear


If I have the gift of prophecy and can fathom all mysteries and all knowledge, and if I have a faith that can move mountains, but have not love, I am nothing.   1 Corinthians 13:2

Offline

#30 2004-03-05 22:12:42

jskier
Member
From: Minnesota, USA
Registered: 2003-07-30
Posts: 356
Website

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

Need some help with this, I'm completely stuck. I used tasslehoff's PKGBUILD and get this:

[root@intel2500 ati]# makepkg -c
: command not foundine 10:
: command not foundine 12:
/usr/bin/makepkg: ./PKGBUILD: line 25: syntax error: unexpected end of file
  (Fri Mar  5 08:15:28 PST 2004)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Retrieving Sources...
==>     Using local copy of fglrx-glc22-4.3.0-3.7.0.i386.rpm
==> Validating source files with MD5sums
    fglrx-glc22-4.3.0-3.7.0.i386.rpm ... Passed
==> Extracting Sources...
==> Removing existing pkg/ directory...
==> Starting build()...
/usr/bin/makepkg: line 536: build: command not found
==> ERROR: Build Failed.  Aborting...

I have a Radeon Powercolor 9600, kernel 2.6.3-1

Thanks in advance,
JSkier


--
JSkier

Offline

#31 2004-03-06 02:47:04

tasslehoff
Member
Registered: 2004-02-26
Posts: 7

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

I was getting that same error with the original PKGBUILD file from the first postthe problem was either that I had somehow cut and pasted part of the ati-drivers.install file into the PKGBUILD or I had one of the dependancies missing.

The other peoples problems I dont know about sad sorry

Offline

#32 2004-03-06 04:37:52

jskier
Member
From: Minnesota, USA
Registered: 2003-07-30
Posts: 356
Website

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

Well, I've played with it more, double checked dependancies and get this:

[root@intel2500 ati]# makepkg -c
: command not foundine 12:
'usr/bin/makepkg: ./PKGBUILD: line 13: syntax error near unexpected token `{
'usr/bin/makepkg: ./PKGBUILD: line 13: `build() {
  (Fri Mar  5 22:34:05 CST 2004)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Retrieving Sources...
==>     Using local copy of fglrx-glc22-4.3.0-3.7.0.i386.rpm
==> Validating source files with MD5sums
    fglrx-glc22-4.3.0-3.7.0.i386.rpm ... Passed
==> Extracting Sources...
==> Removing existing pkg/ directory...
==> Starting build()...
/usr/bin/makepkg: line 536: build: command not found
==> ERROR: Build Failed.  Aborting...

A copy of the PKGBUILD (partially modifed because the downloads wouldn't work)

 # Contributor: Manolis Tzanidakis <mtzanidakis@freemail.gr>
 pkgname=ati-drivers
 pkgver=3.7.0
 pkgrel=1
 pkgdesc="Proprietary (binary) drivers for ATI Radeon Cards."
 url="www.ati.com/support/driver.html"
 depends=('xfree86')
 install="$pkgname.install"
 source=(http://www2.ati.com/drivers/linux/fglrx-glc22-4.3.0-3.7.0.i386.rpm)
 md5sums=('7dd12340a2b8525b3a9fa1f310e06141')
 # build-time deps: rpmunpack, cpio, gzip

build() {
   cd $startdir/pkg
   rpmunpack < $startdir/src/http://www2.ati.com/drivers/linux/fglrx-glc22-4.3.0-3.7.0.i386.rpm | gzip -d | cpio -idmuv
  chmod 755 -R .
  mv opt/kde3 opt/kde
  mkdir -p opt/gnome/share
  mv usr/share/gnome/apps/ opt/gnome/share
  rm -rf usr/share/gnome usr/share/applnk 
    lib/modules/fglrx/{fglrx*.o,fglrx_info.txt} 
    usr/X11R6/bin/LICENSE.{GPL,QPL} 
    usr/X11R6/bin/*.bz2
}

Somehow the build() isn't going through, I don't know why, any other ideas anyone?

Thanks, JSkier


--
JSkier

Offline

#33 2004-03-07 20:08:25

Guest
Guest

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

Someone please help me I miss tuxracer on linux  tongue

#34 2004-04-16 17:37:32

matias
Member
Registered: 2004-04-11
Posts: 42

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

Allyn wrote:

I got as far as sh make.sh (finally, lol, kept screwing up) and now, when i try to run that command, i get:

[root@localhost build_mod]# sh make.sh
ATI module generator V 2.0
==========================
initializing...
probing for VMA API version...
check results are inconsistent!!!
none of the probed versions did succeed.
aborting module build.

what did I do wrong?  I'm using the latest kernel 2.6.3 (i think).  Any help would be appreciated

I get the same error ... using kernel 2.6.5 ... what can it be?

Offline

#35 2004-04-20 22:12:44

thryllkill
Member
From: Guam
Registered: 2004-04-20
Posts: 5

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

jskier, I am getting that same error... did you ever figure it out?

Offline

#36 2004-04-21 19:40:28

matias
Member
Registered: 2004-04-11
Posts: 42

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

[root@fantasy build_mod]# cat make.log
ATI module generator V 2.0
==========================
initializing...
build_date =Wed Apr 21 16:45:58 ART 2004
uname -a =Linux fantasy 2.6.50 #2 SMP Wed Apr 21 10:49:10 ART 2004 i686 unknown unknown GNU/Linux
uname -s =Linux
uname -m =i686
uname -r =2.6.50
uname -v =#2 SMP Wed Apr 21 10:49:10 ART 2004
uid=0(root) gid=0(root) groups=0(root),102(sound)
.
drwxr-xr-x  107 root root 9064 Apr 21 16:36 /usr/include
.
total 5
drwxr-xr-x   2 root root  128 Apr 21 16:37 ATI
lrwxrwxrwx   1 root root   13 Apr 21 10:24 linux -> linux-2.6.50/
drwxr-xr-x  14 root root  384 Apr 15 15:03 linux-2.6.5
drwxrwxr-x  19  500  500 1216 Apr 21 10:19 linux-2.6.5-mep
drwxr-xr-x  19 root root 1216 Apr 21 10:49 linux-2.6.50
.
file /lib/modules/2.6.50/build/include/linux/agp_backend.h says: AGP=1
OsVersion says: SMP=1
file /proc/kallsyms says: SMP=1
file /lib/modules/2.6.50/build/include/linux/autoconf.h says: SMP=1
assuming default: MODVERSIONS=0
.
CC=gcc
cc_version=3.3.3
found major but not minor version match for gcc and the ip-library
ls -l libfglrx_ip.a
lrwxrwxrwx  1 root root 18 Apr 21 16:45 libfglrx_ip.a -> libfglrx_ip.a.GCC3
.
probing for VMA API version...
cc_ret_vma_240 = 1
cc_ret_vma_253 = 1
check results are inconsistent!!!
none of the probed versions did succeed.
aborting module build.
[root@fantasy build_mod]#

2.6.50 .. nice eh? :-).

Offline

#37 2004-04-22 06:48:48

thryllkill
Member
From: Guam
Registered: 2004-04-20
Posts: 5

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

2.6.50 .. nice eh?

huh?

Offline

#38 2004-04-22 11:54:48

thryllkill
Member
From: Guam
Registered: 2004-04-20
Posts: 5

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

problem solved. 

thanks to bogomipz from #archlinux for pointing me in the right direction

the problem was I copied and pasted the PKGBUILD to a notepad file in windows, and cp it over to my arch drive.  when I did it was being saved in a dos format.

if anyone else did that same thing, you need to do the following before 'makepkg -c'

pacman -Sy hd2u

when that gets done installing run

dos2unix PKGBUILD

then run 'makepkg -c' and it should work

Offline

#39 2004-04-22 13:57:19

matias
Member
Registered: 2004-04-11
Posts: 42

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

thryllkill wrote:

2.6.50 .. nice eh?

huh?

to avoid the new kernel override the old one (2.6.5).

Offline

#40 2004-04-22 14:04:48

matias
Member
Registered: 2004-04-11
Posts: 42

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

thryllkill wrote:

problem solved. 
thanks to bogomipz from #archlinux for pointing me in the right direction
the problem was I copied and pasted the PKGBUILD to a notepad file in windows, and cp it over to my arch drive.  when I did it was being saved in a dos format.
if anyone else did that same thing, you need to do the following before 'makepkg -c'
pacman -Sy hd2u
when that gets done installing run
dos2unix PKGBUILD
then run 'makepkg -c' and it should work

still doesn't work for me ... anyone could see my make.log to find the problem, please?.
Greetings.

Offline

#41 2004-05-02 14:17:01

beniro
Member
From: St. Petersburg, FL, USA
Registered: 2002-12-31
Posts: 312

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

You'll have to modify your PKGBUILD file to your specific machine. I couldn't get it to download the file, so I manually put it in the same dir. as PKGBUILD.

In my PKGBUILD file, I changed the pkgver field to match what I had downloaded and commented out the md5 field.  I then changed the source line to:

source=(fglrx-4.3.0-$pkgver.i386.rpm)

and changed the second instance of the rpm package name to match the file I had downloaded as well.

I hope this helps somebody save some time when getting this all installed.

Here's what my PKGBUILD file ended up like:

# Contributor: Manolis Tzanidakis <mtzanidakis@freemail.gr>
pkgname=ati-drivers
pkgver=3.7.6
pkgrel=1
pkgdesc="Proprietary (binary) drivers for ATI Radeon Cards."
url="www.ati.com/support/driver.html"
depends=('xfree86')
install="$pkgname.install"
source=(fglrx-4.3.0-3.7.6.i386.rpm)
#md5sums=('7dd12340a2b8525b3a9fa1f310e06141')
# build-time deps: rpmunpack, cpio, gzip

build() {
   cd $startdir/pkg
   rpmunpack < $startdir/src/fglrx-4.3.0-$pkgver.i386.rpm | gzip -d | cpio -idmuv
  chmod 755 -R .
  mv opt/kde3 opt/kde
  mkdir -p opt/gnome/share
  mv usr/share/gnome/apps/ opt/gnome/share
  rm -rf usr/share/gnome usr/share/applnk
    lib/modules/fglrx/{fglrx*.o,fglrx_info.txt}
    usr/X11R6/bin/LICENSE.{GPL,QPL}
    usr/X11R6/bin/*.bz2
}

Offline

#42 2004-05-02 14:39:40

beniro
Member
From: St. Petersburg, FL, USA
Registered: 2002-12-31
Posts: 312

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

tasslehoff:
When I put cpuid.patch in fglrx directory and from ./build_mod run:

patch firegl_public.c ../cpuid.patch

I get Hunk 1 failed at 3050.  I already applied the vmalloc and amd patched to firegl_public.c

Could someone tell me how to edit the file manually?

Thanks

Offline

#43 2004-05-17 03:50:13

franzfranz
Member
From: indiana
Registered: 2004-05-15
Posts: 13

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

same problem here, I finally got fgl_glxgears to run, but it's painfully slow.  any ideas?

Offline

#44 2004-05-19 19:21:48

vegai
Developer/TU
Registered: 2004-05-19
Posts: 41
Website

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

Xentac wrote:
darksides wrote:
   rm -rf usr/share/gnome usr/share/applnk /
  ...

Those need to be 's.  They escape the newline character to tell bash not to evaluate it as the end of a command.

Yes, the above without corrections will indeed try to remove root. Running rm -rf / is kinda dangerous, you know...

Offline

#45 2004-05-27 00:16:52

Mazaev
Member
Registered: 2004-05-25
Posts: 29
Website

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

Getting same error as above with kernel 2.6.6 and ati driver 3.2.8 and 3.9.0

anyone? :evil:

Offline

#46 2004-05-27 18:25:07

phunni
Member
From: Bristol, UK
Registered: 2003-08-13
Posts: 667

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

when I try and install the new package I get:

error: the following files confilcts were found:
    /usr/X11R6/libGL.so.1.2: exists in filesystem

any ideas how to get past this one?

Offline

#47 2004-05-29 03:57:03

thegnu
Member
From: Brooklyn, NY
Registered: 2004-05-04
Posts: 280
Website

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

[edited out question 1 on the grounds that it was stupid]

2.  does all this not work if on I compile the agpgart component into the kernel instead of as a module?

[edit]
3.  when I try to apply the cpuid patch after having applied the other two patches, it fails.  Should I manually remove the lines in the patch?

[/edit]

Thanks,
thegnu


fffft!

Offline

#48 2004-05-29 03:59:48

thegnu
Member
From: Brooklyn, NY
Registered: 2004-05-04
Posts: 280
Website

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

phunni:

I'm not sure this was a wise decision, but I ran:
pacman -Af ati-dri....

with the force option it seems it overwrites the file.


fffft!

Offline

#49 2004-06-07 07:21:30

phunni
Member
From: Bristol, UK
Registered: 2003-08-13
Posts: 667

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

OK - I have the package installed and both patches applie, but make_install.sh fails with the error:

version magic '2.6.3 preempt K7 gcc-3.4' should be '2.6.3 preeempt K7 gcc-3.3'
...
Invalid module format

I have kernel 2.6.3 and gcc 3.4 with a radeon 9800 pro

any suggestions?

Offline

#50 2004-06-08 08:40:22

phunni
Member
From: Bristol, UK
Registered: 2003-08-13
Posts: 667

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

Figured out my gcc problem - just recompiled the kernel with 3.4

Now, having installed the fglrx module I get an error when I try to start X telling me that fglrx could not be loaded (even though it already is...) because of a "module requirement mismatch"

Any ideas how I fix this?  I have agpgart, nvidia-agp, fglrx and rtc loaded at startup in that order...

Offline

Board footer

Powered by FluxBB