You are not logged in.

#1 2004-05-24 17:46:12

Aletheuo
Member
Registered: 2004-03-26
Posts: 59

Firefox 0.8 dns resolving is slow

On several different Arch Linux pc's I have I'm seeing Firefox resolve internet hosts very slowly.
I've made sure the loopback adapter is up and also added my hostname to the hosts file which neither seem to fix this issue.
I've only noticed this slowness when browsing with Firefox so I think it is a bug in Firefox.
Anyways on the Firefox BB I found this article and it mentions this very problem with running Firefox on OS's with IPv6 enabled, so my question is how can I "turn off" IPv6 in the kernel to see if this helps or not?

http://forums.mozillazine.org/viewtopic … ns+resolve

Arch Linux 0.6 / kernel 2.6.6-1

Thanks,
Craig


Arch Linux (Duke)
JabberID:  cgill27@jabber.org
IRC: Aletheuo
Registered Linux User #354975

Offline

#2 2004-05-24 18:36:04

Aletheuo
Member
Registered: 2004-03-26
Posts: 59

Re: Firefox 0.8 dns resolving is slow

I'll try your two suggestions but they did say in the mozilla forum post that the nightly build also exhibited the same problem.
I'll report back here if either fixes this.

Thanks!
Craig


Arch Linux (Duke)
JabberID:  cgill27@jabber.org
IRC: Aletheuo
Registered Linux User #354975

Offline

#3 2004-05-25 13:18:41

Aletheuo
Member
Registered: 2004-03-26
Posts: 59

Re: Firefox 0.8 dns resolving is slow

Here's a solution that was mentioned somewhere else and I at first thought it worked but I was wrong.  It was adding a couple of lines to your modprobe.conf file.
alias net-pf-10 off
alias ipv6 off

I'm learning as I go but it appears to be a problem with sites that do have an ipv6 address, it looks like Firefox tries to also resolve the AAAA records and can not do it, so there's the delay.
The solution maybe in the nightly builds of Firefox, going to exhaust that now.

Craig


Arch Linux (Duke)
JabberID:  cgill27@jabber.org
IRC: Aletheuo
Registered Linux User #354975

Offline

#4 2004-05-25 22:05:36

skparkes
Member
Registered: 2003-12-11
Posts: 52

Re: Firefox 0.8 dns resolving is slow

Yea, I'm having that same problem.  Haven't looked into fixing it, but definitely have that problem.

Odd thing is, only started acting up when I moved to using a cable modem.  Maybe a connection?

Later,

Isamoor

Offline

#5 2004-05-26 04:37:25

colnago
Member
From: Victoria, BC
Registered: 2004-03-25
Posts: 438

Re: Firefox 0.8 dns resolving is slow

If it is a few specific sites that you use a lot, put them in you hosts file and make sure it is earlier in the order line in host.conf.

Offline

#6 2004-05-28 08:32:56

ganlu
Member
From: ChongQing, China
Registered: 2004-01-04
Posts: 336

Re: Firefox 0.8 dns resolving is slow

A very simple solution is to try the new nightly build since 0526. before that day, gtk2+xft builds can't start up, a bug of firefox, nightly builds after 0526 has solved the bug, I am using 0526 official nightly build.

Offline

#7 2004-06-20 11:15:25

Spider.007
Member
Registered: 2004-06-20
Posts: 1,149
Website

Re: Firefox 0.8 dns resolving is slow

I can confirm this problem is caused by the IPv6 lookup performed by FireFox. My packetdump shows a 5 seconds delay while 'resolving a host'. sad This is solved in FireFox 0.9 by introducing a new preference (experimental package posted here)

FireFox 0.9 has a new pref (about:config) to disable these lookups. They cannot be disabled by putting hosts in your hostsfile. Disabling IPv6 didn't work here either...

Offline

#8 2004-06-21 01:39:02

skoal
Member
From: Frequent Flyer Underworld
Registered: 2004-03-23
Posts: 612
Website

Re: Firefox 0.8 dns resolving is slow

cgill27 wrote:

...how can I "turn off" IPv6 in the kernel to see if this helps or not?

I haven't experienced the same problem with Firefox 0.8, but maybe I'm just too old to tell the difference in speed.

Here's how you can turn off IPV6:

1. Find out your IPV6 address:

ifconfig eth0 |grep "inet6 addr:"

for example,

> ifconfig eth0 |grep "inet6 addr:"
> inet6 addr: fe80::2e0:18ff:fefc:6682/64 Scope:Link

2. Remove it for that interface:

> ifconfig [interface] del [addr/prefixlen]

for example,

> ifconfig eth0 del fe80::2e0:18ff:fefc:6682/64

* You'll have to stop/restart your network services to get the IPV6 back.

As far as I know, that should remove use of your IPV6 address.  However, some of the protocols might still mangle your IPV4 into IPV6 address anyway for outgoing packets.  But, that's all the info I gleaned from `man ifconfig'.

Offline

Board footer

Powered by FluxBB