You are not logged in.

#1 2004-05-30 02:21:53

fbidwell
Member
From: Atlanta, GA (USA)
Registered: 2004-05-09
Posts: 32

Segmentation Fault on system shutdown

When I shutdown the system.  (shutdown - h now).

During the shutdown sequence I see the following error messages

>>
deactivating LVM2 groups
/var/lock/lvm : mkdir failed : read_only file system
cdrom: open failed
devfs_mk_dir : invalid argument ./etc/rc.shutdown : line 75 : 874 Segmentation Fault /sbin/lvm vgchange --ignorelockingfailure -a n

Does anyone have any idea what the problem is?

I've recently did a pacman -Syu and had to back out the kdelib and kdemultimedia upgrades because of the kdeinit segfault.

I also pacmanned in xcdroast and arson. 

Thanks

Offline

#2 2004-05-30 07:14:55

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Segmentation Fault on system shutdown

lvm is logical volume manager...are you using logical volumes?
if not, then try compiling your kernel without support for it..since you dont need it if you are not using it...


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#3 2004-05-30 08:08:12

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: Segmentation Fault on system shutdown

I think there's a new part in rc.conf to disable lvm. Disable it there.


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#4 2004-05-30 09:29:18

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Segmentation Fault on system shutdown

or that.
:oops:


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#5 2004-05-30 18:23:25

fbidwell
Member
From: Atlanta, GA (USA)
Registered: 2004-05-09
Posts: 32

Re: Segmentation Fault on system shutdown

I'm not using LVM.  Do you know what to put in the rc.conf to disable it?

I used to always get the read_only file system error, but never the segmentation fault.  This started happening yesterday after a pacman -Syu.

Offline

#6 2004-05-30 20:15:43

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: Segmentation Fault on system shutdown

You need the latest initscripts. Look at rc.conf.pacnew There's an entry for LVM it looks like this:

.............
CONSOLEFONT=
USECOLOR="yes"

# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

#
# Networking
#
HOSTNAME="myhost".........

And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#7 2004-05-31 14:52:26

fbidwell
Member
From: Atlanta, GA (USA)
Registered: 2004-05-09
Posts: 32

Re: Segmentation Fault on system shutdown

I found the rc.conf.pacman new that you referred to.

The only line that seemed new was the LVM stuff, so I added it to my rc.conf and it fixed the problem.   big_smile  big_smile  Thanks

I have another question though.

When I upgraded my initscripts, how could I have known to look for the rc.conf.pacnew on my own?  I'd like to learn for when I pacman -Syu in the future.

Offline

#8 2004-05-31 16:02:17

Dusty
Schwag Merchant
From: Medicine Hat, Alberta, Canada
Registered: 2004-01-18
Posts: 5,986
Website

Re: Segmentation Fault on system shutdown

I believe that when you run pacman and it updates a config file it says "warnig <file.conf> saved as <file.conf.pacnew>"

You should check the new files in such cases to see whats changed.

Dusty

Offline

#9 2004-07-14 23:33:18

marin_linuxer
Member
From: San Rafael, CA U.S.A.
Registered: 2003-09-03
Posts: 111
Website

Re: Segmentation Fault on system shutdown

In response to the OP.  It seems that _if_ you are _not_ activating the LVM option in rc.conf, but the rc.shutdown script LVM2() detects the /sbin/lvm command, then it attempts to run the command, anyway.  The problem you had seems to be related to the fact that the LVM command, when first run, creates some devfs nodes(!?).  If you've never run the command before shutdown(after devfsd has been killed), then you get that error.

I'm gonna open a bug to request the LVM()'s in rc.shutdown eval the $USELVM in rc.conf before acting.

To answer anyone else's question about how to workaround this in meantime:  just run the following, once, before shutdown:

#lvm vgchange --ignorelockingfailure -a n

OR

pacman -R lvm lvm2


-- Linux!  Isn't it time?

Offline

#10 2004-07-15 18:23:37

apeiro
Daddy
From: Victoria, BC, Canada
Registered: 2002-08-12
Posts: 771
Website

Re: Segmentation Fault on system shutdown

this bug is fixed in initscripts 0.7.

Offline

Board footer

Powered by FluxBB