You are not logged in.

#1 2003-03-20 18:30:04

netkrash
Member
From: Viña del Mar, Chile.
Registered: 2003-03-19
Posts: 94

Be careful with depends!! (PHP & DB stuff)

I've installed PHP-4.3.1-3 that depends on DB-4.1 the problem is that my version of DB was 4.0 so pacman asume that there was no error.

RESULT: PHP won't start, neither apache.

Solution: Refresh package database, update DB...

Best Solution: be careful with depends inside the PKGBUILD of PHP and specify the version number of the required stuff.

greets!!,


GNU/Linux: Share & Enjoy!

Offline

#2 2003-03-20 22:25:02

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: Be careful with depends!! (PHP & DB stuff)

thanks for the post but in defence of the package maintainers for all trees it is not always the easiest to know exactly when specific versioned depends may be required or that a package is even a runtime depend.

i do try my best to be accurate with my depends as i am sure all maintainers do.


AKA uknowme

I am not your friend

Offline

#3 2003-03-21 16:31:08

netkrash
Member
From: Viña del Mar, Chile.
Registered: 2003-03-19
Posts: 94

Re: Be careful with depends!! (PHP & DB stuff)

yeah, i know that smile

But sometimes i've read the PKGBUILD and says something like gcc => 2.5 or something like that in the depends,..

That's what i'm talking about..

but all the mainteiners work is great..


GNU/Linux: Share & Enjoy!

Offline

#4 2003-03-21 18:05:32

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: Be careful with depends!! (PHP & DB stuff)

feel free to point out any such oldepends or missing depends. Xentac and myself take care of the unofficial and unstable tree and i know there are a few [packages that need the depends fixed or even any depends at all. i try to get to such packages when i can but if someone points them out they will be fixed much faster.:)


AKA uknowme

I am not your friend

Offline

#5 2003-03-21 20:11:09

netkrash
Member
From: Viña del Mar, Chile.
Registered: 2003-03-19
Posts: 94

Re: Be careful with depends!! (PHP & DB stuff)

smile rulz!!

btw i'm roberto carvajal, i email you about the depends in xawtv.. remember?

greets and keep up the good work.


GNU/Linux: Share & Enjoy!

Offline

#6 2003-03-21 21:52:16

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: Be careful with depends!! (PHP & DB stuff)

Rob!

thanks for the help and the kind words.

(the new xawtv should be up soon without alsa depends, ithink. if you could verify this i would be most greatful)


AKA uknowme

I am not your friend

Offline

#7 2003-03-22 01:52:07

netkrash
Member
From: Viña del Mar, Chile.
Registered: 2003-03-19
Posts: 94

Re: Be careful with depends!! (PHP & DB stuff)

no problem!!

i'm glad to use this distro and i want to colaborate in everything i can!

even when my english isn't that good!! smile


GNU/Linux: Share & Enjoy!

Offline

Board footer

Powered by FluxBB