You are not logged in.

#1 2004-05-31 18:15:25

xor
Member
From: Sweden
Registered: 2003-03-20
Posts: 71

Getting tired of mplayer package!

Hi.
A few times the mplayer package has been failing after pacman -Syu.
"mplayer: error while loading shared libraries: libXxf86dga.so.1: cannot open shared object file: No such file or directory"

To solve this you have to compile the package yourself, without the libXxf86dga.so.1, which not should be linked to at all.

See thread (redhat hehe) http://www.mail-archive.com/xpert@xfree … 11541.html


/xor

Offline

#2 2004-05-31 19:33:34

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: Getting tired of mplayer package!

xor wrote:

Hi.
A few times the mplayer package has been failing after pacman -Syu.
"mplayer: error while loading shared libraries: libXxf86dga.so.1: cannot open shared object file: No such file or directory"

To solve this you have to compile the package yourself, without the libXxf86dga.so.1, which not should be linked to at all.

See thread (redhat hehe) http://www.mail-archive.com/xpert@xfree … 11541.html


/xor

ok, then post a bug-report bugs.archlinux.org


The impossible missions are the only ones which succeed.

Offline

#3 2004-05-31 22:52:55

leejpar
Member
From: Texas, USA
Registered: 2004-05-28
Posts: 51
Website

Re: Getting tired of mplayer package!

On my system (Syu'd  "current") libXxf86dga.so.1 is included with in the "/usr/X11R6/lib" directory. I assume that this is included with Xfree86 4.4. Are you using XFree86 4.4. I had "all kinds" of problems when I tried to use XFree86 4.3 with "current".


Linux Registered User #337161
'It's free. It works. Duh.'" - Eric Harrison

Offline

#4 2004-06-01 06:33:41

xor
Member
From: Sweden
Registered: 2003-03-20
Posts: 71

Re: Getting tired of mplayer package!

I'll do post it as a bug.
Running Xfree86 4.3, current, problem has been since after 1.0pre3.2-1 package (which is running ok)

/xor

Offline

#5 2004-06-01 06:41:41

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: Getting tired of mplayer package!

update your xfree86 to 4.4
your bug report will probably be ignored
because you use an older version
do a pacman -Syu to keep everything up to date
for me mplayer runs fine without any problem

Offline

#6 2004-06-01 09:04:53

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

Re: Getting tired of mplayer package!

you can also upgrade to X.org Xserver [more libre]
add in your /etc/pacman.conf

[testing]
Server = ftp://ftp.archlinux.org/testing

and then
pacman -Rd xfree86
pacman -S x

have fun

Offline

#7 2004-06-01 19:48:08

xor
Member
From: Sweden
Registered: 2003-03-20
Posts: 71

Re: Getting tired of mplayer package!

Hmm, well!
I do not upgrade to 4.4 because of the ati fglrx driver, it doesn't work with 4.4 and who can live without quake arena ;-)
Maybe the new fglrx  release does play with 4.4, anyone?

/xor

Offline

#8 2004-06-01 20:14:26

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

Re: Getting tired of mplayer package!

ati works with X just do what I said.

Offline

#9 2004-06-05 13:59:01

xor
Member
From: Sweden
Registered: 2003-03-20
Posts: 71

Re: Getting tired of mplayer package!

Hehe.
Just don't do as I do, do as I say....
I'll give it a try.

Edited 060604
Got x installed, haven't tried ati drivers yet but xig Accelerated-X is running so just to play q3 for about 25 minutes is nice.
Major problem with mplayer and the lib is now gone :-)

Thanks!
/xor

Offline

Board footer

Powered by FluxBB