You are not logged in.

#1 2007-11-30 01:44:13

ilnux
Member
Registered: 2007-11-30
Posts: 10

firefox problem does not run

HI,

I used excellent beginners guide Wiki to install archlinux, then desktop, but everytime I run

pacman -S firefox

it seems to finish installing but when I try to use it by clicking on it on the desktop
it does not do anything. No message, it just does nothing. The only suggestion I have seen
elsewhere is to install a dependency (desktop-utils?) which I did try but it did not have
any noticeable effect.

I don't get it, please help!

p.s tried it with Gnome and KDE Desktop, on two different installs

Offline

#2 2007-11-30 01:56:34

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,395
Website

Re: firefox problem does not run

Have you rebooted since the install.  The install for one of the dependencies (mozilla-common ???) adds /opt/mozilla/bin to your path.   To see if it is there type "echo $PATH" and if not rebooting will fix the problem.

Online

#3 2007-11-30 02:43:08

somairotevoli
Member
Registered: 2006-05-23
Posts: 335

Re: firefox problem does not run

You shouldn't ever have to reboot(except for new kernel, but there's even ways around that). Just logout/login your user.

Offline

#4 2007-11-30 07:30:56

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,395
Website

Re: firefox problem does not run

Good point...  Rebooting is just so fast on Arch and I have trouble with autostarted applications in XFCE so I really never think about that.

Online

#5 2007-11-30 07:54:43

ndlarsen
Member
From: Denmark
Registered: 2005-11-02
Posts: 157

Re: firefox problem does not run

Try launching firefox from a terminal. The output might be an indication of what is wrong. Try posting it here too.


I made it long
as I lacked the time to make it short...

Offline

#6 2007-11-30 08:04:56

Hide
Member
From: Castalia
Registered: 2007-02-02
Posts: 368

Re: firefox problem does not run

try:
which firefox-bin
and then start it from that location, or copy that (the location) to the launcher in your DE.

i remember firefox having a different binary location last time I installed it wink

Last edited by Hide (2007-11-30 08:15:00)

Offline

#7 2007-11-30 10:17:08

rztka
Member
From: Czech Republic
Registered: 2006-03-10
Posts: 37

Re: firefox problem does not run

Same problem here after today pacman -Syu hmm. Here is the output from terminal:

[terezka@kamarad ~]$ /opt/mozilla/lib/firefox-2.0.0.10/firefox-bin
/opt/mozilla/lib/firefox-2.0.0.10/firefox-bin: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory

[root@kamarad terezka]# locate libmozjs
/opt/mozilla/lib/firefox-2.0.0.10/libmozjs.so
/opt/mozilla/lib/xulrunner-1.8.1.9/libmozjs.so

something to do with the recent pacman's problems to upgrade from -1 to -2 package? >> http://bugs.archlinux.org/task/8780 (pacman keeps asking to dowloand package and upgrade although I did it already)

Offline

#8 2007-11-30 17:07:03

ilnux
Member
Registered: 2007-11-30
Posts: 10

Re: firefox problem does not run

Thankyou everyone for your feedback, I used all your posts and now the problem is solved for me.

I don't know the specific step(s) I took that made it work but just for the record
here is what I did...

NB: I did this on a fresh install of arch linux (no previous attempts to install firefox)

As root user in terminal:

pacman -S firefox

to install package. Then I immediately rebooted my computer and once back in the
desktop I opened a terminal (as user) and entered

echo $PATH

to check that there was /opt/mozilla/bin. Then I entered

cd /opt/mozilla/bin

to change to that directory  and then entered

firefox

to launch from terminal. It did so with no problem and then I closed firefox browser and
tested the K Menu Launcher and it also worked. Great! Thanks again

Last edited by ilnux (2007-11-30 17:14:54)

Offline

#9 2007-12-01 06:57:23

rztka
Member
From: Czech Republic
Registered: 2006-03-10
Posts: 37

Re: firefox problem does not run

As for me, it's fixed now with the new -3 package. Hurray!

Offline

Board footer

Powered by FluxBB