You are not logged in.

#1 2007-12-02 16:08:55

Stalafin
Member
From: Berlin, Germany
Registered: 2007-10-26
Posts: 616

Fan noise level kills me - how to regulate fans using lm sensors?

I recently set up cpufrequtils using AMDs powernow-k8. Works awesomly - cpu frequency is at 1000 MHz right now.

Then I went and set up lm sensors. No flaws, runs.
But why won't my fans go off? This noise level kills me....

In my BIOS I set the (system) control temperature to be 50 deg C. I am running a passive cpu cooler. The system's temeparture is regulated entirely by system fans.

There would be no need to have the fans running right now. But still they run. Have a look at my sensors output:

[user@machine ~]$ sensors
k8temp-pci-00c3
Adapter: PCI adapter
Core0 Temp:  +34.0°C                                    
Core1 Temp:  +30.0°C                                    

w83627ehf-isa-0290
Adapter: ISA adapter
VCore:       +1.12 V  (min =  +0.00 V, max =  +1.74 V)   
in1:         +6.34 V  (min = +13.46 V, max = +10.08 V)   ALARM
AVCC:        +3.23 V  (min =  +4.02 V, max =  +3.06 V)   ALARM
3VCC:        +3.23 V  (min =  +3.82 V, max =  +4.08 V)   ALARM
in4:         +0.96 V  (min =  +2.04 V, max =  +1.27 V)   ALARM
in5:         +1.20 V  (min =  +2.04 V, max =  +1.02 V)   ALARM
in6:         +5.12 V  (min =  +6.53 V, max =  +6.12 V)   ALARM
VSB:         +3.22 V  (min =  +3.06 V, max =  +3.04 V)   ALARM
VBAT:        +2.93 V  (min =  +4.08 V, max =  +3.06 V)   ALARM
in9:         +1.74 V  (min =  +1.53 V, max =  +1.46 V)   ALARM
Case Fan:   1506 RPM  (min =  703 RPM, div = 16)
CPU Fan:       0 RPM  (min =  703 RPM, div = 128)  ALARM
Aux Fan:    1795 RPM  (min =  703 RPM, div = 16)
fan4:       1875 RPM  (min =  341 RPM, div = 16)
fan5:          0 RPM  (min = 3515 RPM, div = 128)  ALARM
Sys Temp:    +32.0°C  (high =  -3.0°C, hyst = -65.0°C)  ALARM  sensor = thermistor
CPU Temp:    +33.0°C  (high = +65.0°C, hyst = +60.0°C)  sensor = diode
AUX Temp:    +41.5°C  (high = +65.0°C, hyst = +60.0°C)  sensor = thermistor

Is there anything I can do for the Case Fan, and Fans Aux and 4 to at least approximate their min RPM?

Offline

#2 2007-12-02 16:23:16

jacko
Member
Registered: 2007-11-23
Posts: 840

Re: Fan noise level kills me - how to regulate fans using lm sensors?

double check the bios, I know my fan speeds are hard coded in the bios irregardless of software settings from the OS. I am almost positive your bios must support this for it to work.

Offline

#3 2007-12-02 16:25:05

jacko
Member
Registered: 2007-11-23
Posts: 840

Re: Fan noise level kills me - how to regulate fans using lm sensors?

CPU Fan:       0 RPM  (min =  703 RPM, div = 128)  ALARM

I dunno, but from the looks of it I'd say u have the computer setup wrong. It doesn't even recognize the fact that u have a cpu fan, how do you suppose it should regulate that fan?

Offline

#4 2007-12-02 16:39:29

Stalafin
Member
From: Berlin, Germany
Registered: 2007-10-26
Posts: 616

Re: Fan noise level kills me - how to regulate fans using lm sensors?

jacko wrote:

CPU Fan:       0 RPM  (min =  703 RPM, div = 128)  ALARM

I dunno, but from the looks of it I'd say u have the computer setup wrong. It doesn't even recognize the fact that u have a cpu fan, how do you suppose it should regulate that fan?

Did you read my post? Apparently not.

Offline

Board footer

Powered by FluxBB