You are not logged in.

#1 2004-06-10 23:16:29

tmadhavan
Member
From: Wales :D
Registered: 2004-03-26
Posts: 441

Problem with Perl5,Pacman, new KDE packages - help PLZ!

Lo all.

Just doing my routine pacman -Syu, getting a perl error (think I had it before similarly, can't remember) from pacman.

When I run pacman -Syu I get

checking package integrity... done.
loading package data... done.
checking for file conflicts...
error: the following file conflicts were found:
  /usr/lib/perl5/5.8.4/i686-linux-thread-multi/perllocal.pod: exists in filesystem

Think I need to clear the cache or something? Sure that's what I did last time. Tried pacman -s, no luck.

Do I need to downgrade perl or something? Hope someone can help, it's really annoying I can't stay up to date.

Thanks
Thom

Offline

#2 2004-06-10 23:27:24

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: Problem with Perl5,Pacman, new KDE packages - help PLZ!

i -Suyf 'ed it


The impossible missions are the only ones which succeed.

Offline

#3 2004-06-10 23:36:51

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: Problem with Perl5,Pacman, new KDE packages - help PLZ!

This is actually a bug and should be reported.  You need to know which package has that file though.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#4 2004-06-11 00:08:27

Martillo1
Member
From: My kabila in Lavapiés
Registered: 2004-02-20
Posts: 66

Re: Problem with Perl5,Pacman, new KDE packages - help PLZ!

another error upgrading kde:

[root@xxxx yyyy]# srcpac -Sb arts
error: unresolvable dependencies:
  kdelibs: requires arts=1.2.2

[root@xxxx yyyy]# srcpac -Sb kdelibs
error: unresolvable dependencies:
  kdeaccessibility: requires kdelibs=3.2.2
  kdegraphics: requires kdelibs=3.2.2
  kdemultimedia: requires kdelibs=3.2.2

Offline

#5 2004-06-11 04:07:07

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: Problem with Perl5,Pacman, new KDE packages - help PLZ!

You might want to try srcpac -Syb


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#6 2004-06-11 09:53:36

tmadhavan
Member
From: Wales :D
Registered: 2004-03-26
Posts: 441

Re: Problem with Perl5,Pacman, new KDE packages - help PLZ!

Argh confused.

dp you reckon a

pacman -Syuf 

will help?

Xentac I'll report it as soon as I can. How can I find out which package has this file? Some sort of dependency check or something?

Thanks for the quick replies, not sure how to fix it though really.

Thom

Offline

#7 2004-06-12 09:03:32

tmadhavan
Member
From: Wales :D
Registered: 2004-03-26
Posts: 441

Re: Problem with Perl5,Pacman, new KDE packages - help PLZ!

Did a

pacman -Syuf

and that seemed to work, only I lost my settings for the KDE login screen for some reason, different login image etc etc. Nothing too annoying though as far as I know.

Thanks,
T.

Offline

#8 2004-06-12 11:45:28

cmf
Member
Registered: 2003-10-18
Posts: 86

Re: Problem with Perl5,Pacman, new KDE packages - help PLZ!

A few people mentioned this on IRC, we couldn't find what owned that file, but it seems from anotehr post to e spam assain, no idea why KDE is trying to write there, does anyone know which specific KDE pkg it is?

but yeah, it seems just forcing it works...

Offline

#9 2004-06-12 16:07:41

cmf
Member
Registered: 2003-10-18
Posts: 86

Re: Problem with Perl5,Pacman, new KDE packages - help PLZ!

yeah, i'll look into it, i don't use anything with perl modules afaik, (not a perl person though, so what do i know tongue) but i'll check his PKGBUILDs and see what's what.

Thanks
Lou

Offline

#10 2004-06-12 16:54:53

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: Problem with Perl5,Pacman, new KDE packages - help PLZ!

yes all perllocal.pod's should be removed


AKA uknowme

I am not your friend

Offline

Board footer

Powered by FluxBB