You are not logged in.

#1 2007-12-13 01:39:05

fernux
Member
Registered: 2007-06-03
Posts: 31

[solved]Display start at 1280*1024 @75 hz but i ned it to be @85hz

I have tried to run in root, nvidia-settings and saved to xorg.conf but  it always start att 75 hz.
So how to make  my desktop start at 1280*1024 85 Hz?
Her is my xorg.conf:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/lib/X11/rgb"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "se
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "PHILIPS 109P4"
    HorizSync       30.0 - 111.0
    VertRefresh     50.0 - 160.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7600 GS"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "1280x1024_85 +0+0; 1280x1024 +0+0; 1024x768 +0+0; 800x600 +0+0; 640x480 +0+0; 1280x102$
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Last edited by fernux (2007-12-13 07:12:59)

Offline

#2 2007-12-13 03:07:26

orv
Member
Registered: 2007-12-13
Posts: 11

Re: [solved]Display start at 1280*1024 @75 hz but i ned it to be @85hz

Is your Horizontal and Vertical hz settings correct? As far as I can tell, your xorg.conf looks ok.

Offline

#3 2007-12-13 03:13:59

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: [solved]Display start at 1280*1024 @75 hz but i ned it to be @85hz

Some users find the insertion of a preferred mode in monitor is a solution.


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Online

#4 2007-12-13 04:07:15

fernux
Member
Registered: 2007-06-03
Posts: 31

Re: [solved]Display start at 1280*1024 @75 hz but i ned it to be @85hz

I have tried to insert :
Modeline "1280x1024_85.00"  159.36  1280 1376 1512 1744  1024 1025 1028 1075
Option "PreferredMode" "1280x1024_85.00"

that i found in http://wiki.debian.org/XStrikeForce/HowToRandR12  for an solution

but it also fails.perhaps i have to wait for an update nvidia driver or xorg driver.

My Horizontal and Vertical  are correct, i have check it in my manual for philips brilliance 109 p4  crt

thanks for your replay

I also reconfigured xorg whit xorgconfig instead of nvidia-settings and modified as above, same error.

Last edited by fernux (2007-12-13 04:17:01)

Offline

#5 2007-12-13 04:28:15

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: [solved]Display start at 1280*1024 @75 hz but i ned it to be @85hz

Perhaps you will find that using .....CTL ALT +/-.... will enable your system to find the 85HZ mode.

Also, if using kde, the Krandrtray can be opened to allow you to select 85HZ in that tray right click menu.

Then set the config in KDE to start in that mode....


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Online

#6 2007-12-13 04:38:24

fernux
Member
Registered: 2007-06-03
Posts: 31

Re: [solved]Display start at 1280*1024 @75 hz but i ned it to be @85hz

yes  ctrl alt + changes the desktop to 85 hz easier than trough  nvidia settings. thanks for that tip
But i use gnome and in "screen resolution" tab shows 1280*1024 but can only set 56 hz.

Offline

#7 2007-12-13 04:44:50

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: [solved]Display start at 1280*1024 @75 hz but i ned it to be @85hz

Perhaps gnome is the culprit!


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Online

#8 2007-12-13 05:01:32

fwojciec
Member
Registered: 2007-05-20
Posts: 1,411

Re: [solved]Display start at 1280*1024 @75 hz but i ned it to be @85hz

fernux wrote:

yes  ctrl alt + changes the desktop to 85 hz easier than trough  nvidia settings. thanks for that tip
But i use gnome and in "screen resolution" tab shows 1280*1024 but can only set 56 hz.

The "56" figure is how nvidia driver handles refresh frequency reporting (this has something to do with Twinview setups) - it's a meaningless number from the users's perspective, it doesn't reflect the actual refresh frequency.   If you want to have the actual frequency reported in gnome you have to add

Option "DynamicTwinView" "false"

to the device section  in xorg.conf.  If you want to read more about this read this doc (the relevant info is towards the end.  http://us.download.nvidia.com/XFree86/L … dix-d.html

Not sure how to force 85Hz in your case.  I have a twinview setup and I have the following line in the device section of xorg.conf:

Option        "Metamodes"                 "CRT-0: 1280x1024_75, DFP-0: 1280x1024_75"

The refresh rates for my monitors respond to what is specified in this line...

Offline

#9 2007-12-13 07:11:33

fernux
Member
Registered: 2007-06-03
Posts: 31

Re: [solved]Display start at 1280*1024 @75 hz but i ned it to be @85hz

Thanks! the line [Option "DynamicTwinView" "false" ]  solved it.
i tested your other line to but  the line above alone solves it.

Now i can set  both resolution and refresh rate in gnome.
And 1280*1024 85 hz works now.

Last edited by fernux (2007-12-13 07:14:19)

Offline

Board footer

Powered by FluxBB