You are not logged in.

#1 2007-12-12 21:47:20

thiago907
Member
From: Brazil, Fortaleza
Registered: 2007-09-25
Posts: 28

urxvt / irssi problem

guys... how can i solve this?

Can't locate utf8.pm in @INC (@INC contains: /usr/lib/urxvt /usr/lib/perl5/5.8.8/i686-linux-thread-multi /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at /usr/lib/urxvt/urxvt.pm line 687.
BEGIN failed--compilation aborted at /usr/lib/urxvt/urxvt.pm line 687.
Compilation failed in require at -e line 1.
BEGIN failed--compilation aborted at -e line 1.
urxvt: unable to initialize perl-interpreter, continuing without.

everytime i start urxvt/irssi this show up ... already try to re-re-install perl

Last edited by thiago907 (2007-12-12 21:48:12)

Offline

#2 2007-12-13 00:39:05

bender02
Member
From: Germany
Registered: 2007-02-04
Posts: 1,328

Re: urxvt / irssi problem

Well, I don't know how to solve this, but: my urxvt and irssi work fine. utf8.pl is in /usr/lib/perl5/current/utf8.pl and ls -la /usr/lib/perl5 gives

drwxr-xr-x   4 root root    96 2007-10-25 12:53 .
drwxr-xr-x 153 root root 40960 2007-12-12 00:52 ..
lrwxrwxrwx   1 root root     7 2007-10-25 12:11 5.8.0 -> current
lrwxrwxrwx   1 root root     7 2007-10-25 12:11 5.8.1 -> current
lrwxrwxrwx   1 root root     7 2007-10-25 12:11 5.8.2 -> current
lrwxrwxrwx   1 root root     7 2007-10-25 12:11 5.8.3 -> current
lrwxrwxrwx   1 root root     7 2007-10-25 12:11 5.8.4 -> current
lrwxrwxrwx   1 root root     7 2007-10-25 12:11 5.8.5 -> current
lrwxrwxrwx   1 root root     7 2007-10-25 12:11 5.8.6 -> current
lrwxrwxrwx   1 root root     7 2007-10-25 12:11 5.8.7 -> current
lrwxrwxrwx   1 root root     7 2007-10-25 12:11 5.8.8 -> current
drwxr-xr-x  43 root root  4096 2007-11-08 17:04 current
drwxr-xr-x   3 root root    88 2007-10-25 12:53 site_perl

So maybe the trouble is the missing symlinks in your case?

Last edited by bender02 (2007-12-13 00:39:27)

Offline

#3 2007-12-13 01:17:00

dolby
Member
From: 1992
Registered: 2006-08-08
Posts: 1,581

Re: urxvt / irssi problem

install perl again. pacman -Sy perl

oh, u already did. sorry dont know then. maybe do what the guy wjo answered above me says tongue

Last edited by dolby (2007-12-13 01:17:52)


There shouldn't be any reason to learn more editor types than emacs or vi -- mg (1)
[You learn that sarcasm does not often work well in international forums.  That is why we avoid it. -- ewaller (arch linux forum moderator)

Offline

#4 2007-12-13 04:08:51

thiago907
Member
From: Brazil, Fortaleza
Registered: 2007-09-25
Posts: 28

Re: urxvt / irssi problem

bender02 wrote:

Well, I don't know how to solve this, but: my urxvt and irssi work fine. utf8.pl is in /usr/lib/perl5/current/utf8.pl and ls -la /usr/lib/perl5 gives

drwxr-xr-x   4 root root    96 2007-10-25 12:53 .
drwxr-xr-x 153 root root 40960 2007-12-12 00:52 ..
lrwxrwxrwx   1 root root     7 2007-10-25 12:11 5.8.0 -> current
lrwxrwxrwx   1 root root     7 2007-10-25 12:11 5.8.1 -> current
lrwxrwxrwx   1 root root     7 2007-10-25 12:11 5.8.2 -> current
lrwxrwxrwx   1 root root     7 2007-10-25 12:11 5.8.3 -> current
lrwxrwxrwx   1 root root     7 2007-10-25 12:11 5.8.4 -> current
lrwxrwxrwx   1 root root     7 2007-10-25 12:11 5.8.5 -> current
lrwxrwxrwx   1 root root     7 2007-10-25 12:11 5.8.6 -> current
lrwxrwxrwx   1 root root     7 2007-10-25 12:11 5.8.7 -> current
lrwxrwxrwx   1 root root     7 2007-10-25 12:11 5.8.8 -> current
drwxr-xr-x  43 root root  4096 2007-11-08 17:04 current
drwxr-xr-x   3 root root    88 2007-10-25 12:53 site_perl

So maybe the trouble is the missing symlinks in your case?

dont think so... here is mine:

drwxr-xr-x  5 root root  4096 2007-12-12 17:31 .
drwxr-xr-x 63 root root 12288 2007-12-12 17:29 ..
lrwxrwxrwx  1 root root     7 2007-12-10 20:07 5.8.0 -> current
lrwxrwxrwx  1 root root     7 2007-12-10 20:07 5.8.1 -> current
lrwxrwxrwx  1 root root     7 2007-12-10 20:07 5.8.2 -> current
lrwxrwxrwx  1 root root     7 2007-12-10 20:07 5.8.3 -> current
lrwxrwxrwx  1 root root     7 2007-12-10 20:07 5.8.4 -> current
lrwxrwxrwx  1 root root     7 2007-12-10 20:07 5.8.5 -> current
lrwxrwxrwx  1 root root     7 2007-12-10 20:07 5.8.6 -> current
lrwxrwxrwx  1 root root     7 2007-12-10 20:07 5.8.7 -> current
lrwxrwxrwx  1 root root     7 2007-12-10 20:07 5.8.8 -> current
drwxr-xr-x 21 root root  4096 2007-11-30 19:20 core_perl
drwxr-xr-x  2 root root     1 2007-12-13 00:21 current
drwxr-xr-x  6 root root  4096 2007-12-13 00:50 site_perl

Offline

#5 2007-12-13 04:24:50

rson451
Member
From: Annapolis, MD USA
Registered: 2007-04-15
Posts: 1,233
Website

Re: urxvt / irssi problem

i dont know that this is the deal, but his current is 4096 bytes, yours is 1. maybe the links should point to core_perl rather than current for you? mine looks almost exactly as his does and i have no problems.  also, i686 or x64 and are you using the testing repo?


archlinux - please read this and this — twice — then ask questions.
--
http://rsontech.net | http://github.com/rson

Offline

#6 2007-12-13 07:55:59

nesrecar
Member
From: Germany/Munich
Registered: 2004-06-06
Posts: 79

Re: urxvt / irssi problem

_Maybe_ it's a bug in the perl package. I had a similar issue with frozen-bubble. A new pkgrel of perl did the fix.


Public Key 0x24685E35 available from any key server you trust.

IRC: ssimon/Nesrecar

Offline

#7 2007-12-13 14:41:49

bender02
Member
From: Germany
Registered: 2007-02-04
Posts: 1,328

Re: urxvt / irssi problem

For the record, I run perl-5.8.8-9, which is in the core repo, on x86_64 (the arch should not matter though...).

Offline

#8 2007-12-13 14:49:17

thiago907
Member
From: Brazil, Fortaleza
Registered: 2007-09-25
Posts: 28

Re: urxvt / irssi problem

bender02 wrote:

For the record, I run perl-5.8.8-9, which is in the core repo, on x86_64 (the arch should not matter though...).

downgrade perl to 5.8.8-9 did the trick ... thanks smile tongue

and yes i was using testing repo (perl 5.8.8-10)

Offline

#9 2007-12-13 19:19:17

shining
Pacman Developer
Registered: 2006-05-10
Posts: 2,043

Re: urxvt / irssi problem


pacman roulette : pacman -S $(pacman -Slq | LANG=C sort -R | head -n $((RANDOM % 10)))

Offline

Board footer

Powered by FluxBB