You are not logged in.

#1 2007-12-17 14:23:32

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Automount in KDE/Gnome/Xfce doesn't work anymore

Hi guys,
KDE/Gnome/Xfce all fail to automount my pen drives/removable disk. This was working fine till about a week ago. I tried the preferences.fdi stuff in the wiki page, but that didnt help. CD automounting works fine though (although auto unmounting doesnt, and I have to right click on the cd and select 'eject'). Initially I thought its because I'm using KDEMod, but that cant be it cause no updates were made to kdemod recently, and kdemod is no reason for gnome and xfce to break either.

Thanks,
Varun

Offline

#2 2007-12-17 15:32:48

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,745

Re: Automount in KDE/Gnome/Xfce doesn't work anymore

emmm check lsusb for devices and dmesg see if they are loading make sure your in the right groups [worth a look!] everything is working fine here....


Mr Green

Offline

#3 2007-12-17 19:44:10

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: Automount in KDE/Gnome/Xfce doesn't work anymore

lsusb and dmesg dont show anything abnormal... Doesn't work for different users, doesn't work for root. Do you have the preferences file in /etc/hal ? , or is it just default?

Offline

#4 2007-12-18 14:06:54

mianka
Member
From: BE LEUVEN
Registered: 2006-05-30
Posts: 208

Re: Automount in KDE/Gnome/Xfce doesn't work anymore

Something seems to have gone wrong in one of the last updates.On my machines (3) ,when inserting a cd nothing shows up on the kde-desktop anymore,alsa also broken.

Offline

#5 2007-12-18 19:26:53

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: Automount in KDE/Gnome/Xfce doesn't work anymore

alsa may be broken because of the kernel in testing right now. Try downgrading to the previous kernel and you should be fine.

Offline

#6 2007-12-19 06:41:51

nobody_there
Member
Registered: 2007-12-19
Posts: 2

Re: Automount in KDE/Gnome/Xfce doesn't work anymore

I had the same problem after updating my system 2 days ago. But the wiki entry helped a lot:

If you are experiencing problems with automounting usb sticks and/or drives, but do not have problems with automounting CDs or DVDs, and if you are able to manually mount the USB device in question, then you should create the file "preferences.fdi" in the folder /etc/hal/fdi/policy and paste the following line into the file
<merge key="volume.ignore" type="bool">false</merge>

I think, that was fixed some time ago ('cause until I updated, everything worked alright), but now it's broken again. I may be mistaken though, but that fix worked in my case smile

Offline

#7 2007-12-19 14:13:32

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: Automount in KDE/Gnome/Xfce doesn't work anymore

Hmm, I tried that earlier and it didn't work.. and it worked now tongue To anyone else having this problem, also make sure your user is a member of 'dbus' and 'hal' groups.... Thanks for the tip smile

Offline

#8 2007-12-24 18:00:17

pelle.k
Member
From: Åre, Sweden (EU)
Registered: 2006-04-30
Posts: 667

Re: Automount in KDE/Gnome/Xfce doesn't work anymore

I don't get that!? I've *never* been a member of udev nor hal group, in any installation of arch linux i've done, but i can still mount drives with gnome-volume-manager and konqueror...
I am a member of "storage" however.

I had some problems recently, however, when gparted decided to "leave" a hal policy because it crashed in the middle of an operation.

/usr/share/hal/fdi/policy/gparted-disable-automount.fdi

This shouldn't be there. So if you have it, you now know what the problem is...


"Your beliefs can be like fences that surround you.
You must first see them or you will not even realize that you are not free, simply because you will not see beyond the fences.
They will represent the boundaries of your experience."

SETH / Jane Roberts

Offline

#9 2008-01-06 20:47:17

randomguy
Member
Registered: 2007-06-19
Posts: 78

Re: Automount in KDE/Gnome/Xfce doesn't work anymore

pelle.k wrote:

I don't get that!? I've *never* been a member of udev nor hal group, in any installation of arch linux i've done, but i can still mount drives with gnome-volume-manager and konqueror...
I am a member of "storage" however.

I had some problems recently, however, when gparted decided to "leave" a hal policy because it crashed in the middle of an operation.

/usr/share/hal/fdi/policy/gparted-disable-automount.fdi

This shouldn't be there. So if you have it, you now know what the problem is...

Thanks, man ! gparted screwed up my policies too.

Offline

Board footer

Powered by FluxBB