You are not logged in.

#1 2008-01-14 23:22:40

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

e17 in community

I'm currently uploading e17-cvs to the [community] repo. Most likely this will replace the e17 snapshots which are currently in [community] as it is unknown when, or even if the snapshots on the e17 server will be updated. However for the moment the snapshots are still available in [community] and will remain so until further notice.

If you want to install e17-cvs from the [community] repo, please remove any version of e17 you have on your system before installing.
e17-cvs from [community] will install under the /usr prefix, whereas the snapshots in [community] are installed under the /opt/e17 prefix.
If you happen to use the takhis repo, it will not work nicely together with e17-cvs from [community] for the same reason as the snapshots. The same goes for a lot of e17-cvs packages in AUR, they should all be updated to be installed under the /usr prefix.

After you have removed all currently installed versions of any e17 package, install e17-cvs with

pacman -S e17-cvs

and for any additional modules currently supplied in [community], do

pacman -S e17-extra-cvs

You can start e17-cvs by adding 'enlightenment_start' to ~/.xinitrc, or using the e17 login manager entrance.
Using entrance is as simple as

adding 'entranced' to the daemons in /etc/rc.conf

or

modifying /etc/inittab to use: 
x:5:respawn:/usr/sbin/entranced -nodaemon >& /dev/null

Any questions or problems, just ask.

NOTE:
the e17 wiki page should be adjusted to include the above. I did put a few comments there but it should be rewritten partly to incorporate above changes.

[edit]
x86_64 versions are now also in [community]

Last edited by pressh (2008-01-23 09:37:53)

Offline

#2 2008-01-14 23:56:40

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: e17 in community

E17's development is happening in a hurry these days. How often do you intend to update?

Offline

#3 2008-01-15 00:06:16

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: e17 in community

at least twice a month. If development goes fast I should be able to update it on a weekly basis.

[edit]
that is at least for i686. I'll try to do my best for the x86_64 guys to keep it not far behind but I don't have a 64bit machine and I can't fly.

Last edited by pressh (2008-01-15 00:14:02)

Offline

#4 2008-01-15 00:26:46

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: e17 in community

That's great. Thanks.

Offline

#5 2008-01-15 04:00:47

aRcHaTe
Member
Registered: 2006-10-24
Posts: 644

Re: e17 in community

pressh will it be support on community for other packages for e17 like eclair? or any othersoftware for e17...

Last edited by sickhate (2008-01-15 04:01:11)


Its a sick world we live in....

Offline

#6 2008-01-15 08:44:28

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: e17 in community

I may support other e17 packages in the near future. At the moment I tested most of them and I did not put them into community as I considered them either too unstable or too future incomplete. If these apps become more mature feel free to contact me and ask for inclusion. I won't include apps which give a bad user experience though  (these apps should go into unsupported).
If you think I missed an important e17 app which currently is actively developed and in good shape, let me know and I'll test it.

Offline

#7 2008-01-15 08:45:17

furester
Member
From: italy
Registered: 2004-12-22
Posts: 25
Website

Re: e17 in community

I usully update my copy of e17 every day, this is a sort of regression but I think that it will help more people try e17, so I'm (quite) happy for this decision ..
But where is bling module gone? and all efm_* modules? I checked them out on 20080108 and they works! And we need bling to use itask!

Offline

#8 2008-01-15 09:35:02

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: e17 in community

furester wrote:

I usully update my copy of e17 every day, this is a sort of regression but I think that it will help more people try e17, so I'm (quite) happy for this decision ..

you can still do so if you want wink

furester wrote:

But where is bling module gone? and all efm_* modules? I checked them out on 20080108 and they works! And we need bling to use itask!

All additional modules are in e_modules-cvs I think

Offline

#9 2008-01-15 13:31:26

furester
Member
From: italy
Registered: 2004-12-22
Posts: 25
Website

Re: e17 in community

pressh wrote:
furester wrote:

But where is bling module gone? and all efm_* modules? I checked them out on 20080108 and they works! And we need bling to use itask!

All additional modules are in e_modules-cvs I think

Installing your package e17's module manager says that there isn't bling in modules dir and ask if i want to disable it .. reading the PKGBUILD I don't understand why it can't find bling modules: it seems to be compiled!

Offline

#10 2008-01-15 13:44:57

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: e17 in community

furester wrote:

Installing your package e17's module manager says that there isn't bling in modules dir and ask if i want to disable it .. reading the PKGBUILD I don't understand why it can't find bling modules: it seems to be compiled!

try removing the config files in your users home dir. Make sure to back them up first.

Offline

#11 2008-01-15 14:02:40

furester
Member
From: italy
Registered: 2004-12-22
Posts: 25
Website

Re: e17 in community

pressh wrote:
furester wrote:

Installing your package e17's module manager says that there isn't bling in modules dir and ask if i want to disable it .. reading the PKGBUILD I don't understand why it can't find bling modules: it seems to be compiled!

try removing the config files in your users home dir. Make sure to back them up first.

after removing ~/.e directory and reinstalling your package ..

$ enlightenment_remote -module-list | grep bling
$

or if you prefer

$ enlightenment_remote -module-list
REPLY <- BEGIN
REPLY: "start" ENABLED 1
REPLY: "ibar" ENABLED 1
REPLY: "ibox" ENABLED 1
REPLY: "dropshadow" ENABLED 1
REPLY: "clock" ENABLED 1
REPLY: "battery" ENABLED 1
REPLY: "cpufreq" ENABLED 1
REPLY: "temperature" ENABLED 1
REPLY: "pager" ENABLED 1
REPLY: "exebuf" ENABLED 1
REPLY: "winlist" ENABLED 1
REPLY: "conf" ENABLED 1
REPLY: "conf_applications" ENABLED 1
REPLY: "conf_borders" ENABLED 1
REPLY: "conf_clientlist" ENABLED 1
REPLY: "conf_colors" ENABLED 1
REPLY: "conf_desk" ENABLED 1
REPLY: "conf_desklock" ENABLED 1
REPLY: "conf_desks" ENABLED 1
REPLY: "conf_dialogs" ENABLED 1
REPLY: "conf_display" ENABLED 1
REPLY: "conf_dpms" ENABLED 1
REPLY: "conf_exebuf" ENABLED 1
REPLY: "conf_fonts" ENABLED 1
REPLY: "conf_icon_theme" ENABLED 1
REPLY: "conf_imc" ENABLED 1
REPLY: "conf_intl" ENABLED 1
REPLY: "conf_keybindings" ENABLED 1
REPLY: "conf_menus" ENABLED 1
REPLY: "conf_mime" ENABLED 1
REPLY: "conf_mouse" ENABLED 1
REPLY: "conf_mousebindings" ENABLED 1
REPLY: "conf_mouse_cursor" ENABLED 1
REPLY: "conf_paths" ENABLED 1
REPLY: "conf_performance" ENABLED 1
REPLY: "conf_profiles" ENABLED 1
REPLY: "conf_screensaver" ENABLED 1
REPLY: "conf_shelves" ENABLED 1
REPLY: "conf_startup" ENABLED 1
REPLY: "conf_theme" ENABLED 1
REPLY: "conf_transitions" ENABLED 1
REPLY: "conf_wallpaper" ENABLED 1
REPLY: "conf_window_display" ENABLED 1
REPLY: "conf_window_focus" ENABLED 1
REPLY: "conf_window_manipulation" ENABLED 1
REPLY: "conf_winlist" ENABLED 1
REPLY: "conf_engine" ENABLED 1
REPLY: "fileman" ENABLED 1
REPLY <- END

Offline

#12 2008-01-15 14:16:02

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: e17 in community

I have the same output when I do not load the module.
after I load the module via the menu (configuration->modules->load bling) it shows up.
On your machine bling does not show up in the modules configuration dialog ?

Offline

#13 2008-01-15 15:11:53

aRcHaTe
Member
Registered: 2006-10-24
Posts: 644

Re: e17 in community

pressh wrote:

I may support other e17 packages in the near future. At the moment I tested most of them and I did not put them into community as I considered them either too unstable or too future incomplete. If these apps become more mature feel free to contact me and ask for inclusion. I won't include apps which give a bad user experience though  (these apps should go into unsupported).
If you think I missed an important e17 app which currently is actively developed and in good shape, let me know and I'll test it.

i understand...by the way ive tryed entropy i like it more then the one by default on e17...its working great for me big_smile made a few changes on the PKGBUILD and puff

ps: bling is working great

Last edited by sickhate (2008-01-15 15:13:52)


Its a sick world we live in....

Offline

#14 2008-01-15 15:22:34

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: e17 in community

sickhate wrote:

i understand...by the way ive tryed entropy i like it more then the one by default on e17...its working great for me big_smile made a few changes on the PKGBUILD and puff
ps: bling is working great

The reason I did not include entropy was because of entropy was hanging. I'll rebuild evfs and entropy and give it another try.

[edit]
I still have the problem. Can you try my packages for evfs-cvs and entropy-cvs from here and report ? packages and PKGBUILDs for both are included in the archive.

Last edited by pressh (2008-01-15 16:07:47)

Offline

#15 2008-01-15 21:18:02

bimbo
Member
Registered: 2005-08-12
Posts: 20

Re: e17 in community

Where can I download the PKGBUILDs to build on arch64? they are not in AUR

Offline

#16 2008-01-15 21:44:50

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: e17 in community

bimbo wrote:

Where can I download the PKGBUILDs to build on arch64? they are not in AUR

You can get the PKGBUILDs via ABS, though I imagine it would be a bit hard to figure out in which order you have to build them.
I need to rewrite my scripts to get the PKGBUILDs from ABS instead of the local ones, but this will take some time as I'm also busy trying to get it build on a 64bit build machine (sorry it is taking a bit longer as the chroot is cleaned up after every build and this gives problems with the deps between the packages as I have to upload them to community and wait for the build machine to sync. I can't yet promise a timeframe for the x86_64 packages to appear in community).

As a temporary solution I can offer you my current build scripts until I have rewritten them to make use of ABS. If you want to use them, send me an e-mail.
The rewritten buildscripts I will put on a server (it can take a couple of days though) at least until x86_64 is supported as should. Sorry I just don't have a 64bit machine atm but I'm trying my best for you guys!

Offline

#17 2008-01-15 22:55:50

bimbo
Member
Registered: 2005-08-12
Posts: 20

Re: e17 in community

My mistake, when I said AUR I meant ABS, they don't appear to be included in the "community" folder under /var/abs/.

It'll be good to have your build scripts. Also if you know how I can access the ABS tree for i686 it'll be even better.

Offline

#18 2008-01-15 23:43:35

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: e17 in community

bimbo wrote:

My mistake, when I said AUR I meant ABS, they don't appear to be included in the "community" folder under /var/abs/.

It'll be good to have your build scripts. Also if you know how I can access the ABS tree for i686 it'll be even better.

sorry they don't appear on i686 ABS either, though they are on the webinterface. Something must have gone wrong somewhere... I'll add them again tomorrow morning (need to get some sleep now). I'll also contact you for the scripts.

[edit]
sorry my mistake they are in the i686 ABS tray. I think you cannot find it in the x86_64 ABS tray because it is only tagged CURRENT, whereas I suppose x86_64 shows only pacakages tagged with CURRENT-64. The ABS config files are in /etc/abs/ if you are sure you want to play with it.

Last edited by pressh (2008-01-16 09:50:43)

Offline

#19 2008-01-16 02:23:08

aRcHaTe
Member
Registered: 2006-10-24
Posts: 644

Re: e17 in community

pressh wrote:
sickhate wrote:

i understand...by the way ive tryed entropy i like it more then the one by default on e17...its working great for me big_smile made a few changes on the PKGBUILD and puff
ps: bling is working great

The reason I did not include entropy was because of entropy was hanging. I'll rebuild evfs and entropy and give it another try.

[edit]
I still have the problem. Can you try my packages for evfs-cvs and entropy-cvs from here and report ? packages and PKGBUILDs for both are included in the archive.

pressh ive tested then..and they work great...it dos not hang on my system...needs only a ".desktop"


Its a sick world we live in....

Offline

#20 2008-01-16 12:06:44

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: e17 in community

sickhate wrote:
pressh wrote:
sickhate wrote:

i understand...by the way ive tryed entropy i like it more then the one by default on e17...its working great for me big_smile made a few changes on the PKGBUILD and puff
ps: bling is working great

The reason I did not include entropy was because of entropy was hanging. I'll rebuild evfs and entropy and give it another try.

[edit]
I still have the problem. Can you try my packages for evfs-cvs and entropy-cvs from here and report ? packages and PKGBUILDs for both are included in the archive.

pressh ive tested then..and they work great...it dos not hang on my system...needs only a ".desktop"

can you provide me with the complete output of 'ps aux' both when entropy is running, and one after which you just closed entropy (use pastbin.archlinux.org)

Offline

#21 2008-01-16 12:21:21

X/ax
Member
From: Oost vlaanderen, Belgium
Registered: 2008-01-13
Posts: 275
Website

Re: e17 in community

I installed e17-cvs (and extras), they work just fine, but it's my opinion that enlightenment still needs some time...
I'm very excited about it though, and therefore thanks for updating the cvs for us, I'll follow it up very closely!!


My coding blog (or an attempt at it)
Archer start page (or an attempt at it)

Offline

#22 2008-01-16 14:35:59

aRcHaTe
Member
Registered: 2006-10-24
Posts: 644

Re: e17 in community

pressh wrote:
sickhate wrote:
pressh wrote:

The reason I did not include entropy was because of entropy was hanging. I'll rebuild evfs and entropy and give it another try.

[edit]
I still have the problem. Can you try my packages for evfs-cvs and entropy-cvs from here and report ? packages and PKGBUILDs for both are included in the archive.

pressh ive tested then..and they work great...it dos not hang on my system...needs only a ".desktop"

can you provide me with the complete output of 'ps aux' both when entropy is running, and one after which you just closed entropy (use pastbin.archlinux.org)

ok no problm ill send you as soon as i can big_smile


Its a sick world we live in....

Offline

#23 2008-01-16 19:54:44

aRcHaTe
Member
Registered: 2006-10-24
Posts: 644

Re: e17 in community

pressh wrote:
sickhate wrote:
pressh wrote:

The reason I did not include entropy was because of entropy was hanging. I'll rebuild evfs and entropy and give it another try.

[edit]
I still have the problem. Can you try my packages for evfs-cvs and entropy-cvs from here and report ? packages and PKGBUILDs for both are included in the archive.

pressh ive tested then..and they work great...it dos not hang on my system...needs only a ".desktop"

can you provide me with the complete output of 'ps aux' both when entropy is running, and one after which you just closed entropy (use pastbin.archlinux.org)

http://pastebin.archlinux.org/24108

hope it helps...


Its a sick world we live in....

Offline

#24 2008-01-18 12:40:39

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: e17 in community

sickhate wrote:

just a note to let you know that I'm looking for a solution but have not found it yet.

Offline

#25 2008-01-18 12:57:54

reverie
Member
From: Denmark
Registered: 2006-03-02
Posts: 59
Website

Re: e17 in community

Updated takhis repo for both i686 and x86_64, should remove conflicts and give a smooth upgrade to community for those still using takhis repo. After an upgrade you can safely remove takhis from pacman.conf and /opt/e17 should be gone. You can also remove the "e_deprecated" package, which was just there to give a smooth transaction. Note, if an old version of imlib2-cvs is still lingering on your system, you also need to manually replace it:

pacman -Rd imlib2-cvs e_deprecated
pacman -S imlib2

Edit: x86_64 now in line

Last edited by reverie (2008-01-22 17:44:20)

Offline

Board footer

Powered by FluxBB