You are not logged in.

#1 2004-06-21 15:57:37

infernova
Member
Registered: 2004-04-09
Posts: 61

mounting audio CD?

I have a problem mounting audio CD when using mount command, the return error is as follows:

mount: wrong fs type, bad option, bad superblock on /dev/cdroms/cdrom0, or too many mounted file systems

just so y'all know, my fstab has been configured as iso9660. I can mount any CD except audio CD, and DVD.

does anyone know the workaround to this problem?

much thanks ahead!

Offline

#2 2004-06-21 16:15:29

robot5x
Member
Registered: 2004-01-26
Posts: 266

Re: mounting audio CD?

You can't mount audio cd's, I'm afraid....there is no support for the filesystem that audio cds use (redbook?). If you're ripping them they still don't need to be mounted...to mount DVD you'll need to change your ftsab entry, or make another one - they mostly use udf as far as I know.
There's loads of good docs at tldp.org that explain all this.

Offline

#3 2004-06-21 17:05:23

Dusty
Schwag Merchant
From: Medicine Hat, Alberta, Canada
Registered: 2004-01-18
Posts: 5,986
Website

Re: mounting audio CD?

or use mount -t fstype instead of altering fstab if you mostly just want to mount iso9660

Offline

#4 2004-06-21 17:24:50

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,444

Re: mounting audio CD?

infernova wrote:

I have a problem mounting audio CD when using mount command

Sounds like you used to use BeOS for a time smile
Hey, don't moch, I loved it while it was a Be Inc thing.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#5 2004-06-22 02:32:42

luke
Member
From: US
Registered: 2004-06-22
Posts: 54

Re: mounting audio CD?

I just went through this so I'll tell you what I did.

I used xmms.  Open up xmms and Press Ctrl+P to open up the preferences dialogue.  Click on the CD Player Plug-In and then click on the Configure button.  Enter the info into the Device text (for me it was /dev/cdroms/cdrom0) and in the Directory (for me it was /mnt/cd).  If you haven't yet you will need to create the folder in /mnt/ (mkdir /mnt/cd).  After all of that.  Close xmms and open the CDRom drive.  Put in an audio cd. close the drive.  Open up xmms and then push play.  The "Play Files" dialogue open up.  Browse to /mnt/cd and choose the tracks. Press play.

Hope that helps

Offline

#6 2004-06-22 15:31:19

infernova
Member
Registered: 2004-04-09
Posts: 61

Re: mounting audio CD?

hey luke!, thanks for the advice, it works!

unfortunately, the sound is too soft, and eventhough i have max-ed out the volume, the music is still too soft. any particular output lib we should use? i'm currently using arts output to playback all the mp3 format.

thanks again!

Offline

#7 2004-06-22 15:35:19

luke
Member
From: US
Registered: 2004-06-22
Posts: 54

Re: mounting audio CD?

Sorry, can't help you there, as I am useing alsa as well.  You could check your settings for alsa and make sure that all the volumns are up.  Try "alsamixer" from a terminal.

That's all I know.

Offline

#8 2004-06-22 16:50:42

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: mounting audio CD?

did you bump up your "cd" (volume) output with a mixer?

note this is not the same as raising the volume in an application itself.


AKA uknowme

I am not your friend

Offline

Board footer

Powered by FluxBB