You are not logged in.

#26 2004-06-24 13:29:10

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: no luck with epson usb scanner [solved]

me searched a little on the web:

http://lists.alioth.debian.org/pipermai … 10301.html
http://lists.freebsd.org/pipermail/free … 02498.html

hmm ... seems to be an epson-known-trouble-with-2.6-libusb sad

i would contact sane developers or/and author of epson backend


The impossible missions are the only ones which succeed.

Offline

#27 2004-06-24 15:23:01

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,756

Re: no luck with epson usb scanner [solved]

looking at man sane-epson

your scanner is shown as scsi....

maybe you could try a different config....from a similar scanner...

HTH

Mr Green


Mr Green

Offline

#28 2004-06-24 15:34:09

blabla
Member
Registered: 2004-06-22
Posts: 39

Re: no luck with epson usb scanner [solved]

Dp ,

Thanks for your effort (Mr green also)

I´ve mailed the poster of your link http://lists.alioth.debian.org/pipermai … 10301.html

Maybe he got a solution for this problem. If not, i´m going to contact the ¨sane-people¨

Offline

#29 2004-06-24 16:11:42

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: no luck with epson usb scanner [solved]

blabla wrote:

Dp ,

Thanks for your effort (Mr green also)

I´ve mailed the poster of your link http://lists.alioth.debian.org/pipermai … 10301.html

Maybe he got a solution for this problem. If not, i´m going to contact the ¨sane-people¨

good luck


The impossible missions are the only ones which succeed.

Offline

#30 2004-06-24 20:33:44

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: no luck with epson usb scanner [solved]

Did you try what I told you?, Cause I had a really similar problem(the scanner worked in the past, and then suddenly stopped working, even though scanimage -L worked and sane-find-scanner too) , I don't know if the error message was the same you where getting, cause my system is in spanish. Try accessing the scanner and then check /var/log/kernel. I kept getting

usb 3-1: usbfs: interface 0 claimed while 'xsane' sets config #1

Looked for that error in google, and was told that you had to uncomment "epson" in /etc/sane.d/dll.conf. That fixed it.

Hope it works.


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#31 2004-06-25 09:33:25

blabla
Member
Registered: 2004-06-22
Posts: 39

Re: no luck with epson usb scanner [solved]

I tried what you told me; it didn´t work for  me but...............

I got this reaction to my email:

Hi,

Sorry to say that, AFAIK, this bug has not been fixed. Some are able to
scan by using xsane and clicking "acquire" a second time after
receiving the I/O error resulting from the first "acquire" attempt. I
get many emails from others with this problem, and it apparently
affects some additional scanner brands and models too. Please contact
the Sane Epson backend maintainer and the libusb developers regarding
this bug. If enough people contact them, maybe they will figure out how
to fix it. The appropriate bug reporting/contact information can be
found on the SANE and libusb websites.

Thanks,
Scott Miller

And clicking ¨acquire¨ for the second time actually works for me!!!!!!!!!!!!!

Offline

#32 2004-06-25 10:24:24

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,756

Re: no luck with epson usb scanner [solved]

Yay!!!  lol

Mr Green

(very happy now!!)


Mr Green

Offline

#33 2004-06-27 07:19:46

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: no luck with epson usb scanner [solved]

hi
the sane package has a bug
have a look at this http://bugs.archlinux.org/index.php?do=details&id=1038
you have to make the libusbscanner executable
and change libusbscanner to your needs
then it finally works for me without a problem
that is not epson specific it affects all usb scanners

Offline

#34 2004-06-27 08:01:16

blabla
Member
Registered: 2004-06-22
Posts: 39

Re: no luck with epson usb scanner [solved]

Already did that, that wasn't the problem.

gr

Offline

#35 2004-07-04 16:11:57

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: no luck with epson usb scanner [solved]

an other question to this
how you setup your scanner?
do you start it before you boot or after boot?
if before boot try this
http://bbs.archlinux.org/viewtopic.php?t=5458

try running xsane as root and look if it works
if yes then it's a permission problem

Offline

Board footer

Powered by FluxBB