You are not logged in.

#1 2008-03-24 16:38:01

Dheart
Member
From: Sofia, Bulgaria
Registered: 2006-10-26
Posts: 943

xhost +$hostname problem

For some time xhost + hostname stopped working. I am no longer able to run applications as root or other users with xhost + myhostname - I'm forced to use xhost +

[dheart@lightbringer ~]$ hostname
lightbringer
[dheart@lightbringer ~]$ xhost
access control enabled, only authorized clients can connect
[dheart@lightbringer ~]$ xhost + lightbringer
lightbringer being added to access control list
[dheart@lightbringer ~]$ su
Password: 
[root@lightbringer dheart]# kwrite 
No protocol specified
kwrite: cannot connect to X server :0.0
[root@lightbringer dheart]# exit
exit
[dheart@lightbringer ~]$ xhost + 127.0.0.1
127.0.0.1 being added to access control list
[dheart@lightbringer ~]$ su
Password: 
[root@lightbringer dheart]# kwrite 
No protocol specified
kwrite: cannot connect to X server :0.0
[root@lightbringer dheart]# exit
exit
[dheart@lightbringer ~]$ xhost + 85.187.41.92
85.187.41.92 being added to access control list
[dheart@lightbringer ~]$ su 
Password: 
[root@lightbringer dheart]# kwrite 
No protocol specified
kwrite: cannot connect to X server :0.0
[root@lightbringer dheart]# exit
exit
[dheart@lightbringer ~]$ xhost
access control enabled, only authorized clients can connect
INET:127.0.0.1
INET:lightbringer.domain.org
[dheart@lightbringer ~]$ xhost +
access control disabled, clients can connect from any host
[dheart@lightbringer ~]$ su
Password: 
[root@lightbringer dheart]# kwrite 
kbuildsycoca running...
[root@lightbringer dheart]#

Also here's my /etc/hosts

#
# /etc/hosts: static lookup table for host names
#

#<ip-address>   <hostname.domain.org>   <hostname>
85.187.41.92 lightbringer.domain.org  lightbringer

# End of file

Any ideas?


My victim you are meant to be
No, you cannot hide nor flee
You know what I'm looking for
Pleasure your torture, I will endure...

Offline

#2 2008-03-24 16:42:33

Misfit138
Misfit Emeritus
From: USA
Registered: 2006-11-27
Posts: 4,170

Re: xhost +$hostname problem

The wiki says "Your X server must be configured to listen to TCP connections for xhost + localhost to work"
Though I have never done so, so I wouldn't know how to proceed.

Offline

#3 2008-03-24 17:14:39

Dheart
Member
From: Sofia, Bulgaria
Registered: 2006-10-26
Posts: 943

Re: xhost +$hostname problem

Misfit138 wrote:

The wiki says "Your X server must be configured to listen to TCP connections for xhost + localhost to work"
Though I have never done so, so I wouldn't know how to proceed.

Ye... Must've missed that...
Anyway anyone knows how to configre X to listen to TCP connections?
Or some other solution to my problem?


My victim you are meant to be
No, you cannot hide nor flee
You know what I'm looking for
Pleasure your torture, I will endure...

Offline

#4 2008-03-24 17:36:11

Spider.007
Member
Registered: 2004-06-20
Posts: 1,145
Website

Re: xhost +$hostname problem

Configure your login-manager to allow TCP connections, for gdm that's DisallowTCP=false Or do this as root:

export XAUTHORITY=~user/.Xauthority

Both xhost + localhost and xhost + 127.0.0.1 work for me by the way; and I haven't configured anything special?

Last edited by Spider.007 (2008-03-24 17:49:26)

Offline

#5 2008-03-25 11:32:32

Dheart
Member
From: Sofia, Bulgaria
Registered: 2006-10-26
Posts: 943

Re: xhost +$hostname problem

Spider.007 wrote:

Configure your login-manager to allow TCP connections, for gdm that's DisallowTCP=false Or do this as root:

export XAUTHORITY=~user/.Xauthority

Both xhost + localhost and xhost + 127.0.0.1 work for me by the way; and I haven't configured anything special?

xhost + $hostname worked for me until some time.... anyway I put this

export XAUTHORITY=~user/.Xauthority

in rc.local and I'd also aprciate how to enable the xhost + thing (I use kdm)


My victim you are meant to be
No, you cannot hide nor flee
You know what I'm looking for
Pleasure your torture, I will endure...

Offline

Board footer

Powered by FluxBB