You are not logged in.

#1 2004-05-20 00:24:55

GGO
Member
From: Kona, Hawaii
Registered: 2004-05-20
Posts: 48
Website

Openbox 3.2 Installation Troubles --solved

I'm using widget, and I was not able to startX after configuring it (suing X-configure) the error was mouse-related. I read some of the documentation, and saw the recommendation to update openbox.

So i download openbox-3.2.tar.gz, and decompress it. I then cd into the dir, and type ./configure. all is well, it tells me to type make. I do, and i get an error message.

"make: *** [all-recusive] Error 1"

There was more, but it would be a hassle to type out, just ask if you need more, and this isnt just a basic problem.

edit: for any newbies who find this: in your XF86Config file, change the device option under the mouse section to be /dev/psaux, if you are using a ps/2 mouse.

Offline

#2 2004-05-20 00:30:38

Dusty
Schwag Merchant
From: Medicine Hat, Alberta, Canada
Registered: 2004-01-18
Posts: 5,986
Website

Re: Openbox 3.2 Installation Troubles --solved

pacman -Sy
pacman -Syu
pacman -S openbox

Make sure extra is configured in your /etc/pacman.conf

man pacman

won't hurt either. smile

Dusty

Offline

#3 2004-05-20 01:19:24

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: Openbox 3.2 Installation Troubles --solved

GGO wrote:

I'm using widget, and I was not able to startX after configuring it (suing X-configure) the error was mouse-related. I read some of the documentation, and saw the recommendation to update openbox.

So i download openbox-3.2.tar.gz, and decompress it. I then cd into the dir, and type ./configure. all is well, it tells me to type make. I do, and i get an error message.

"make: *** [all-recusive] Error 1"

There was more, but it would be a hassle to type out, just ask if you need more, and this isnt just a basic problem.

the compiling trouble is maybe because of the incompatiblity with the gcc 3.4.0

did you used ABS to rebuild it?

try to update it first with pacman, as Dusty explained


The impossible missions are the only ones which succeed.

Offline

#4 2004-05-20 06:43:36

GGO
Member
From: Kona, Hawaii
Registered: 2004-05-20
Posts: 48
Website

Re: Openbox 3.2 Installation Troubles --solved

i dont have a network connection yet on this machine, i have to install the nvidia drivers still. i was hoping to get X working before this, but i guess not. i'll check back later if im still having trouble. also, how do you specify a proxy connection for pacman?

Offline

#5 2004-05-20 14:27:58

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: Openbox 3.2 Installation Troubles --solved

GGO wrote:

i dont have a network connection yet on this machine, i have to install the nvidia drivers still. i was hoping to get X working before this, but i guess not. i'll check back later if im still having trouble. also, how do you specify a proxy connection for pacman?

http://bbs.archlinux.org/viewtopic.php? … ight=proxy


The impossible missions are the only ones which succeed.

Offline

#6 2004-07-14 09:24:07

GGO
Member
From: Kona, Hawaii
Registered: 2004-05-20
Posts: 48
Website

Re: Openbox 3.2 Installation Troubles --solved

Ok, I got pacman running, and I updated openbox, yet I still get the same error. Anyone have any ideas?

Offline

#7 2004-07-14 09:32:28

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,750

Re: Openbox 3.2 Installation Troubles --solved

Are you using ABS ??? or pacman to install...???

(Don't know if have connection sorted yet)

Mr Green


Mr Green

Online

#8 2004-07-14 09:36:22

GGO
Member
From: Kona, Hawaii
Registered: 2004-05-20
Posts: 48
Website

Re: Openbox 3.2 Installation Troubles --solved

I got the connection sorted out, for now anyway. I upgraded to the latest version of pacman, and ran pacman -Sy, then -Syu, then just to be sure pacman -S openbox, which told me that i already had the latest version.

Offline

#9 2004-07-14 09:46:02

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: Openbox 3.2 Installation Troubles --solved

what's the problem?


arch + gentoo + initng + python = enlisy

Offline

#10 2004-07-14 09:55:07

GGO
Member
From: Kona, Hawaii
Registered: 2004-05-20
Posts: 48
Website

Re: Openbox 3.2 Installation Troubles --solved

when I run X -configure, it cannot detect my mouse. thats what it says anyway. of course I can't startx either.

Offline

#11 2004-07-14 09:58:05

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: Openbox 3.2 Installation Troubles --solved

is this hwd that does that? I've never tried it.


arch + gentoo + initng + python = enlisy

Offline

#12 2004-07-14 10:15:08

GGO
Member
From: Kona, Hawaii
Registered: 2004-05-20
Posts: 48
Website

Re: Openbox 3.2 Installation Troubles --solved

no, X -configure is something I learned when setting up my dual-monitors with redhat 9. works pretty well, except for now. is this command appropriate for arch linux? also, i can't seem to download hwd with pacman, it says its not in the database.

Offline

#13 2004-07-14 10:16:56

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: Openbox 3.2 Installation Troubles --solved

Have you already made your xorg.conf?


arch + gentoo + initng + python = enlisy

Offline

#14 2004-07-14 10:31:19

GGO
Member
From: Kona, Hawaii
Registered: 2004-05-20
Posts: 48
Website

Re: Openbox 3.2 Installation Troubles --solved

yes, i made it, but im not using x.org, im using xfree86 4.3. is it worth it to switch to x.org?

Offline

#15 2004-07-14 10:37:16

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: Openbox 3.2 Installation Troubles --solved

if you got broadband yes. there is wikis on xorg, openbox and 3D.
xfree should start anyway. when you startx, does it complains that it can't find the mouse?


arch + gentoo + initng + python = enlisy

Offline

#16 2004-07-14 10:38:49

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,750

Re: Openbox 3.2 Installation Troubles --solved

I think you need to get X running first before you can use openbox...

hwd should give you your systems hardware & will create a config file too

of course you can use xconfig

thats up to you...

Without X set up nothing is going to work

Mr Green


Mr Green

Online

#17 2004-07-14 11:02:03

GGO
Member
From: Kona, Hawaii
Registered: 2004-05-20
Posts: 48
Website

Re: Openbox 3.2 Installation Troubles --solved

i upgraded openbox because that is what one of the wiki docs (that isnt there anymore) said i should do. and yes, x is complaining about my mouse.

Offline

#18 2004-07-14 11:04:35

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: Openbox 3.2 Installation Troubles --solved

what is it for mouse? psaux or usb?


arch + gentoo + initng + python = enlisy

Offline

#19 2004-07-14 11:09:10

GGO
Member
From: Kona, Hawaii
Registered: 2004-05-20
Posts: 48
Website

Re: Openbox 3.2 Installation Troubles --solved

where are you referring to by "what is it for mouse?" i'm using a ps/2 mouse

Offline

#20 2004-07-14 11:17:30

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: Openbox 3.2 Installation Troubles --solved

put this code in your conf in the mouse section

Option "Device" "/dev/psaux"

strange because this should be the default, you could also try /dev/input/mice


arch + gentoo + initng + python = enlisy

Offline

#21 2004-07-14 11:23:28

GGO
Member
From: Kona, Hawaii
Registered: 2004-05-20
Posts: 48
Website

Re: Openbox 3.2 Installation Troubles --solved

damn, i love you! big_smile

ok, i have a window manager, this rocks. now could you help me out with my network troubles? it's the next thread down. and thank you!

Offline

Board footer

Powered by FluxBB