You are not logged in.

#1 2004-07-20 18:22:01

android
Member
From: San Diego
Registered: 2003-04-18
Posts: 144

Now Moved to xorg - Xfree86 4.4.0 continuing to crash

Wow, I just did:

pacman -S xorg

I've never had an x upgrade go so smoothly!

Everything is back up already.

Sorry for the edited original post. It's kind of wiki'esque for the forums.

Thanks to the packager for the smooth upgrade to x.org!!!

I'm hoping it doesn't exhibit the same random crashes as Xfree86 4.4.0.

John E. A.

NEWER STUFF HERE:

Sorry if the formatting is bad. I'm writing this from lynx.
Since Xfree86 just gave up again.
I don't think this has anything to do with xmms. Has anyone else been experiencing aperiodic crashes of Xfree86 4.4?
It doesn't seem to be able to run for more than a couple of days at a time.
Thanks Again!!!

John E. A.

ORG STUFF BELOW HERE:

I guess it's only to be expected that a big move to native alsa would bring some problems. At least that's what I'm blaiming at the moment.

Although, more specifically, the problem seems to be with xmms 1.2.10. I'm using the alsa output plugin (which, I believe, doesn't exist in previous pkg versions).

I wasn't sure where t put this post. I put it here since the biggest pain is that the xmms seg fault kills the X server, and all of my meticulously placed windows and workspaces disapear.

Ill post to the xmms bug list too. I just wondered if other arch users were experiencing this trouble.

BTW, I use the snd_intel8x0 kernel audio driver.

I hope everyone is enjoying their summer time. It's REALLY nice here today...

John E. A.

Offline

#2 2004-07-20 18:56:01

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: Now Moved to xorg - Xfree86 4.4.0 continuing to crash

I think that plugin exists for a long time. I use your same module, and have no problem with it. Maybe you should check your X log, or try strace xmms.


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#3 2004-07-21 14:02:52

bogomipz
Member
From: Oslo, Norway
Registered: 2003-11-23
Posts: 169

Re: Now Moved to xorg - Xfree86 4.4.0 continuing to crash

The ALSA plugin is not new. The only problem I've experienced with it is that xmms won't resume after you pause it, you have to hit stop then play. It was supposed to be fixed in 1.2.10, but isn't. OSS-emulation was the remedy I ended up with.

I've never had xmms or any other program kill X, doesn't sound too cool. You're sure it's not the warm summer that's giving X the creeps? wink


All of your mips are belong to us!!

Offline

#4 2004-07-22 15:34:28

android
Member
From: San Diego
Registered: 2003-04-18
Posts: 144

Re: Now Moved to xorg - Xfree86 4.4.0 continuing to crash

OK, I've come around to believing it's not xmms at all.

xmms is just another innocent victim, it's seg fault message just seems to be at the end of the console output after the X crash.

I am advised by those over at xmms bugzilla that there should be NO way for xmms to crash Xfree86.

Xfree86 4.4.0-3 is still periodically crashing on me. Nothing in the log file afterward.

This is a fairly new system, it's been Xfree86 4.4.0 from the beginning, no tortuous upgrade in this machines history.

I just come back to the machine in the morning, and it's at a console prompt w/ xmms seg fault message at the end(and other dead X stuff). This output does not seem to be captured to the log.

Any help is greatly appreciated...

John E. A.

p.s. A little overcast today, maybe I can concentrate 8-)

Offline

#5 2004-07-27 14:37:17

bigh
Member
From: Zurich, Switzerland
Registered: 2004-03-23
Posts: 62

Re: Now Moved to xorg - Xfree86 4.4.0 continuing to crash

my x also crashs after a few days of a fresh install.
I cant explain whats the reason. Its often after a few minutes.
First I thought its xfce then mozilla and gaim but they arent the problem I think.
The logs ive looked in dont show me the problem..
Wich log could be helpful for you to help me?

I really dont know what to do anymore. Without x archlinux isnt useless for me. But I dont like to use something else...

ps: sry for my very bad english. Its very difficult for me to explain the real problem in english..

Offline

#6 2004-07-27 15:41:36

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: Now Moved to xorg - Xfree86 4.4.0 continuing to crash

Mysterious crashes without any trace in logs often happen due to problems with phisical memory. Before you check anything else try to check your RAM with memtest. Take a look at this thread for examples and links http://bbs.archlinux.org/viewtopic.php? … ht=memtest

Offline

#7 2004-08-01 06:53:10

android
Member
From: San Diego
Registered: 2003-04-18
Posts: 144

Re: Now Moved to xorg - Xfree86 4.4.0 continuing to crash

Just a follow up to this issue.

I've been running xorg instead of xfree86 for just over a week now.

So far none of the random X crashes have resurfaced.

I never had complete system crash, only X server crash. The command line was always active afterward (every single time). So I don't think it was a hardware issue this time, although the memtest suggestion is prudent.

As for me, I'm calling the migration to xorg a fix.

Knocking on wood...

John E. A.

Offline

Board footer

Powered by FluxBB