You are not logged in.

#1 2004-06-28 22:06:06

standsolid
Member
From: Carlsbad, CA
Registered: 2004-05-23
Posts: 54
Website

VNC 4.0 patch to build on gcc 3.4 --almost there

please scroll down to my latest post to view the patch and explanation.  I cannot get Xvnc to compile, but I am able to get the base RealVNC to work.  please help if you can

RealVNC  has released VNC 4.0...I would like to see the arch package updated as well.

according to their website, they changed their build process to be "cleaner"...

release notes

http://www.realvnc.com/dist/vnc-4.0-x86_linux.tar.gz


ewwwwww Arch is all gooey

Offline

#2 2004-06-29 18:22:58

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: VNC 4.0 patch to build on gcc 3.4 --almost there

Isn't this what the flag out of date feature on the website is for?


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#3 2004-06-29 21:41:20

standsolid
Member
From: Carlsbad, CA
Registered: 2004-05-23
Posts: 54
Website

Re: VNC 4.0 patch to build on gcc 3.4 --almost there

Xentac wrote:

Isn't this what the flag out of date feature on the website is for?

didn't see that sad

maybe that should be posted on one of the stickies?


ewwwwww Arch is all gooey

Offline

#4 2004-06-29 23:10:02

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,377
Website

Re: VNC 4.0 patch to build on gcc 3.4 --almost there

vnc is flagged out of date, yes, but it will not build against gcc 3.4, so we are waiting


The impossible missions are the only ones which succeed.

Offline

#5 2004-07-20 22:29:20

standsolid
Member
From: Carlsbad, CA
Registered: 2004-05-23
Posts: 54
Website

Re: VNC 4.0 patch to build on gcc 3.4 --almost there

OK
This patch allows VNC 4.0 to build with gcc 3.4  -- i based it off of a post in the VNC lists that redhat posted for the beta verison of this.

It replaces min( with std::min(

I compiled it successfully, and even made a pkgfile -- but I can not figure out how to compile Xvnc with it.   It appears as if they are asking for a piece of the XFree86 distribution in the readme.  This patch is the furthest I've gotten (i am able to use x0vncserver -- nad it's awesome)

can someone figure out how to build Xvnc?

http://standsolid.com/arch_forums/vnc-gcc34.patch


ewwwwww Arch is all gooey

Offline

#6 2004-07-21 19:29:39

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,377
Website

Re: VNC 4.0 patch to build on gcc 3.4 --almost there

standsolid wrote:

OK
This patch allows VNC 4.0 to build with gcc 3.4  -- i based it off of a post in the VNC lists that redhat posted for the beta verison of this.

It replaces min( with std::min(

I compiled it successfully, and even made a pkgfile -- but I can not figure out how to compile Xvnc with it.   It appears as if they are asking for a piece of the XFree86 distribution in the readme.  This patch is the furthest I've gotten (i am able to use x0vncserver -- nad it's awesome)

can someone figure out how to build Xvnc?

http://standsolid.com/arch_forums/vnc-gcc34.patch

hey, thanx a lot for the patch - i can build vnc 4.0 now without trouble, great!

i'm going to update it in extra and have decided to exclude Xvnc out of the vnc pkg

Xvnc 4.0 is NOT longer in the vnc pkg

why?

README wrote:

Building Xvnc
=============

Building Xvnc and the VNC support for native X servers is much more complex.
If you don't need to build it, skip to the section below on installing.

Xvnc differs from the other programs in that it is built inside the X source
tree.  Unlike previous versions of Xvnc, we do not provide an X source tree
with this distribution.  We have designed the distribution to be as independent
as possible of the X tree used.

We have successfully used XFree86 version 4.3.0, 4.2.0 and 3.3.6 (available
from http://www.xfree86.org).  You could also try the original X.org tree
available from http://www.x.org but this does not build as easily because of
lack of support for C++, no support for building server only, and other issues.

Note that the X tree is enormous and notoriously difficult to deal with -
building it is not for the faint-hearted!

Once you have a copy of the X source tree, make sure it is unpacked at the top
level of this distribution, so that the xc directory of the X source tree
matches the xc of this distribution, for example:

  % tar xzf X420src-1.tgz

Then you must apply a patch to some files in the X source tree:

  % patch -Np0 <xc.patch

If this works, you should be able to build the entire X tree, including Xvnc:

  % cd xc
  % make World

This will take a long time, and will quite probably fail for one reason or
another!  If you are having trouble, we suggest you try to build the X tree in
isolation first before attempting it with the VNC additions.

If successful, in the xc/programs/Xserver directory you should find an Xvnc
binary, plus the native X server binary(ies) for your platform with VNC support
compiled in.  If you are building from an XFree86 version 4 tree on a supported
platform, you should also find a vnc.so module in
xc/programs/Xserver/vnc/modules.

Exactly which X extensions and features are built into Xvnc and the native X
server binary is determined by the settings in xc/config/cf.  The file vnc.def
contains the settings we use to build our binary distributions.  You may need
to edit this and the other files as appropriate.


The impossible missions are the only ones which succeed.

Offline

#7 2004-07-21 22:59:01

standsolid
Member
From: Carlsbad, CA
Registered: 2004-05-23
Posts: 54
Website

Re: VNC 4.0 patch to build on gcc 3.4 --almost there

but isn't Xvnc essential to have VNC  server running properly?

perhpas a Xvnc package is in order.... or split the vncviewer and vncserver packages?


ewwwwww Arch is all gooey

Offline

#8 2004-07-21 23:38:04

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,377
Website

Re: VNC 4.0 patch to build on gcc 3.4 --almost there

standsolid wrote:

but isn't Xvnc essential to have VNC  server running properly?

perhpas a Xvnc package is in order.... or split the vncviewer and vncserver packages?

yes, if you want to have a vncserver, you need Xvnc, but as they cleaned up the building by removing Xvnc and forcing it to be built in the x-server source-tree, i decided that if we split, then in

vnc (all except Xvnc)

and

xvnc (depends=(xvnc) n makedepends=(xfree86-sources) or makedepends=(xorg-sources)) -> maybe it needs to be splitted to xvnc-xfree86 and xvnc-xorg too :-(

but as there is no xvnc pkg yet, temporarely it will be only vnc around

to the people working on a xvnc pkg:
the main trouble you can expect is:
- dealing with the x-server sources (huge, has momentum, not really clean)
- Xvnc has some incompatibilities with x.org
- maybe other trouble

but it would be really cool if someone would manage to make one - someone with a fast connection (big sources), good nerves and time to spend :-)

good luck

as an alternative, i'll have a look at x11vnc in the meantime


The impossible missions are the only ones which succeed.

Offline

#9 2004-07-22 03:04:23

standsolid
Member
From: Carlsbad, CA
Registered: 2004-05-23
Posts: 54
Website

Re: VNC 4.0 patch to build on gcc 3.4 --almost there

well, the new vnc 4.0 takes care of what x11vnc does -- but it's still a welcome package, in this user's opinion. 

Although, I believe the comments made about the x.org release was made before they merged in the XFree86 CVS pre 4.4.  Currently the X.org implementation is not all that different from the Xfree86 branch (As I inderstand)

for now, x0vncserver and X11 forwarding over SSH do all that I need, so I'm happy.


ewwwwww Arch is all gooey

Offline

#10 2004-07-22 06:42:04

dpb
Member
From: Cyperspace?
Registered: 2004-04-11
Posts: 231

Re: VNC 4.0 patch to build on gcc 3.4 --almost there

Clad I read this before I upgraded vnc... I use vncserver daily so I had to add a IgnorePkg for it...

Offline

#11 2004-07-22 11:58:15

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,377
Website

Re: VNC 4.0 patch to build on gcc 3.4 --almost there

x11vnc is in extra


The impossible missions are the only ones which succeed.

Offline

#12 2004-07-22 17:00:30

standsolid
Member
From: Carlsbad, CA
Registered: 2004-05-23
Posts: 54
Website

Re: VNC 4.0 patch to build on gcc 3.4 --almost there

vncserver works fine with the Xvnc binary found in this package on my machine (arch current/extra -- athlon XP)

http://www.realvnc.com/dist/vnc-4.0-x86_linux.tar.gz

perhaps this is a solution?  I know it's at least my temporary solution....


ewwwwww Arch is all gooey

Offline

#13 2004-07-22 19:30:13

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,377
Website

Re: VNC 4.0 patch to build on gcc 3.4 --almost there

standsolid wrote:

vncserver works fine with the Xvnc binary found in this package on my machine (arch current/extra -- athlon XP)

http://www.realvnc.com/dist/vnc-4.0-x86_linux.tar.gz

perhaps this is a solution?  I know it's at least my temporary solution....

do u use xorg or xfree86? if both work with the precompiled bin from realvnc, then i can include Xvnc from there to the pkg as a middle-solution


The impossible missions are the only ones which succeed.

Offline

#14 2004-07-23 09:47:17

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,377
Website

Re: VNC 4.0 patch to build on gcc 3.4 --almost there

i tried including the binary from realvnc, but it gives this:

[damir@Asteraceae vnc]$ Xvnc
Xvnc: error while loading shared libraries: libstdc++-libc6.1-1.so.2: cannot open shared object file: No such file or directory
[damir@Asteraceae vnc]$

on my machine (arch current using xorg)

-> :-( ideas?

well, i have, but not really cool one --- anyone knows the cxxlibs pkg for slack? it would be our compatibility thig for such troubles, but it is definitely too high for me messing with this


The impossible missions are the only ones which succeed.

Offline

#15 2004-07-23 09:53:36

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,377
Website

Re: VNC 4.0 patch to build on gcc 3.4 --almost there

cxxlibs: C++ shared libraries
cxxlibs: 
cxxlibs: This package contains the shared libraries needed to run dynamically
cxxlibs: linked C++ binaries.
cxxlibs: 
cxxlibs:       Includes libstdc++-3-libc6.2-2-2.10.0.so (from gcc-2.95.4)
cxxlibs:                libstdc++.so.2.7.2.8,
cxxlibs:                libstdc++.so.2.8.0,
cxxlibs:                libstdc++.so.2.9.0,
cxxlibs:                libstdc++-2-libc6.1-1-2.9.0.so,
cxxlibs:                libstdc++-3-libc6.1-2-2.10.0.so.

The impossible missions are the only ones which succeed.

Offline

Board footer

Powered by FluxBB