You are not logged in.

#1 2004-07-24 08:14:51

Registered: 2004-02-02
Posts: 358

Yet Another NVIDIA Problem(TM)

Since I updated XFree86 a week or so ago, it just keeps failing to initialise the NVIDIA module. I tried X.Org, which does exactly the same. Looking at the log, everything seems to start up properly with no errors, but suddenly it decides to give up, no reason given.

I have just discovered that if I uninstall, reinstall and modprobe the the NVIDIA drivers, it works! Until I reboot. Then, no matter what I try, it will not work at all! So I have to uninstall, reinstall and modprobe each time I reboot.

Very weird is all I can say.


#2 2004-07-24 08:57:29

From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,297

Re: Yet Another NVIDIA Problem(TM)

try adding nvidia to rc.conf's modules list
that should do it
there is also a nvidia package in the staging repo
which gives you hints about installing
pacman -S nvidia


#3 2004-07-25 13:38:10

Registered: 2004-02-02
Posts: 358

Re: Yet Another NVIDIA Problem(TM)

Well, I had done that, but the point was that once I restarted, whether the nvidia modules was loaded by /etc/rc.sysinit or manually with modprobe, it would not work (but modprobe did not report any errors). The /dev/nvidia* devices do not show up.

Seems the problem is with UDev (maybe I needed to configure something for it?). I have switched back to DevFS for now, and it works again (X.Org). I had forgotten when I posted that I had also switched to UDev at the same time...

I still have another slightly related problem. I recently (yesterday) had this idea that maybe I should try get my (hardly ever used) Lucent winmodem working under Linux for the odd times I use dial-up. Drivers were easy to find ( This worked under UDev, but then stopped working when I restarted (grr), the same as NVIDIA, whether they were in MODULES or whether I modprobe'd 'em. I actually got KPPP to dial on /dev/modem and it would have authorised had I bothered to configure PPP daemon first ;-) Didn't work under DevFS either, even though the install script had added a rule in /etc/modprobe.conf to alias /dev/modem which doesn't materialse. The device does appear at /dev/tts/LTM0 but KPPP can't dial on it.


#4 2004-07-25 16:35:49

Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797

Re: Yet Another NVIDIA Problem(TM) … dev+nvidia

I believe it was also added to the udev wiki.  You need that nvidia script to generate your devices.

I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal


Board footer

Powered by FluxBB