You are not logged in.

#1 2008-05-26 12:33:49

Registered: 2008-05-20
Posts: 42

kernel panic when booting arch install disk on thinkpad i1400


I have a VERY old Thinkpad i1400 sitting around I figured I would set up for my kids. This is a Celeron 366 that currently has 96MB (will upgrade to 256MB once I confirm I can use the thing), a 20GB hard drive, and working bootable CDROM, with a PCMCIA network card (3Com 3C589D).

I successfully installed Arch on it many years ago (back in the 2.4 kernel days) and it was so old I couldn't do a pacman -Syu on it and now that installation is hosed. So I am trying to install from scratch.

I downloaded the latest FTP install ISO. I boot it and the kernel panics with this final message:

[<c0461417>] unknown_bootoption+0x0/0x1df
Kernel panic - not syncing: Attempted to kill the idle task!

I did some searching and found this old exchange on the Forum:

I tried the suggestions (various combinations of apm=off, acpi=off, dma=off) and none of them worked.

Please note that the panic message in that topic is different than what I am getting.

This machine boots fine with Puppy (2.6 kernel, but no PCMCIA) and DSL (2.4 kernel, everything works fine).

I want to use Arch! I know it, it's lightweight, and is a better fit than Puppy or DSL.

Does anyone have any suggestion?


#2 2008-05-26 13:27:34

From: Japan
Registered: 2006-05-16
Posts: 86

Re: kernel panic when booting arch install disk on thinkpad i1400

I get the same error on a Thinkpad A21e (750Mhz Celeron, 128Mb PC100) but not on a Thinkpad 1100-iSeries (550Mhz Celeron, 192Mb). Ubuntu, Crux and a couple of other distros all work fine on it. Suggestions would be welcome. smile

Linux user No. 409907


Board footer

Powered by FluxBB