You are not logged in.

#1 2004-08-05 19:57:04

Blizzard Wolf
Member
Registered: 2004-08-04
Posts: 14

KSplash and Panel crash on startup.

After my problem with my NVidia drivers, things have been going downhill.

Last night, my KDE refuses to exit properly, I had to kill XServer, and it seems to do the same for a while...eventually.

Then after I go to GNOME then go back to KDE, I also encounter two errors. KSplash doesn't work anymore, so as Panel, I don't know what happened, but they say there's a bug in the application, and I cannot recover from it for some reason.

Any have ideas?

If it helps, it happened after updating Mozilla and another package...libpng. It's probably involving libpng and my png files on my panel and maybe on the splash menu, and I can't do a backtrace because I am missing a program.

And yes, i have tried reboot twice, GNOME works just fine, I like it, but it is painful to customize since it isn't as pretty and the packages don't put their own shortcuts in the menu.

Offline

#2 2004-08-05 21:14:53

Blizzard Wolf
Member
Registered: 2004-08-04
Posts: 14

Re: KSplash and Panel crash on startup.

Now it's getting worse, every KDE program is causing a signal 11 error, KDE's gone bad...I've tried reinstalling, it doesn't work.

Offline

#3 2004-08-05 21:45:17

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: KSplash and Panel crash on startup.

Could it be that KDE needs to be recompiled against the new glibc? Have you contacted the maintainer of the KDE packages? Have you had the same problems with other X applications that are not KDE based?


AKA uknowme

I am not your friend

Offline

#4 2004-08-05 23:53:45

Blizzard Wolf
Member
Registered: 2004-08-04
Posts: 14

Re: KSplash and Panel crash on startup.

Definately not, if it did, then everything would've crashed before.

No, I don't know what it involves, backtracing it I am unable to do.

No, but XCDROAST is a painful experience to configure.

Offline

#5 2004-08-06 00:20:25

hypermegachi
Member
Registered: 2004-07-25
Posts: 311

Re: KSplash and Panel crash on startup.

i have this problem too now sad

i thought it was because of the nptl i was using, but downgrading didn't fix it.

Offline

#6 2004-08-06 00:43:11

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: KSplash and Panel crash on startup.

EDIT: if you are not interested in a wrong statement, please read on to the next post, thx :-)

sarah31 wrote:

Could it be that KDE needs to be recompiled against the new glibc? Have you contacted the maintainer of the KDE packages? Have you had the same problems with other X applications that are not KDE based?

to check this, i played with kde a little (starting some kde bins and checking)

kontact also fails to run
konqueror disapears without feedback while rightclicking or other actions
...
long list

tried to crash konqueror in gdb:

...
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 2437)]
0xb77d536d in free () from /opt/kde/lib/libkdecore.so.4
(gdb) 

hä? not really much info ... strange...

trying kontact:

...

[New Thread 16384 (LWP 2445)]
Reading symbols from /usr/X11R6/lib/libXrender.so.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/libstdc++.so.6...(no debugging symbols found)...done.
Reading symbols from /usr/lib/libgcc_s.so.1...(no debugging symbols found)...done.
Reading symbols from /lib/libm.so.6...(no debugging symbols found)...done.
Reading symbols from /lib/libc.so.6...(no debugging symbols found)...done.
Reading symbols from /usr/X11R6/lib/libXxf86vm.so.1...(no debugging symbols found)...done.
Reading symbols from /usr/X11R6/lib/libXt.so.6...(no debugging symbols found)...done.
Reading symbols from /lib/ld-linux.so.2...(no debugging symbols found)...done.
ERROR: Communication problem with kontact, it probably crashed.

Program exited with code 0377.
(gdb) 

ok, then i realized, that i need to run it with --nofork:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 2499)]
0xb69317bc in memcpy () from /lib/libc.so.6
(gdb) 

it IS a glibc trouble!

EDIT: it is NOT!

EDIT2: actually, it is, at least in a way ... memcpy() is from glibc but used in libpng intensively, so the trouble was in memcpy, but it was caused by libpng 1.2.6rc1


The impossible missions are the only ones which succeed.

Offline

#7 2004-08-06 01:02:25

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: KSplash and Panel crash on startup.

ignore my last post - i was wrong! :oops:

kde works without problems with the new glibc -  the problem is the libpng !!! i downgraded it and funny, but the issues are solved

it's the same problem like this:

http://bbs.archlinux.org/viewtopic.php?t=6013


The impossible missions are the only ones which succeed.

Offline

#8 2004-08-06 01:39:53

Blizzard Wolf
Member
Registered: 2004-08-04
Posts: 14

Re: KSplash and Panel crash on startup.

Great, now how do the newbies downgrade?

Offline

#9 2004-08-06 02:56:57

hypermegachi
Member
Registered: 2004-07-25
Posts: 311

Re: KSplash and Panel crash on startup.

go into one of the mirrors and manually download a stable package.

then just use pacman -U package.pkg.tar.gz

Offline

#10 2004-08-06 03:12:11

Blizzard Wolf
Member
Registered: 2004-08-04
Posts: 14

Re: KSplash and Panel crash on startup.

They fixed it, thank you!

*Puts away Gentoo CD*

Offline

#11 2004-08-06 18:04:38

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: KSplash and Panel crash on startup.

Blizzard Wolf wrote:

*Puts away Gentoo CD*

*huh*, that was close :-)


The impossible missions are the only ones which succeed.

Offline

Board footer

Powered by FluxBB