You are not logged in.

#1 2004-08-14 10:47:12

TobyR
Member
From: Cambridge, UK
Registered: 2004-08-14
Posts: 25

Redhat to Arch - problem with power down and wheel mouse

Hi all,
I've just re-installed my Linux PC with Arch 0.6 having always been a Redhat user.  I'm having a few issues with the basics up and would really appreciate some advice.  In no particular order:

1.  The PC will not power itself down - I have to switch it off when prompted.  My reading on the subject tells me this is something that APIC or APD should be doing.

/proc/cpuinfo suggests apic is supported
flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov mmx

... but 'pacman -Q' suggests apmd is installed, but not apicd.   That said, there's no 'apmd' in /etc/rc.d/, which is where I thought all the daemons were shown.  So, should I install apicd, or stick with apmd, and how do I get either running? I get the impression I need to add something to GRUB, but I wouldn't know what.

2.  Is there an Arch equivalent to 'service --status-all'?

3.  Is there an Arch eqiuvalent to 'chkconfig'?

4.  In /etc/X11/XF86Config what mouse setting should I use for a wheel mouse?

Thanks in advance for your help - it's much appreciated!

/Toby


---------------------------
Arch Linux 0.6
Pentium II 266MHz
160MB SDRAM

Offline

#2 2004-08-14 11:29:54

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,751

Re: Redhat to Arch - problem with power down and wheel mouse

What kernel are you using....

Wheel mouse settings ... have you not got a copy of your old xfconfig from red-hat assuming you had it working with it....

you could try hwd (pacman it in)...

Or search forum

is wheel mouse USB ?


Mr Green

Offline

#3 2004-08-14 11:57:24

TobyR
Member
From: Cambridge, UK
Registered: 2004-08-14
Posts: 25

Re: Redhat to Arch - problem with power down and wheel mouse

Thanks ...
1. Kernel 2.6
2. No, I didn't keep it (silly me)
3. Mouse PS2


---------------------------
Arch Linux 0.6
Pentium II 266MHz
160MB SDRAM

Offline

#4 2004-08-14 15:21:59

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,751

Re: Redhat to Arch - problem with power down and wheel mouse

http://bbs.archlinux.org/viewtopic.php? … +mouse+ps2

Don't know if that will help....

I use 2.6.7 & since loading 2.6 I get power down...

have you got anything in /proc/acpi ??

HTH


Mr Green

Offline

#5 2004-08-14 15:23:55

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: Redhat to Arch - problem with power down and wheel mouse

how old is your pc?
try acpi=force on grub or lilo prompt

Offline

#6 2004-08-14 15:54:57

i3839
Member
Registered: 2004-02-04
Posts: 1,185

Re: Redhat to Arch - problem with power down and wheel mouse

You don't need acpid or apmd to poweroff, they are killed before the actual shutdown anyway...

Make sure that your bios settings are correct, disable apm and enable acpi if you want to use acpi, and vice versa for apm (can also try apm with apm=power-off as kernel parameter). I use acpi=force too because my bios is too old. See "dmesg" for how and why apci is disabled. It's also possible that "poweroff" works while normal "halt" or "shutdown" don't because the power isn't turned off by default (had that once).

Mouse settings are easy if you have a normal mouse, I use the following :

Section "InputDevice"
    Identifier    "Mouse1"
    Driver    "mouse"
    Option "Protocol"    "IMPS/2"
    Option "Device"      "/dev/psaux"
    Option "ZAxisMapping"    "4 5"
EndSection

The ZAxisMapping enables the mousewheel.

See for more info the Arch wiki, link at top right of the forum.

Offline

#7 2004-08-15 13:04:31

TobyR
Member
From: Cambridge, UK
Registered: 2004-08-14
Posts: 25

Re: Redhat to Arch - problem with power down and wheel mouse

All very strange - I haven't changed the BIOS settings since I changed over from RH, and under RH power off worked fine.   
Thanks to everyone's responses I've beena ble to dig a bit deeper.

/proc/apm exists and says simply:
1.16ac 1.2 0x03 0x01 0xff 0x80 -1% -1 ?

/proc/acpi does not exist so  I assume that it's APM the PC is set upto use.  However, 'apm=power-off" has no effect, and if I do try "acpi=force" I get a message (in dmesg):
ACPI: Unable to locate RSDP

... which reading around the subject appears to mean ACPI just isn't supported (old machine etc etc)
So I guess the machine used to use (successfully) APM - but why doesn't it power off now?  And what if any is the significance of the fact that when I run 'displayapm' from the grub prompt it says:
"APM BIOS not found or probe failed"?


---------------------------
Arch Linux 0.6
Pentium II 266MHz
160MB SDRAM

Offline

#8 2004-08-15 19:00:47

neocephas
Member
From: orange, ca
Registered: 2004-02-14
Posts: 30

Re: Redhat to Arch - problem with power down and wheel mouse

In my grub entry I have

acpi=off apm=power-off

to enable powering off with just APM.  My laptop doesn't like ACPI either.

Offline

Board footer

Powered by FluxBB