You are not logged in.

#1 2004-08-15 13:38:01

Abaddon
Member
From: Poland
Registered: 2004-05-03
Posts: 232

qmake


Gnome - The weakest link!
Linux, *not* GNU/Linux!

Offline

#2 2004-08-15 14:26:39

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: qmake

Hmm.. psi 0.9.2 is using qmake (inside a Makefile, obviously) and I had no problem compiling it.

Offline

#3 2004-08-15 19:15:19

Abaddon
Member
From: Poland
Registered: 2004-05-03
Posts: 232

Re: qmake

With qt 3.3.3?


Gnome - The weakest link!
Linux, *not* GNU/Linux!

Offline

#4 2004-08-15 19:38:47

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: qmake

qt 3.3.3?
Grr.. my RSS reader bot is not working... I've just seen that 3.3.3 is out.
I have to admit, I haven't tested 3.3.3 yet.

If qmake doesn't work there, than it's a valid bug request.

Offline

#5 2004-08-15 20:29:42

Abaddon
Member
From: Poland
Registered: 2004-05-03
Posts: 232

Re: qmake

Please check it. I found it as buggy.


Gnome - The weakest link!
Linux, *not* GNU/Linux!

Offline

#6 2004-08-17 10:24:25

Abaddon
Member
From: Poland
Registered: 2004-05-03
Posts: 232

Re: qmake

Is enyone there? :>


Gnome - The weakest link!
Linux, *not* GNU/Linux!

Offline

#7 2004-08-17 10:35:09

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: qmake

i try to rebuild qt at the moment give you feedback when it's done

Offline

#8 2004-08-17 11:29:37

dpb
Member
From: Cyperspace?
Registered: 2004-04-11
Posts: 231

Re: qmake

Abaddon wrote:

Is enyone there? :>

No.  8)

Offline

#9 2004-08-17 12:09:06

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: qmake

here is the corrected PKGBUILD:
# $Id: PKGBUILD,v 1.29 2004/08/12 20:47:05 judd Exp $
# Maintainer: Judd Vinet <jvinet@zeroflux.org>
# Contributor: John Proctor <jproctor@prium.net>
pkgname=qt
pkgver=3.3.3
pkgrel=1
pkgdesc="The QT gui toolkit."
url="http://www.trolltech.com/products/qt/index.html"
pkgfqn=${pkgname}-x11-free-${pkgver}
# We need the postgresql sources for QT's postgres sql plugin
psqlver=7.4.3
install=qt.install
depends=('x-server' 'libpng' 'libjpeg')
makedepends=('mysql' 'postgresql' 'sqlite')
source=(ftp://ftp.trolltech.com/qt/source/${pkgfqn}.tar.bz2 qt.profile
        ftp://ftp.postgresql.org/pub/source/v$p … ver.tar.gz
        qt-3.2.3.patch)
md5sums=('3e0a0c8429b0a974b39b5f535ddff01c' 'd75ab729b02bba8f58ba7b6d46609dd7'
         '581d8a4a4f5fe013d6d9b0137d11172c' '7c8ae8926f620065fcd7112c7b2a5e4b')

build() {
  export QTDIR=$startdir/src/$pkgfqn
  export PATH=${QTDIR}/bin:${PATH}
  export LD_LIBRARY_PATH=${QTDIR}/lib:${LD_LIBRARY_PATH}
  cd $startdir/src/$pkgfqn
  patch -Np1 -i ../qt-3.2.3.patch || return 1
  echo "yes" | ./configure -prefix /opt/qt -system-zlib -qt-gif
    -system-libpng -system-libjpeg -plugin-imgfmt-mng -thread -no-stl
    -no-g++-exceptions -plugin-sql-mysql -plugin-sql-psql -plugin-sql-sqlite

  cd $startdir/src/$pkgfqn/plugins/src/sqldrivers/mysql
  qmake -o Makefile "INCLUDEPATH+=/usr/include/mysql" "LIBS+=-L/usr/lib/mysql -lmysqlclient" mysql.pro
  cd $startdir/src/$pkgfqn/plugins/src/sqldrivers/psql
  qmake -o Makefile "INCLUDEPATH+=$startdir/src/postgresql-$psqlver" "LIBS+=-L/usr/lib/mysql -lmysqlclient" mysql.pro
  qmake -o Makefile "INCLUDEPATH+=$startdir/src/postgresql-$psqlver/src/include $startdir/src/postgresql-$psqlver/src/interfaces/libpq" "LIBS+=-L/usr/lib -lpq" psql.pro

  cd $startdir/src/$pkgfqn
  # fix the broken makefiles
  sed -i 's|[[:space:]]*strip.*doc/html.*$|#|g' src/Makefile

  # optimize the build
  sed -i "s:-O2:${CFLAGS}:g" mkspecs/linux-g++/qmake.conf

  make || return 1
  make INSTALL_ROOT=$startdir/pkg install
  rm $startdir/pkg/opt/qt/bin/qmake
  cp $startdir/src/$pkgfqn/qmake/qmake $startdir/pkg/opt/qt/bin
  install -D -m755 $startdir/qt.profile $startdir/pkg/etc/profile.d/qt.sh
}

Offline

Board footer

Powered by FluxBB