You are not logged in.

#1 2008-08-05 15:55:36

kaspi
Member
From: CERN, Geneva
Registered: 2007-10-05
Posts: 20
Website

problems with vesa video driver

Hello,

I'm experiencing a problem with my graphic card (ATI Radeon Xpress 200) - the X doesn't start. I guess I'm not the first one and hence, I'm asking for help...

The relevant part of my xorg.conf

Section "Device"
    Driver      "vesa"
EndSection

The /var/log/Xorg.0.log

(II) VESA(0): initializing int10
(II) VESA(0): Primary V_BIOS segment is: 0xc000
(II) VESA(0): VESA BIOS detected
(II) VESA(0): VESA VBE Version 2.0
(II) VESA(0): VESA VBE Total Mem: 16384 kB
(II) VESA(0): VESA VBE OEM: ATI RADEON XPRESS 200 Series
(II) VESA(0): VESA VBE OEM Software Rev: 1.0
(II) VESA(0): VESA VBE OEM Vendor: ATI Technologies Inc.
(II) VESA(0): VESA VBE OEM Product: RS48
(II) VESA(0): VESA VBE OEM Product Rev: 01.00
(**) VESA(0): Depth 24, (--) framebuffer bpp 24
(==) VESA(0): RGB weight 888
(==) VESA(0): Default visual is TrueColor
(==) VESA(0): Using gamma correction (1.0, 1.0, 1.0)
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"(II) Module "ddc" already built-in
(II) VESA(0): VESA VBE DDC supported
(II) VESA(0): VESA VBE DDC Level none
(II) VESA(0): VESA VBE DDC transfer in appr. 2 sec.
(II) VESA(0): VESA VBE DDC read failed
(II) VESA(0): Searching for matching VESA mode(s):

... many lines with mode parameters ...

(II) VESA(0): Total Memory: 256 64KB banks (16384kB)
(EE) VESA(0): No matching modes
(II) UnloadModule: "vesa"
(II) UnloadModule: "int10"
(II) Unloading /usr/lib/xorg/modules//libint10.so
(II) UnloadModule: "vbe"
(II) Unloading /usr/lib/xorg/modules//libvbe.so
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Do you have an idea what the problem might be?

Thanks in advance, Kaspi.

Offline

#2 2008-08-05 15:58:43

smurnjiff
Member
Registered: 2007-06-25
Posts: 211

Re: problems with vesa video driver

Well, you can either use the radeon Xorg module or the catalyst driver.  If you choose the latter, then:

mv /etc/X11/xorg.conf /etc/X11/xorg.conf_bak
aticonfig --initial --input=/etc/X11/xorg.conf

Offline

#3 2008-08-07 07:43:30

kaspi
Member
From: CERN, Geneva
Registered: 2007-10-05
Posts: 20
Website

Re: problems with vesa video driver

Thanks for reply. In fact, the vesa choice is just a fall back solution as I have problems with both readeon and catalyst driver. The radeon is actually running, but in a very funny resolution 1280x768 giving an oblong view of the world. With catalyst I was able to run kdm, but it hang shortly after successful login. Really, I don't know what to do... I'm just getting used to the prolate shapes :-) Anyway, thanks.

Cheers, Kašpi.

Offline

#4 2008-08-07 17:50:48

ghostHack
Member
From: Bristol UK
Registered: 2008-02-29
Posts: 261

Re: problems with vesa video driver

You need an Identifier line aswell as a Driver line in the Device section so that the Screen definition knows what to use.  As an example the Device and Screen sections from my corg.conf

Section "Device"
    Identifier     "Card0"
    Driver         "nvidia"
    VendorName     "nVidia Corporation"
    BoardName      "G71 [GeForce 7900 GT/GTO]"
Option "RenderAccel" "True"
Option "TripleBuffer" "True"
Option "BackingStore" "True"

EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    Option         "AddARGBGLXVisuals" "True"
    SubSection     "Display"
        Viewport    0 0
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       4
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       8
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       15
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
    EndSubSection
EndSection

Alternatively, have you tried just removing the xorg.conf and seeing what X's auto detection gives you?

Offline

Board footer

Powered by FluxBB