You are not logged in.

#26 2004-08-20 10:59:32

s3pHiRoTh
Member
From: Portugal
Registered: 2004-08-19
Posts: 12

Re: fonts still a problem

Yeah i noticed, i was just taking the K's as an example.

I've used slackware 9.1 for a long time and slackware 10 for some days on this machine (and still use it on my old desktop) and i never had any kind of problem like this. I have some time today, maybe i'll try recompiling X manually today and then i'll post something here.

Offline

#27 2004-08-20 16:02:34

murpheus40
Member
Registered: 2004-03-04
Posts: 77

Re: fonts still a problem

s3pHiRoTh wrote:

Yeah i noticed, i was just taking the K's as an example.

I've used slackware 9.1 for a long time and slackware 10 for some days on this machine (and still use it on my old desktop) and i never had any kind of problem like this. I have some time today, maybe i'll try recompiling X manually today and then i'll post something here.


I also use Slackware 10 and never had this problem. Last time I installed archlinux, the problem regarding letters like "k", "x" was there. This is why I removed archlinux. sad
Anyway, I'm going to re-install it on my new HDD and see if the problem persists again.

Offline

#28 2004-08-21 03:11:08

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: fonts still a problem

yeah, the font issue has been the main reason keeping arch off of my desktop. I use it for servers, but I like to have decent fonts on my desktop.. 
:shock:


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#29 2004-08-21 18:04:49

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: fonts still a problem

cactus wrote:

yeah, the font issue has been the main reason keeping arch off of my desktop. I use it for servers, but I like to have decent fonts on my desktop.. 
:shock:

yep, you are right. whatever the problem is, it's bad in arch. i posted an update in a related thread, here. i don't think arch is ever going to get a wide user base until it fixes the font problem. like you said, people want decent fonts in their gui.

Offline

#30 2004-08-21 20:16:27

inklingx
Member
From: Belgium
Registered: 2004-05-30
Posts: 18

Re: fonts still a problem

i have decent fonts, but only in gnome and after disabling the bytecode patch in the freetype package sad

example: http://home.pi.be/~gforce06/arch2.png

Offline

#31 2004-08-21 22:02:27

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: fonts still a problem

inklingx wrote:

i have decent fonts, but only in gnome and after disabling the bytecode patch in the freetype package sad

example: http://home.pi.be/~gforce06/arch2.png

those perhaps don't look too bad. gnome uses some sort of antialias trickery through gconf to give a "grayscale" option, but i couldn't figure out how to implement that system wide. but i'd almost rather use windows than gnome tongue (well, not really -- no offense if you like gnome), and besides 4 me it only worked in slackware on my laptop, not in arch. sad

Offline

#32 2004-08-24 10:36:53

s3pHiRoTh
Member
From: Portugal
Registered: 2004-08-19
Posts: 12

Re: fonts still a problem

To make it system wide you need to tweak your /etc/fonts/local.conf
However, that enables AA in xft enabled apps, what i want is that my fonts are rendered correctly. Altough AA minimizes the problem where it's used, this is not AA related at all.

Offline

#33 2004-08-24 11:33:50

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: fonts still a problem

Is the new xorg release going to change anything about font rendering?
http://freedesktop.org/XOrg/XorgReleasePlan

The following features are already included in the X.Org CVS tree on Freedesktop.Org

FreeType2 updated to v2.1.8
Retire XTT font module and FreeType1 (FreeType2 subsumes this functionality)
Retire old PS Type1 font rasterizer (except for CID font usage) since the FreeType2 rasterizer now handles PS Type1 (*.pfa, *.pfb)

hmmmm....

Offline

#34 2004-08-24 15:22:22

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: fonts still a problem

s3pHiRoTh wrote:

To make it system wide you need to tweak your /etc/fonts/local.conf
However, that enables AA in xft enabled apps, what i want is that my fonts are rendered correctly. Altough AA minimizes the problem where it's used, this is not AA related at all.

the question is, how to write "grayscale" into the AA options in the local.conf xml file so that it works -- if X even recognizes that parameter from there, and it's not just a thing specific to gconf. i've tried replacing a number of different variables in the "Enable sub-pixel rendering" strings with "grayscale," but none of them have worked, e.g.:

  <!--  Enable sub-pixel rendering  -->
        <match target="font">
                <test qual="all" name="rgba">
                        <const>unknown</const>
                </test>
                <edit name="rgba" mode="assign"><const>grayscale</const></edit>
        </match>

so if you could tell me how to enable grayscale system-wide so that my fonts look the way they do in the gnome shot below, i would appreciate it more than i could probably tell you. tongue

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

lanrat wrote:

Is the new xorg release going to change anything about font rendering?
http://freedesktop.org/XOrg/XorgReleasePlan

The following features are already included in the X.Org CVS tree on Freedesktop.Org

FreeType2 updated to v2.1.8
Retire XTT font module and FreeType1 (FreeType2 subsumes this functionality)
Retire old PS Type1 font rasterizer (except for CID font usage) since the FreeType2 rasterizer now handles PS Type1 (*.pfa, *.pfb)

hmmmm....

it might change things in areas unrelated to the spindly font problem, b/c some of us already are using freetype2 >2.1.7 with no help, and also without using XTT or freetype1 (even though it's still required to build stuff, etc., afaik, freetype2 is now taking over its duties). maybe the changes to the radeon driver will be helpful -- " Xv gamma correction" perhaps sounds promising (unless they're talking about something in the xv image program roll ).

but i've even queried the gurus on the freetype list, and no one can answer why fonts from a default install can look like this (crappy/broken):
http://synaptical.dyndns.org/fontconfig … _serif.png

and this (just about perfect):
http://synaptical.dyndns.org/fontconfig/gnome-slack.png

with the exact same configuration files. "it's the configuration, it's the local.conf, it's the DPI, it's the aa, it's the fonts." tongue okay, then tell me why one is perfect and one is broken, when they both have the same exact fonts and exact same config files? :?:

Offline

#35 2004-08-24 23:00:30

aCoder
Member
From: Medina, OH
Registered: 2004-03-07
Posts: 359
Website

Re: fonts still a problem

the question is, how to write "grayscale" into the AA options in the local.conf xml file so that it works -- if X even recognizes that parameter from there, and it's not just a thing specific to gconf. i've tried replacing a number of different variables in the "Enable sub-pixel rendering" strings with "grayscale," but none of them have worked,

Well, it's probably not in with the sub-pixel stuff, since that's only for LCDs.


If you develop an ear for sounds that are musical it is like developing an ego. You begin to refuse sounds that are not musical and that way cut yourself off from a good deal of experience.
  - John Cage

Offline

#36 2004-08-25 02:49:19

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: fonts still a problem

umm, i have an LCD. wink and that's where the grayscale option is in gconf, as opposed to rgb.

Offline

#37 2004-08-25 12:44:28

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: fonts still a problem

The fonts from the second (good) screenshot look like 1.5 of the "normal" weight. Look at any bold "a" or "e" characters - they are a little to bold IMO and unreadable. It's a very minor problem and the rest is much better than in the other screenshots (the first one is scary :shock:). I also coulnd't find anything that would improve font rendering. But I'm still not giving up - sooner or later someone has to find a solution....

Offline

#38 2004-08-25 18:25:20

nggalai
Member
From: Switzerland
Registered: 2004-08-01
Posts: 215
Website

Re: fonts still a problem

lanrat wrote:

The fonts from the second (good) screenshot look like 1.5 of the "normal" weight. Look at any bold "a" or "e" characters - they are a little to bold IMO and unreadable. It's a very minor problem and the rest is much better than in the other screenshots (the first one is scary :shock:). I also coulnd't find anything that would improve font rendering. But I'm still not giving up - sooner or later someone has to find a solution....

I agree. The second screenshot may have better kerning, but the font weight is way too heavy for the font.

93,
-Sascha.rb

Offline

#39 2004-08-25 18:26:27

aCoder
Member
From: Medina, OH
Registered: 2004-03-07
Posts: 359
Website

Re: fonts still a problem

umm, i have an LCD. wink and that's where the grayscale option is in gconf, as opposed to rgb.

Well, I don't have an LCD, but I still have grayscale smoothing.  Smoothing being it's location in GNOME's Font configuration dialog.


If you develop an ear for sounds that are musical it is like developing an ego. You begin to refuse sounds that are not musical and that way cut yourself off from a good deal of experience.
  - John Cage

Offline

#40 2004-08-25 19:54:46

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: fonts still a problem

aCoder wrote:

umm, i have an LCD. wink and that's where the grayscale option is in gconf, as opposed to rgb.

Well, I don't have an LCD, but I still have grayscale smoothing.  Smoothing being it's location in GNOME's Font configuration dialog.

acoder, what do you mean? that you have grayscale antialias in other desktops other than gnome?

what i'm talking about is when you go into the gconf editor and go down to "font rendering." there's an option for rgb, and when i change it to grayscale i get the good fonts as in the screenshot -- but only in gnome, and so far only on slack10 on my laptop. is that the same thing you are talking about, or some other configuration?

as for the fonts looking too heavy, imo that's just because we are so used to the spindly fonts. everything else is better -- look at that menu, and the mozilla menubar, how absolutely readable they are. if i used gnome regularly i would tweak the fonts smaller, but otherwise they are basically perfect. the shape of the capital W is also a clue -- with the good fonts, it looks normal, with the bad ones, the outside ends stick out at too much of an angle.

but i agree with lanrat, sooner or later we have to have a solution. it's just unacceptable to have fonts like in that first shot when everything is configured properly.

-- slackhack, the font lunatic big_smile

Offline

#41 2004-08-25 20:43:42

nggalai
Member
From: Switzerland
Registered: 2004-08-01
Posts: 215
Website

Re: fonts still a problem

slackhack wrote:

as for the fonts looking too heavy, imo that's just because we are so used to the spindly fonts.

Not really in my case--my day job's on a Windows box, OS-X sometimes. And fonts look "more right" on those systems. Anti-Aliasing should just, well, anti-alias edges, font weight should be about the same as if you had AA disabled. As far as I'm concerned, those "spindly" screen shots are more the way it's supposed to look than the other ones, just from the anti-aliasing perspective.

All IMO of course. smile

93,
-Sascha.rb

Offline

#42 2004-08-25 21:12:14

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: fonts still a problem

nggalai wrote:
slackhack wrote:

as for the fonts looking too heavy, imo that's just because we are so used to the spindly fonts.

Not really in my case--my day job's on a Windows box, OS-X sometimes. And fonts look "more right" on those systems. Anti-Aliasing should just, well, anti-alias edges, font weight should be about the same as if you had AA disabled. As far as I'm concerned, those "spindly" screen shots are more the way it's supposed to look than the other ones, just from the anti-aliasing perspective.

All IMO of course. smile

93,
-Sascha.rb

i do know what you mean, and it's hard to tell if the extra weight is from antialising or from some other aspect of the rendering.

what i do know is that when the fonts look the way they do in the gnome shot, *all* the fonts on the system in all applications look  really good (again in slack, basically perfect):
http://synaptical.dyndns.org/fontconfig … stream.png
http://synaptical.dyndns.org/fontconfig … erdana.png

and when the bitstream fonts look spindly, the other ones not only do NOT look good, but even sometimes (esp. in arch for some reason) look really, REALLY bad:
http://synaptical.dyndns.org/fontconfig … erdana.png
http://synaptical.dyndns.org/fontconfig … xisans.png

so that says to me that when you have the spindly fonts, something is wrong. but the first case is the way they *should* be, even if they sometimes need a little tweaking to adjust the weight (though in the first 2 in this post they do not, and the bolded characters are all perfect, too).

i think you are just more used to something like this, which is not correct: tongue
http://synaptical.dyndns.org/fontconfig … amvera.png

are you telling me you'd rather have those fonts than the ones in the first shot? i wouldn't. they're much too round and spindly == wrong. the difference is subtle, but once you begin to recognize it you can't get used to the substandard rendering. who in the linux community can fix this, is the question?

Offline

#43 2004-08-25 21:17:40

nggalai
Member
From: Switzerland
Registered: 2004-08-01
Posts: 215
Website

Re: fonts still a problem

slackhack wrote:

are you telling me you'd rather have those fonts than the ones in the first shot? i wouldn't.

Na, I'd rather have such fonts:

vera.gif

i.e. apart from the kerning errors, what I have right now.

93,
-Sascha.rb

Offline

#44 2004-08-25 21:19:07

aCoder
Member
From: Medina, OH
Registered: 2004-03-07
Posts: 359
Website

Re: fonts still a problem

acoder, what do you mean? that you have grayscale antialias in other desktops other than gnome?

what i'm talking about is when you go into the gconf editor and go down to "font rendering." there's an option for rgb, and when i change it to grayscale i get the good fonts as in the screenshot -- but only in gnome, and so far only on slack10 on my laptop. is that the same thing you are talking about, or some other configuration?

Alright, I wasn't using gconf-editor, mostly because I like to pretend gconf doesn't exist.  I just pulled it up though, and 'antialiasing' is set to 'grayscale'.  'rgb' does appear by 'rgba_order', but that key is only used when sub-pixel AA is enabled, which is only for LCDs, and only when 'antialiasing' is set to 'rgba' so I ignore it.  Since you have an LCD, you could try using 'rgba' instead of 'grayscale' then fooling with various sub-pixel order settings depending on your LCD, although, 9 times out of 10, you're going to want to use 'rgb' which is default. 

Not really in my case--my day job's on a Windows box, OS-X sometimes. And fonts look "more right" on those systems. Anti-Aliasing should just, well, anti-alias edges, font weight should be about the same as if you had AA disabled.  As far as I'm concerned, those "spindly" screen shots are more the way it's supposed to look than the other ones, just from the anti-aliasing perspective.

Actually, on a Windows system at least, the best option for rendering fonts is disabled by default.  You get nicer fonts by using the Cleartype method for font rendering as opposed to the Standard method.  My OS X fonts look just fine though, so, ummm...


If you develop an ear for sounds that are musical it is like developing an ego. You begin to refuse sounds that are not musical and that way cut yourself off from a good deal of experience.
  - John Cage

Offline

#45 2004-08-25 21:31:26

nggalai
Member
From: Switzerland
Registered: 2004-08-01
Posts: 215
Website

Re: fonts still a problem

aCoder wrote:

Actually, on a Windows system at least, the best option for rendering fonts is disabled by default.  You get nicer fonts by using the Cleartype method for font rendering as opposed to the Standard method.  My OS X fonts look just fine though, so, ummm...

I've been running Cleartype since I got my TFT screen. And I agree, that's the way to go on Windows.

93,
-Sascha.rb

Offline

#46 2004-08-25 21:59:54

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: fonts still a problem

Actually, on a Windows system at least, the best option for rendering fonts is disabled by default.  You get nicer fonts by using the Cleartype method for font rendering as opposed to the Standard method.

yes! i totally agree.

nggalai: sorry, but those are the spindlies. tongue you may prefer them, but they're not the good fonts.

Offline

#47 2004-08-26 12:08:52

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: fonts still a problem

Ooops. I knew I forgot to turn on something on my windows machine. Thanks for reminding me. I used http://www.microsoft.com/typography/cle … uner/1.htm to change the settings (I know, posting windows settings in linux forum.... ;-)) . There are some samples and screenshots how it should look. Now my windows fonts look like I want my linux fonts to look like :-)

Yesterday I reviewed some x font setup guides and all of them were saying almost only about subpixel settings. I already have everything set up as they say and still no effect. I could not find any other options which I could experiment with... This is very strange. The windows setup guide seems to also be about subpixel rendering only (same definitions like in  fonts-conf manual - rgb vs bgr, etc.). Not everything is perfect with cleartype (like the "s" character in times new roman font - not "bold" enough, some courier font characters not really displayed correctly in small size, etc.) and it needs some time to get used to it (I made a little expermint and turned on cleartype for a few people in my work - they didn't like it :-) Maybe they were using strandard rendering for to long...) but I think this is the right direction (verdana in bigger size really rocks!).

I don't know how gnome does this becuase local.conf from http://www.gnome.org/fonts/ is not really different then all we tried I think.

I found two great pages with links to other pages that are explaining everything in detail:
http://grc.com/ctwhat.htm
http://jmason.org/howto/subpixel.html
(I'm sure all people interested in fonts have already seen them but I'm posting them for other so they can see what are we exactly talking about).

One of those pages inludes an interesting patch for subpixel rendering
http://freedesktop.org/pipermail/fontco … 00905.html
If you look at the screenshots the second one (with patch applied) is much better and the first one is looking almost exactly as my screen looked in my first days with arch linux and X.

It seems the more I read the less I know :-) Now I'm completly unsure if subpixel should be turned off for crt or if it's harmless (some pages say it's harmless some say it shouldn't be turned on under any circumstances).

Well, I'm still investigating this...

PS. Everything suggests that the best results can be achieved only on lcds. Maybe I should change my crt to an lcd but I like my crt. It never failed me. And 19" lcds are not the cheapest things in the world... :?

Offline

#48 2004-08-27 15:56:53

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: fonts still a problem

lanrat wrote:

PS. Everything suggests that the best results can be achieved only on lcds. Maybe I should change my crt to an lcd but I like my crt. It never failed me. And 19" lcds are not the cheapest things in the world... :?

i have an LCD, and the fonts are no better -- in fact, they now look great instead on my roommate's CRT computer where i installed slackware. tongue the subpixel settings on my system aren't really doing much because of the (unknown) underlying problem. and regarding your question, i don't think having the subpixel rendering makes *that* much difference on a CRT, though it's probably better to have it off.

those advanced tips and tweaks are all definitely good to know, but in this case they don't really fully work because of whatever is wrong to begin with. the chester font hints are now in freetype2, and i've  tried freetype with and without those being enabled with no difference at all. so it's something else, something in X.

i think compiling XFree/xorg for one's own particular system might be the only way to get decent fonts, in slack at least. in arch it seems that something is "blocking" it from compiling or working right, with tons and tons of "punned-type pointer" errors breaking the strict aliasing rules (not the same aliasing regarding fonts wink).

so the question is how to compile xorg on arch? whenever i have tried a straight compile it has failed with a bunch of errors, and i would have no clue about doing a pkgbuild for it. but that might be something to work on this weekend. maybe it can work. i also just  subscribed to the xorg list, so i'm going to see if anyone knows anything there. maybe soon we can have this resolved and have the good fonts again (but don't hold your breath tongue).


p.s. fonts in the menus in fvwm look *really* good, but just too big. i haven't learned how to tweak fvwm yet to make them smaller. but in applications they still look crappy. it might just be how things are compiled in arch, and that there is no way around it without compiling everything yourself (which kind of defeats the purpose -- just use gentoo lol ).

Offline

#49 2004-08-30 11:20:21

s3pHiRoTh
Member
From: Portugal
Registered: 2004-08-19
Posts: 12

Re: fonts still a problem

Compiling Xorg in arch in order to build a package is not that difficult. Just go to your abs tree and look for the xorg directory and for it's PKGBUILD. then make a tmp dir, copy the PKGBUILD and the sources there and makepkg. I did and it solved nothing. However, it might be something that's being done in the PKGBUILD file, some compilation option or something. I have to mess it with those options for a while to see what i can get.

Offline

#50 2004-08-30 16:57:37

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: fonts still a problem

i tried it again, and this time it fails with an error pointing me here:
http://ep09.pld-linux.org/~mmazur/linux … aders/doc/

i guess it's because i've since tried using the ntpl glibc? anyway, any ideas what to do with those header files? do i just copy the directory into /usr/include?

Offline

Board footer

Powered by FluxBB