You are not logged in.

#1 2004-08-30 16:54:11

cereal
Member
From: Switzerland
Registered: 2004-08-29
Posts: 29
Website

jackd: weird startup problem

Hello there

I'm new here to the forums (and to Archlinux), so I hope this is more or less the right place to post this...

Well... I've got several problems concerning the jack-audio-connection-kit. Most of them, I think, are Hardware- or Kernel-Configuration specific, so I think I'm gonna post them elsewhere...

The one problem, I think, that *may be* arch-specific is, that everytime I boot my box, it says something like:

:: Starting Jack Audio Connection-Kit Daemon [DONE]
/etc/rc.d/jack-audio-connection-kit: line 11: 1159 Aborted
/usr/bin/jackd $SERVER_PARAMS -d $DRIVER_PARAMS &>/dev/null

So... I redirected output of jackd and what it says is:

jackd 0.98.1
Copyright 2001-2003 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with System V SHM support
loading driver ..
creating alsa driver ... hw:0|hw:0|1024|8|48000|0|0|nomon|swmeter|-|32bit
ALSA lib pcm_hw.c:1155:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: No such file or directory
jackd: pcm.c:690: snd_pcm_nonblock: Assertion `pcm' failed.

The funny thing is, that, when I start jack later on (either using the startup script or manually), jack doesn't fail (at least not at this point... but that's another story). I also looked for this /dev/snd/pcmC0D0p device and at least when the system is up and running, this device exists. So... anyone got an idea of what may cause this problem?

Thanks in advance...


"I watched a snail crawl along the edge of a straight razor. That's my dream. That's my nightmare." - (Kurtz, Apocalypse Now)

A few PKGBUILDs

Offline

#2 2004-08-30 17:50:48

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: jackd: weird startup problem

You may be starting jackd too soon.  The alsa devices may not have been created at that point.

Also, if you don't think it's a newbie question or that you're a newbie then you probably want to post it in something like Package Config Problems.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#3 2004-08-30 18:03:40

cereal
Member
From: Switzerland
Registered: 2004-08-29
Posts: 29
Website

Re: jackd: weird startup problem

You may be starting jackd too soon. The alsa devices may not have been created at that point.

Jack is the last daemon started and for example the alsamixer volume restoration script works flawlessly (it runs just before the jack script, but I think this script shouldn't have any impact on wether jack starts or not)

Also, if you don't think it's a newbie question or that you're a newbie then you probably want to post it in something like Package Config Problems.

Well... I'm an Arch Linux newbie, jack newbie... Anyway, thanks for the information. I didn't realize, I could post it there, but actually that would make sense...


"I watched a snail crawl along the edge of a straight razor. That's my dream. That's my nightmare." - (Kurtz, Apocalypse Now)

A few PKGBUILDs

Offline

#4 2004-08-31 07:06:19

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: jackd: weird startup problem


The impossible missions are the only ones which succeed.

Offline

#5 2004-08-31 08:32:03

cereal
Member
From: Switzerland
Registered: 2004-08-29
Posts: 29
Website

Re: jackd: weird startup problem

Nope... though I had the first one. But I rebuilt jack with abs (I didn't modify the PKGBUILD!), so the readline issue got resolved. But I never came across the second bug.


"I watched a snail crawl along the edge of a straight razor. That's my dream. That's my nightmare." - (Kurtz, Apocalypse Now)

A few PKGBUILDs

Offline

Board footer

Powered by FluxBB