You are not logged in.

#1 2004-09-07 23:09:49

Dreameen
Member
From: Poland
Registered: 2004-09-06
Posts: 252

Power Off

The problem is that when i type $halt as root the system goes down, console writes out: Power Off, Power Down but strangely enough i have to turn the computer off manually.

What setting is responsible for thic "half shutdown" behaviour???

Offline

#2 2004-09-08 15:18:08

Dreameen
Member
From: Poland
Registered: 2004-09-06
Posts: 252

Re: Power Off

Really. This is the last issue i have with arch. How to force it to Power Down completely???

Every time i $shutdown -h now or $halt or $init 0 my computer is still turned on and i have to push the Power button..

Offline

#3 2004-09-08 15:25:17

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: Power Off

try acpi=force on startup and then when you don't have trouble
add this to your lilo or grub bootmanager

Offline

#4 2004-09-08 15:27:51

Bobonov
Member
From: Roma - Italy
Registered: 2003-05-07
Posts: 295

Re: Power Off

You have to enable acpi support at kernel load
if you use gru just add
acpi=on acpi=power-off
at the end of the line where you load the kernel
kernel (hd0,0)/vmlinuz26.........

For lilo you should use (not 100% sure)
option="acpi=on acpi=power-off"

If it does not work probably you need to enable some compability option for your motherboard, there should be some topics in the forum about that.
P.S.
Always try to search in the forum, most of the question already have an answer, like this one

Offline

#5 2004-09-08 16:31:26

Dreameen
Member
From: Poland
Registered: 2004-09-06
Posts: 252

Re: Power Off

sad
I edited grub.lst and added acpi=on acpi=power-off at the end of the kernel line and i get following error when i trz to load arch:

Error 11: Unrecognized device string

How to remove the changes from grub.lst without being able to log into command line..

Ps. I am writing this post from another machine.

Offline

#6 2004-09-08 16:33:41

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: Power Off

on grub prompt
use 'e'
to edit the commands that are passed to it
then use 'b' to boot
i thought of adding this to the line first
without change the menu.lst

Offline

#7 2004-09-08 16:35:10

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: Power Off

i don't think acpi=on will work if your bios is older than 2000/2001
there you should use acpi=force

Offline

#8 2004-09-08 17:20:01

Dreameen
Member
From: Poland
Registered: 2004-09-06
Posts: 252

Re: Power Off

Thank you very much tpowa smile

acpi=force works like charm...moving along..

Offline

Board footer

Powered by FluxBB