You are not logged in.

#1 2004-09-11 13:53:06

Namlook
Member
From: France / Montpellier
Registered: 2004-05-30
Posts: 74

$£*#!& mplayer problem (to slow playing dvd) [SOLVED]

Ok. Got problem with reading dvd.

When I start mplayer the dvd's starting but the sound and the image are not synchronized and mplayer tell me that :

 ************************************************
           **** Your system is too SLOW to play this!  ****
           ************************************************

Possible reasons, problems, workarounds:
- Most common: broken/buggy _audio_ driver
  - Try -ao sdl or use ALSA 0.5 or the OSS emulation of ALSA 0.9.
  - Experiment with different values for -autosync, 30 is a good start.
- Slow video output
  - Try a different -vo driver (-vo help for a list) or try -framedrop!
- Slow CPU
  - Don't try to play a big DVD/DivX on a slow CPU! Try -hardframedrop.
- Broken file
  - Try various combinations of -nobps -ni -forceidx -mc 0.
- Slow media (NFS/SMB mounts, DVD, VCD etc)
  - Try -cache 8192.
- Are you using -cache to play a non-interleaved AVI file?
  - Try -nocache.
Read DOCS/HTML/en/devices.html for tuning/speedup tips.
If none of this helps you, read DOCS/HTML/en/bugreports.html.

yes dma is enable :

/dev/dvd:
 using_dma    =  1 (on)

I think is a sound problem cause when I swith of the sound, it's all fine. But I can find where is this sound problem.

I use kernel-2.6.8.1 on a wombat ArchBox.
I install the alsa-lib, alsa-utils, alsa-driver

my modprobe.conf :

#
# /etc/modprobe.conf (for v2.6 kernels)
#

alias /dev/nvidia*   nvidia
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.6 ---
options snd  device_mode=0666
alias snd-card-0 snd-cmipci
alias sound-slot-0 snd-cmipci
# --- END: Generated by ALSACONF, do not edit. ---

duno what's the problem...  :cry:

HELP !

Offline

#2 2004-09-11 14:28:59

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: $£*#!& mplayer problem (to slow playing dvd) [SOLVED]

well if you are using kernel 2.6.x you don't need to install external alsa package sunless one of your packages may require the alsa lib or something.

next your dma is on but perhaps you need to pass other option as well. i had shakey dvd playback until i used this :

hdparm -d 1 -X34 -k 1 /drive/path


AKA uknowme

I am not your friend

Offline

#3 2004-09-12 16:29:49

Namlook
Member
From: France / Montpellier
Registered: 2004-05-30
Posts: 74

Re: $£*#!& mplayer problem (to slow playing dvd) [SOLVED]

love you Sarah !

It finally works with :
- MPlayer 1.0pre4-3.4.0
- Your great line : hdparm -d 1 -X34 -k 1 /drive/path (dud how fast is it ! I use it for my cdrom too)
- I had to add -framedrop flag.

thanks a lot !   big_smile

Namlook

Offline

#4 2004-09-12 18:05:34

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: $£*#!& mplayer problem (to slow playing dvd) [SOLVED]

consider:

 -X   set IDE xfer mode (DANGEROUS)

The impossible missions are the only ones which succeed.

Offline

#5 2004-09-13 03:04:27

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: $£*#!& mplayer problem (to slow playing dvd) [SOLVED]

pfft i used it for well over a year without a problem. Just don't set something outside tha capabilities of your drive.


AKA uknowme

I am not your friend

Offline

Board footer

Powered by FluxBB