You are not logged in.

#1 2004-07-30 15:48:15

Cobra
Member
Registered: 2004-07-30
Posts: 98

Problem with ARTS [fixed]

I'm new to this forum so first of all I want to say hello.
I got interested in archlinux because a friend of mine told me about the interesting packaging system and the performance of archlinux (however this is not my concern, I don't use linux for setting up a server or something smile )

Anyways I tried it and I liked it from the start. I've got most of the things working well with kernel 2.6 (the one on the CD of arch 0.6)

There is one problem though. I can't seem to get arts to work. Every time I start up the deamon, it's complaining about alsa-lib or something.

this is what I did:
[laurens@Nectar]-[/home/laurens]-83-$> artsd

unix_connect: can't connect to server (unix:/tmp/mcop-laurens/Nectar-1954-410a6da3)
ALSA lib pcm_hw.c:549:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
ALSA lib pcm_hw.c:549:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe

after <ctrl-c>I tried
$> artds -l 0 (level 0 = debugging)
and got the following output:

[laurens@Nectar]-[/home/laurens]-79-$> artsd -l 0
artsd version is 1.2.3
gsl: using Unix98 pthreads directly for mutexes and conditions
[artsd:  6356] SoundServerStartup --> got lock
autodetecting driver: 
 - toss: 4
 - esd: -1
 - null: -1
 - alsa: 11
 - oss: 10
... which means we'll default to alsa
ALSA driver: default
buffering: 7 fragments with 1024 bytes (audio latency is 40.6 ms)
ALSA lib pcm_hw.c:549:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
Closing ALSA-driver
virtualize StereoVolumeControl
ALSA driver: default
buffering: 7 fragments with 1024 bytes (audio latency is 40.6 ms)
ALSA lib pcm_hw.c:549:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
Closing ALSA-driver
virtualize StereoVolumeControl
ALSA driver: default
buffering: 7 fragments with 1024 bytes (audio latency is 40.6 ms)
ALSA lib pcm_hw.c:549:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
audio format is 44100 Hz, 16 bits, 2 channels
addDirectory(/opt/kde/lib/mcop,)
addDirectory(/opt/kde/lib/mcop/Arts,Arts)
addDirectory(/home/laurens/.mcop/trader-cache,)
addDirectory(/opt/kde/lib/mcop,)
addDirectory(/opt/kde/lib/mcop/Arts,Arts)
addDirectory(/home/laurens/.mcop/trader-cache,)
[artsd:  6356] SoundServerStartup <-- released lock

then I had to <ctrl-c>:

Synth_PLAY: closing audio fd
Closing ALSA-driver

This is my lsmod output:

[laurens@Nectar]-[/home/laurens]-81-$> lsmod
Module                  Size  Used by
ipt_MASQUERADE          3456  1 
iptable_nat            22692  2 ipt_MASQUERADE
ip_conntrack           30220  2 ipt_MASQUERADE,iptable_nat
iptable_filter          2560  1 
ip_tables              17152  3 ipt_MASQUERADE,iptable_nat,iptable_filter
parport_pc             22976  1 
lp                      9608  0 
parport                36808  2 parport_pc,lp
ppp_synctty             8320  0 
ppp_async              10624  1 
ppp_generic            27412  6 ppp_synctty,ppp_async
slhc                    6912  1 ppp_generic
8139too                22272  0 
mii                     4864  1 8139too
sis900                 18308  0 
crc32                   4352  2 8139too,sis900
tsdev                   6016  0 
joydev                  8640  0 
evdev                   7936  0 
snd_pcm_oss            51880  0 
snd_mixer_oss          18304  1 snd_pcm_oss
snd_intel8x0           32556  1 
snd_ac97_codec         68356  1 snd_intel8x0
snd_pcm                91780  2 snd_pcm_oss,snd_intel8x0
snd_timer              23556  1 snd_pcm
snd_page_alloc          9480  2 snd_intel8x0,snd_pcm
gameport                3968  1 snd_intel8x0
snd_mpu401_uart         7040  1 snd_intel8x0
snd_rawmidi            21540  1 snd_mpu401_uart
snd_seq_device          6920  1 snd_rawmidi
snd                    50276  11 snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               8160  1 snd
ohci_hcd               20484  0 
rtc                    11976  0 
nls_cp850               4992  1 
vfat                   12928  1 
fat                    41632  1 vfat
nls_iso8859_15          4736  4 
ntfs                  119660  3

For the record: I can play sound easily with alsa, so that's no problem at all. I just want to get rid of the sounds that are placed in a stack or something while I'm listening to music. I want it to play all together. Already tried ESD but that makes my sound ugly.

Any help appreciated.

Offline

#2 2004-08-02 17:37:07

Cobra
Member
Registered: 2004-07-30
Posts: 98

Re: Problem with ARTS [fixed]

I can't believe I'm the only person having problems with arts....
suggestions anyone?

Offline

#3 2004-08-02 17:50:10

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: Problem with ARTS [fixed]

is your system up-to-date? ( pacman -Suy )


The impossible missions are the only ones which succeed.

Offline

#4 2004-08-03 11:33:13

Cobra
Member
Registered: 2004-07-30
Posts: 98

Re: Problem with ARTS [fixed]

Yes, it is. I do pacman -Syu every day.

Offline

#5 2004-08-03 11:42:05

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: Problem with ARTS [fixed]

i cannot reproduce your problem

why do you want to start artsd manually? if a kde-app wants to use artsd, it starts it automatically (i use xfce4 or ion and if i start a kde-app, kdeinit makes sure, arts works)

EDIT:
i managed to reproduce, at least aproximately, your broken pipe:

[damir@Asteraceae /]$ artsd
ALSA lib pcm_hw.c:549:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
ALSA lib pcm_hw.c:549:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
can't register Arts::MidiManager
There are already artsd objects registered, looking if they are active...
ALSA lib pcm_hw.c:549:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe

Error: Can't add object reference (probably artsd is already running).
       If you are sure it is not already running, remove the relevant files:

       /tmp/mcop-damir/Arts_SoundServerV2
       /tmp/mcop-damir/Arts_SoundServer
       /tmp/mcop-damir/Arts_SimpleSoundServer
       /tmp/mcop-damir/Arts_PlayObjectFactory
       /tmp/mcop-damir/Arts_AudioManager

this happens, if i run artsd, if it already is running, so it is maybe not the same

good luck


The impossible missions are the only ones which succeed.

Offline

#6 2004-08-03 17:47:33

Cobra
Member
Registered: 2004-07-30
Posts: 98

Re: Problem with ARTS [fixed]

I start it manually to check if there will be any problems. Obviously there are problems. I'll try to start it as a deamon and post what happens.
Thanks smile


*edit: I cannot locate arts in /etc/rc.d/
How can I start it at boot?

*edit 2: I use fvwm2 as window manager, if that could be useful to you.

Offline

#7 2004-08-04 12:56:27

Cobra
Member
Registered: 2004-07-30
Posts: 98

Re: Problem with ARTS [fixed]

You also said that a kde-app starts arts automatically. I tried to open xmms with the arts-plugin. I got the following error if I tried to start playing an mp3 file:

artsxmms_open(): Unable to initialize aRts: can't connect to aRts soundserver
Message: Init failed: 1

<ctrl-c>

Offline

#8 2004-08-04 19:58:37

Cobra
Member
Registered: 2004-07-30
Posts: 98

Re: Problem with ARTS [fixed]

Oh another question, maybe I don't have KDE init... how can I get it? KDEinit gives no results on the package searchengine.

Offline

#9 2004-08-04 20:27:39

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: Problem with ARTS [fixed]

Cobra wrote:

Oh another question, maybe I don't have KDE init... how can I get it? KDEinit gives no results on the package searchengine.

i'm not sure, but it is either in kdelibs or kdebase


The impossible missions are the only ones which succeed.

Offline

#10 2004-08-04 21:24:57

Cobra
Member
Registered: 2004-07-30
Posts: 98

Re: Problem with ARTS [fixed]

artsd still gives the same errors.

Offline

#11 2004-08-04 21:55:58

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: Problem with ARTS [fixed]

i discussed with some of the kde-users i know (mostly gentooers, but still ok as human beings) and the only thing we got to stop arts from starting, if everything was ok setup, is that either arts is already running or some other app/daemon uses the soundcard

are you sure, no other daemon is runnign (esd, jack, ...)?

is there nobody around to use arts but not kde?

the only situation i use arts is, when i use amarok - try installing amarok and try to play someting in it - it should load arts automatically; and if it fails, watch the console for maybe other infos


The impossible missions are the only ones which succeed.

Offline

#12 2004-08-04 22:17:10

Cobra
Member
Registered: 2004-07-30
Posts: 98

Re: Problem with ARTS [fixed]

I tried to play with arts plugin and got this:

artsxmms_open(): Unable to initialize aRts: can't connect to aRts soundserver
Message: Init failed: 1

if this could be useful:

MODULES=(!usbserial !ide-scsi ohci_hcd snd-intel8x0 snd-pcm-oss)
DAEMONS=(syslogd klogd !pcmcia network adsl netfs hotplug crond samba cups iptables alsamixer numlock)

Offline

#13 2004-08-09 18:44:20

Sly McFly
Member
Registered: 2004-01-02
Posts: 10

Re: Problem with ARTS [fixed]

I get the same problem too. The weird thing is that my sound worked a few days ago.  All my modules are loaded and the sound is turned up in alsamixer, but I get the same arts error. It's also strange because I don't get any errors when using alsa, the music players act like there's nothing wrong and play the music even though nothing is coming out of my speakers.

Offline

#14 2004-08-09 21:32:43

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: Problem with ARTS [fixed]

just wondering ... what libpng and glibc do you use? are they the same as in current? if not, try to -Suy


The impossible missions are the only ones which succeed.

Offline

#15 2004-08-09 22:17:48

Sly McFly
Member
Registered: 2004-01-02
Posts: 10

Re: Problem with ARTS [fixed]

All of my packages are up to date. There are two times when I did something radical to my machine this past week, one was installing a USB 2.0 pci card, the other was when I installed KDE. That's the only thing I can think of that might possible lead to problems. I have no idea why my sound will not work.

Offline

#16 2004-08-17 15:18:48

Cobra
Member
Registered: 2004-07-30
Posts: 98

Re: Problem with ARTS [fixed]

I also have the latest versions of all packages.

Offline

#17 2004-08-20 20:02:57

Cobra
Member
Registered: 2004-07-30
Posts: 98

Re: Problem with ARTS [fixed]

Hey boys, I fixed it myself without needing arts!

I made /etc/asound.conf and added this:

pcm.dsp0 {
  type plug
  slave.pcm "dmixer"
}

pcm.!default {
  type plug
  slave.pcm "dmixer"
}

pcm.dmixer {
  type dmix
  ipc_key 3950183
  slave {
    pcm "hw:0,0"
    rate 44100
    period_time 0
    period_size 1024
    buffer_size 8192
  }
  bindings {
    0 0
      }
}

ctl.mixer0 {
 type hw
 card 0
}1 1

Now I use amsn, totem and xmms with alsa and everything mixes just fine. Everybody: thanks for your help.

Offline

#18 2004-08-20 23:09:59

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: Problem with ARTS [fixed]

Err... this doesn't look like the most obvious solution.
Where did you find the info about it?

Offline

#19 2004-08-21 16:03:53

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: Problem with ARTS [fixed]

I guess it's from one of the alsa sites, isn't it?
I posted some info and links a while ago:
http://bbs.archlinux.org/viewtopic.php? … light=alsa

Check these out:
http://alsa.opensrc.org/index.php?page=DmixPlugin
http://alsa.opensrc.org/index.php?page= … are+mixing
(I don't use it but found it while searching for something else)

Offline

#20 2004-08-28 19:28:21

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,431
Website

Re: Problem with ARTS [fixed]

i have this prob too!  and yes my system is up to date.  i was using esd till recently but for some reason my cpu has started to do 100% spikes every 5 seconds (exactly) and it makes the esd audio skip - alsa and oss playback unaffected - so i was trying to swap all my sounds over to arts but, as i said, i am having the same issues.

1. when i use the arts plugin in xmms i get:

artsxmms_open(): Unable to initialize aRts: can't connect to aRts soundserver

2. when i try to start the daemon i get:

ALSA lib pcm_hw.c:549:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
ALSA lib pcm_hw.c:549:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe

i may try cobras fix but i'd like to know what it does first! big_smile

Offline

#21 2004-09-15 18:16:33

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,431
Website

Re: Problem with ARTS [fixed]

i would like to add some hints to this post as this is by far only half the story.

1st - his /etc/asound.conf is wrong

pcm.dsp0 {
  type plug
  slave.pcm "dmixer"
}

pcm.!default {
  type plug
  slave.pcm "dmixer"
}

pcm.dmixer {
  type dmix
  ipc_key 3950183
  slave {
    pcm "hw:0,0"
    rate 44100
    period_time 0
    period_size 1024
    buffer_size 8192
  }
  bindings {
    0 0
      }
}

ctl.mixer0 {
 type hw
 card 0
}1 1 

notice the 1 1 at the end? i always wondered why that was - it should be here:

  bindings {
    0 0
    1 1
      }

otherwise you'll be scratching your ass wondering why you only get sound in one speaker.

Now, for each app.

The settings that work for me are:

xmms - change output plugin to ALSA - click configure - in the audio device combo box type "dmixer" - click apply and xmms is set

xine - open up the setup (change you settings to master of the know universe and restart if you have not already) - click the audio tab - change device used for mono/stereo output to dmixer - scroll down and change audio driver to use to alsa - apply and restart

gaim - just set sounds to auto and test - if it doesn't work when playing another sound tell it to use command and use aplay

gkrellm - play all your alerts with aplay - if you have used another app before and need to change all you alerts do it the smart way! - killall gkrellm - change to your ~/.gkrellm dir - open user config with gvim and find and replace all instances of your old app e.g. esdplay (uhhh), with aplay - much easier than using the configurator.

could this go in the wiki with more apps added?

Offline

Board footer

Powered by FluxBB