You are not logged in.

#1 2004-09-14 01:14:10

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Problem reinstalling lilo in sata disc.

I've decided to update my kernel to 2.6.8.1-3 (i've been using 2.6.7), and I read that it names sata discs as sda, not hde as 2.6.7 did. I tried to reinstall lilo, changing the root line to /dev/sda6, but it won't install, arguing that sda6 does not exist. I tried this:
cp /dev/hde6 /dev/sda6, but had catastrophic consecuences, as I ran out of RAM, swap and had to reboot. Now I can't boot, as I did not reinstall lilo. Anyway, I know how to fix that; what I want to know is how can I reinstall lilo, if sda does not exist (once I fix this mess). I use udev.


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#2 2004-09-14 08:47:31

Cobra
Member
Registered: 2004-07-30
Posts: 104

Re: Problem reinstalling lilo in sata disc.

try to make a symlink with the udev rules file:

edit (or touch) /etc/udev/rules.d/00-myrules.rules

KERNEL="hde6", SYMLINK="sda6"

Offline

#3 2004-09-14 16:27:58

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: Problem reinstalling lilo in sata disc.

I tried that, and lilo was installed, but I could not boot, because it gave me a VFS: Can't mount root filesystem on blablabla
and then kernel panic.
The strangest of all, is that kernel 2.6.7 used to work fine for me, but now I recompiled it with the  2.6.8.1-3 config from abs, and it gave me the same problem, about not mounting the root device. I've tryed both sda and hde, and still can't make the kernel work. Kernel 2.6.3 from the 0.6 repo works fine.


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#4 2004-09-15 20:15:43

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: Problem reinstalling lilo in sata disc.

I changed to grub, and now everything works fine, with any kernel.


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

Board footer

Powered by FluxBB