You are not logged in.

#1 2004-09-15 21:56:12

beniro
Member
From: St. Petersburg, FL, USA
Registered: 2002-12-31
Posts: 312

3d Acceleration on two monitors with nvidia?

Is there any way to get two monitors that are running on the same pc and kernel BOTH be 3d accelerated in X?

Like two instances of X or two instances of the WM...or...something?  I have an nvidia card for both of my monitors and would like both accelerated...

Is this possible?  Can I use the "nvidia" (as opposed to "nv") driver for both?

I'm unclear on this issue, any help would be appreciated.

Offline

#2 2004-09-15 23:16:55

paranoos
Member
From: thornhill.on.ca
Registered: 2004-07-22
Posts: 442

Re: 3d Acceleration on two monitors with nvidia?

try reading nvidia's documentation about twinview in linux.

i'm currently using twinview to clone my primary display onto my tv. of course, both are accelerated, because they're displaying the same thing.

twinview can be configured to have two monitors side by side displaying two desktops. hopefully something in those docs will help you configure it the way you want.

Offline

#3 2004-09-15 23:27:33

contrasutra
Member
From: New Jersey
Registered: 2003-07-26
Posts: 507

Re: 3d Acceleration on two monitors with nvidia?

I have two separate Nvidia cards running two monitors with Xinerama. Both use the nvidia driver just fine. One card is a TNT2 PCI, so I don't really know if it's accelerated or not. tongue


"Contrary to popular belief, penguins are not the salvation of modern technology.  Neither do they throw parties for the urban proletariat."

Offline

#4 2004-09-15 23:53:27

beniro
Member
From: St. Petersburg, FL, USA
Registered: 2002-12-31
Posts: 312

Re: 3d Acceleration on two monitors with nvidia?

Thanks a bunch to you both.

Strangely, I had gotten used not getting much info from the actual vendors of my hardware about Linux support, so I hadn't checked with nvidia.  D'oh!

I've tried loading the nvidia module for both my nvidia cards, and that didn't work, but that was before xorg 6.8.  I will explore more and report back.

Thanks for the leads, guys!  smile

Offline

#5 2004-09-16 08:15:02

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: 3d Acceleration on two monitors with nvidia?

I have one gforce4 installed and it's connected to my monitor and tv. I don't use any twinview mode to have two different X screens with different resolutions and window managers (1600x1200x85Hz xfce4 for the monitor and 1024x768 kahakai or pure x for the tv). Both screens are 2d/3d accelerated (you should see if it's enabled in your xorg log in /var/log). I have no problem with running bzflag or mplayer (IMO this is the best setting for the fullscreen mode, better than clonning at least :-)).

All kinds of setup are covered in the nvidia readme file - you just have to read it carefully including all (well most) appendixes :-)
In your case I would suspect two things:
1. simple syntax errors or not fully configured separate screens/displays in your xorg.conf
2. no pci settings in xorg.conf (check nvidia readme - this setting it's very important - it won't work well without it). I guess this setting is equally very important for one or more cards (the driver has to know which pci slot to use for which screen).

If you post your current settings maybe we could help you more.

Offline

#6 2004-09-16 17:00:47

beniro
Member
From: St. Petersburg, FL, USA
Registered: 2002-12-31
Posts: 312

Re: 3d Acceleration on two monitors with nvidia?

I do have the pci bus settings for both of the monitors included in the xorg.conf file.

If I try to use the "nvidia" module for both the cards, both monitors go black when I startx.

I had to press the reset button on the tower...how do you kill x when blind (both monitors black)???

I'm at work right now...will do some additional explorations tonight and report back...hopefully all will become a 3d accelerated, dropshadowed, translucent, noisy, crazy, beautiful and utterly useless multimedia experience!  smile

Offline

#7 2004-09-16 17:54:21

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: 3d Acceleration on two monitors with nvidia?

beniro wrote:

If I try to use the "nvidia" module for both the cards, both monitors go black when I startx.

Just try google first like this for example:
http://www.google.com/search?num=100&hl … tnG=Search
First result gives an example of x config for dual monitor using nvidia driver. Also to have separate screens try to use info from ftp://download.nvidia.com/XFree86/Linux … README.txt Appendix R - it's for two screens using one card but I guess you could try changing busid for the second screen and maybe it will work?

beniro wrote:

I had to press the reset button on the tower...how do you kill x when blind (both monitors black)???

From man Xorg:

Ctrl+Alt+Backspace
               Immediately kills the server -- no questions asked.   This  can
               be disabled with the DontZap xorg.conf(5x) file option.

beniro wrote:

I'm at work right now...will do some additional explorations tonight and report back...

Ok. Don't forget to check your dmesg output and of course /var/log/Xorg.0.log for any errors/warnings.

beniro wrote:

hopefully all will become a 3d accelerated, dropshadowed, translucent, noisy, crazy, beautiful and utterly useless multimedia experience!  smile

lol

Offline

#8 2004-09-19 20:07:29

beniro
Member
From: St. Petersburg, FL, USA
Registered: 2002-12-31
Posts: 312

Re: 3d Acceleration on two monitors with nvidia?

I finally had a chance to do some more exploration.

Currently, I've got two fluxboxes running across my monitors (no xinerama right now).  The only thing I don't like is that I still can't get the "nvidia" driver to work for both displays.

Strangely enough, when I try to use the "nvidia" module for both, upon "startx" both monitors go black and ctl + alt + backspace won't kill X, I have to hit the reset button.

Here is the log generated after both monitors going blank.  Any help would be very appreciated:

<----------I editted a few lines out here and there in the log, due to the forums truncating the message.  I editted in particular the long series of line starting with NV or NVIDIA and then a bunch of resolutionm combos.  let me know if there is something particular you want me to post. ---------->

(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="X.Org Foundation"
    compiled for 6.8.1, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="X.Org Foundation"
    compiled for 6.8.1, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="X.Org Foundation"
    compiled for 6.8.1, module version = 1.0.2
    Module class: X.Org Font Renderer
    ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "speedo"
(WW) Warning, couldn't open module speedo
(II) UnloadModule: "speedo"
(EE) Failed to load module "speedo" (module does not exist, 0)
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
    compiled for 6.8.1, module version = 2.1.0
    Module class: X.Org Font Renderer
    ABI class: X.Org Font Renderer, version 0.4
(II) Loading font FreeType
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.6106
    Module class: XFree86 Video Driver
(II) LoadModule: "nv"
(II) Loading /usr/X11R6/lib/modules/drivers/nv_drv.o
(II) Module nv: vendor="X.Org Foundation"
    compiled for 6.8.1, module version = 1.0.1
    Module class: X.Org Video Driver
    ABI class: X.Org Video Driver, version 0.7
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="X.Org Foundation"
    compiled for 6.8.1, module version = 1.0.0
    Module class: X.Org XInput Driver
    ABI class: X.Org XInput driver, version 0.4
(II) LoadModule: "keyboard"
(II) Loading /usr/X11R6/lib/modules/input/keyboard_drv.o
(II) Module keyboard: vendor="X.Org Foundation"
    compiled for 6.8.1, module version = 1.0.0
    Module class: X.Org XInput Driver
    ABI class: X.Org XInput driver, version 0.4
(II) NVIDIA X Driver  1.0-6106  Wed Jun 23 08:14:45 PDT 2004
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) NV: driver for NVIDIA chipsets: RIVA 128, RIVA TNT, RIVA TNT2,
    Unknown TNT2, Vanta, RIVA TNT2 Ultra, RIVA TNT2 Model 64,
    Aladdin TNT2, GeForce 256, GeForce DDR, Quadro, GeForce2 MX/MX 400,
    GeForce2 MX 100/200, GeForce2 Go, Quadro2 MXR/EX/Go,
    GeForce2 Integrated GPU, GeForce2 GTS, GeForce2 Ti, GeForce2 Ultra,
    Quadro2 Pro, GeForce4 MX 460, GeForce4 MX 440, GeForce4 MX 420,
    GeForce4 MX 440-SE, GeForce4 440 Go, GeForce4 420 Go,
    GeForce4 420 Go 32M, GeForce4 460 Go, GeForce4 440 Go 64M,
    GeForce4 410 Go 16M, Quadro4 500 GoGL, Quadro4 550 XGL, Quadro4 NVS,
    GeForce4 MX 440 with AGP8X, GeForce4 MX 440SE with AGP8X,
    GeForce4 MX 420 with AGP8X, GeForce4 448 Go, GeForce4 488 Go,
    Quadro4 580 XGL, Quadro4 280 NVS, Quadro4 380 XGL,
    GeForce4 MX Integrated GPU, GeForce3, GeForce3 Ti 200,
    GeForce3 Ti 500, Quadro DCC, GeForce4 Ti 4600, GeForce4 Ti 4400,
    0x0252, GeForce4 Ti 4200, Quadro4 900 XGL, Quadro4 750 XGL,
    Quadro4 700 XGL, GeForce4 Ti 4800, GeForce4 Ti 4200 with AGP8X,
    GeForce4 Ti 4800 SE, GeForce4 4200 Go, Quadro4 700 GoGL,
    Quadro4 980 XGL, Quadro4 780 XGL, GeForce FX 5800 Ultra,
    GeForce FX 5800, Quadro FX 2000, Quadro FX 1000,
    GeForce FX 5600 Ultra, GeForce FX 5600, 0x0313, GeForce FX 5600SE,
    0x0316, 0x0317, GeForce FX Go5600, GeForce FX Go5650,
    Quadro FX Go700, 0x031D, 0x031E, 0x031F, GeForce FX 5200,
    GeForce FX 5200 Ultra, GeForce FX 5200, GeForce FX 5200SE,
    GeForce FX Go5200, GeForce FX Go5250, GeForce FX Go5200 32M/64M,
    0x0329, Quadro NVS 280 PCI, Quadro FX 500, GeForce FX Go5300,
    GeForce FX Go5100, 0x032F, GeForce FX 5900 Ultra, GeForce FX 5900,
    GeForce FX 5900XT, GeForce FX 5950 Ultra, 0x0334, Quadro FX 3000,
    GeForce FX 5700 Ultra, GeForce FX 5700, GeForce FX 5700LE,
    GeForce FX 5700VE, 0x0345, GeForce FX Go5700, GeForce FX Go5700,
    0x0349, 0x034B, Quadro FX Go1000, Quadro FX 1100, 0x034F
(II) Primary Device is: PCI 01:00:0
(WW) NVIDIA: No matching Device section for instance (BusID PCI:2:4:0) found
(--) Chipset NVIDIA GPU found
(II) resource ranges after xf86ClaimFixedResources() call:
    [0] -1    0    0xffe00000 - 0xffffffff (0x200000) MX[B](B)
    [1] -1    0    0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
    [2] -1    0    0x000f0000 - 0x000fffff (0x10000) MX[B]
    [3] -1    0    0x000c0000 - 0x000effff (0x30000) MX[B]
    [4] -1    0    0x00000000 - 0x0009ffff (0xa0000) MX[B]
    [5] -1    0    0xfeaffc00 - 0xfeaffcff (0x100) MX[B]
    [6] -1    0    0xea7ff000 - 0xea7fffff (0x1000) MX[B]
    [7] -1    0    0x40000000 - 0x400003ff (0x400) MX[B]
    [8] -1    0    0xfebffc00 - 0xfebfffff (0x400) MX[B]
    [9] -1    0    0xf0000000 - 0xefffffff (0x0) MX[B]O
    [10] -1    0    0x48000000 - 0x4fffffff (0x8000000) MX[B](B)
    [11] -1    0    0xea7fe000 - 0xea7fefff (0x1000) MX[B](B)
    [12] -1    0    0xfc9e0000 - 0xfc9fffff (0x20000) MX[B](B)
    [13] -1    0    0xd0000000 - 0xd7ffffff (0x8000000) MX[B](B)
    [14] -1    0    0xfb000000 - 0xfbffffff (0x1000000) MX[B](B)
    [15] -1    0    0x0000ffff - 0x0000ffff (0x1) IX[B]
    [16] -1    0    0x00000000 - 0x000000ff (0x100) IX[B]
    [17] -1    0    0x0000b000 - 0x0000b007 (0x8) IX[B]
    [18] -1    0    0x0000b400 - 0x0000b4ff (0x100) IX[B]
    [19] -1    0    0x0000bc00 - 0x0000bc07 (0x8) IX[B]
    [20] -1    0    0x0000b800 - 0x0000b81f (0x20) IX[B]
    [21] -1    0    0x0000c800 - 0x0000c81f (0x20) IX[B]
    [22] -1    0    0x0000dc00 - 0x0000dc0f (0x10) IX[B]
    [23] -1    0    0x0000e000 - 0x0000e003 (0x4) IX[B]
    [24] -1    0    0x0000e400 - 0x0000e407 (0x8) IX[B]
    [25] -1    0    0x0000e800 - 0x0000e803 (0x4) IX[B]
    [26] -1    0    0x0000ec00 - 0x0000ec07 (0x8) IX[B]
    [27] -1    0    0x0000ffa0 - 0x0000ffaf (0x10) IX[B]
    [28] -1    0    0x0000d800 - 0x0000d81f (0x20) IX[B]
    [29] -1    0    0x0000d400 - 0x0000d41f (0x20) IX[B]
    [30] -1    0    0x0000d000 - 0x0000d01f (0x20) IX[B]
    [31] -1    0    0x0000cc00 - 0x0000cc1f (0x20) IX[B]
(--) Chipset GeForce2 MX/MX 400 found
(II) resource ranges after xf86ClaimFixedResources() call:
    [0] -1    0    0xffe00000 - 0xffffffff (0x200000) MX[B](B)
    [1] -1    0    0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
    [2] -1    0    0x000f0000 - 0x000fffff (0x10000) MX[B]
    [3] -1    0    0x000c0000 - 0x000effff (0x30000) MX[B]
    [4] -1    0    0x00000000 - 0x0009ffff (0xa0000) MX[B]
    [5] -1    0    0xfeaffc00 - 0xfeaffcff (0x100) MX[B]
    [6] -1    0    0xea7ff000 - 0xea7fffff (0x1000) MX[B]
    [7] -1    0    0x40000000 - 0x400003ff (0x400) MX[B]
    [8] -1    0    0xfebffc00 - 0xfebfffff (0x400) MX[B]
    [9] -1    0    0xf0000000 - 0xefffffff (0x0) MX[B]O
    [10] -1    0    0x48000000 - 0x4fffffff (0x8000000) MX[B](B)
    [11] -1    0    0xea7fe000 - 0xea7fefff (0x1000) MX[B](B)
    [12] -1    0    0xfc9e0000 - 0xfc9fffff (0x20000) MX[B](B)
    [13] -1    0    0xd0000000 - 0xd7ffffff (0x8000000) MX[B](B)
    [14] -1    0    0xfb000000 - 0xfbffffff (0x1000000) MX[B](B)
    [15] -1    0    0x0000ffff - 0x0000ffff (0x1) IX[B]
    [16] -1    0    0x00000000 - 0x000000ff (0x100) IX[B]
    [17] -1    0    0x0000b000 - 0x0000b007 (0x8) IX[B]
    [18] -1    0    0x0000b400 - 0x0000b4ff (0x100) IX[B]
    [19] -1    0    0x0000bc00 - 0x0000bc07 (0x8) IX[B]
    [20] -1    0    0x0000b800 - 0x0000b81f (0x20) IX[B]
    [21] -1    0    0x0000c800 - 0x0000c81f (0x20) IX[B]
    [22] -1    0    0x0000dc00 - 0x0000dc0f (0x10) IX[B]
    [23] -1    0    0x0000e000 - 0x0000e003 (0x4) IX[B]
    [24] -1    0    0x0000e400 - 0x0000e407 (0x8) IX[B]
    [25] -1    0    0x0000e800 - 0x0000e803 (0x4) IX[B]
    [26] -1    0    0x0000ec00 - 0x0000ec07 (0x8) IX[B]
    [27] -1    0    0x0000ffa0 - 0x0000ffaf (0x10) IX[B]
    [28] -1    0    0x0000d800 - 0x0000d81f (0x20) IX[B]
    [29] -1    0    0x0000d400 - 0x0000d41f (0x20) IX[B]
    [30] -1    0    0x0000d000 - 0x0000d01f (0x20) IX[B]
    [31] -1    0    0x0000cc00 - 0x0000cc1f (0x20) IX[B]
(WW) ****INVALID MEM ALLOCATION**** b: 0xff000000 e: 0xffffffff correcting
(II) NonSys
    [0] -1    0    0xfeaffc00 - 0xfeaffcff (0x100) MX[B]
    [1] -1    0    0xea7ff000 - 0xea7fffff (0x1000) MX[B]
    [2] -1    0    0x40000000 - 0x400003ff (0x400) MX[B]
    [3] -1    0    0xfebffc00 - 0xfebfffff (0x400) MX[B]
    [4] -1    0    0xf0000000 - 0xf0000000 (0x1) MX[B]
    [5] -1    0    0xffe00000 - 0xffffffff (0x200000) MX[B](B)
    [6] -1    0    0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
    [7] -1    0    0x000f0000 - 0x000fffff (0x10000) MX[B]
    [8] -1    0    0x000c0000 - 0x000effff (0x30000) MX[B]
    [9] -1    0    0x00000000 - 0x0009ffff (0xa0000) MX[B]
    [10] -1    0    0x0000b000 - 0x0000b007 (0x8) IX[B]
    [11] -1    0    0x0000b400 - 0x0000b4ff (0x100) IX[B]
    [12] -1    0    0x0000bc00 - 0x0000bc07 (0x8) IX[B]
    [13] -1    0    0x0000b800 - 0x0000b81f (0x20) IX[B]
    [14] -1    0    0x0000c800 - 0x0000c81f (0x20) IX[B]
    [15] -1    0    0x0000dc00 - 0x0000dc0f (0x10) IX[B]
    [16] -1    0    0x0000e000 - 0x0000e003 (0x4) IX[B]
    [17] -1    0    0x0000e400 - 0x0000e407 (0x8) IX[B]
    [18] -1    0    0x0000e800 - 0x0000e803 (0x4) IX[B]
    [19] -1    0    0x0000ec00 - 0x0000ec07 (0x8) IX[B]
    [20] -1    0    0x0000ffa0 - 0x0000ffaf (0x10) IX[B]
    [21] -1    0    0x00000000 - 0x00000000 (0x1) IX[B]
    [22] -1    0    0x00000000 - 0x00000000 (0x1) IX[B]
    [23] -1    0    0x00000000 - 0x00000000 (0x1) IX[B]
    [24] -1    0    0x00000000 - 0x00000000 (0x1) IX[B]
    [25] -1    0    0x0000d800 - 0x0000d81f (0x20) IX[B]
    [26] -1    0    0x0000d400 - 0x0000d41f (0x20) IX[B]
    [27] -1    0    0x0000d000 - 0x0000d01f (0x20) IX[B]
    [28] -1    0    0x0000cc00 - 0x0000cc1f (0x20) IX[B]
    [29] -1    0    0x0000ffff - 0x0000ffff (0x1) IX[B]
    [30] -1    0    0x00000000 - 0x000000ff (0x100) IX[B]
(WW) ****INVALID MEM ALLOCATION**** b: 0x48000000 e: 0x4fffffff correcting

<----------EDIT---------->

(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Reloading /usr/X11R6/lib/modules/libfb.a
(II) Loading sub module "xaa"
(II) LoadModule: "xaa"
(II) Loading /usr/X11R6/lib/modules/libxaa.a
(II) Module xaa: vendor="X.Org Foundation"
    compiled for 6.8.1, module version = 1.2.0
    ABI class: X.Org Video Driver, version 0.7
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Reloading /usr/X11R6/lib/modules/libramdac.a
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  Yes, I do.
(II) LoadModule: "rac"
(II) Loading /usr/X11R6/lib/modules/librac.a
(II) Module rac: vendor="X.Org Foundation"
    compiled for 6.8.1, module version = 1.0.0
    ABI class: X.Org Video Driver, version 0.7
(II) resource ranges after preInit:
    [0] 1    0    0xe0000000 - 0xe7ffffff (0x8000000) MX[B]
    [1] 1    0    0xfd000000 - 0xfdffffff (0x1000000) MX[B]
    [2] 0    0    0xd0000000 - 0xd7ffffff (0x8000000) MX[B]
    [3] 0    0    0xfb000000 - 0xfbffffff (0x1000000) MX[B]
    [4] -1    0    0xe0000000 - 0xe7ffffff (0x8000000) MX[B](B)
    [5] -1    0    0xfd000000 - 0xfdffffff (0x1000000) MX[B](B)
    [6] -1    0    0xffe00000 - 0xffffffff (0x200000) MX[B](B)
    [7] -1    0    0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
    [8] -1    0    0x000f0000 - 0x000fffff (0x10000) MX[B]
    [9] -1    0    0x000c0000 - 0x000effff (0x30000) MX[B]
    [10] -1    0    0x00000000 - 0x0009ffff (0xa0000) MX[B]
    [11] -1    0    0xfeaffc00 - 0xfeaffcff (0x100) MX[B]
    [12] -1    0    0xea7ff000 - 0xea7fffff (0x1000) MX[B]
    [13] -1    0    0x40000000 - 0x400003ff (0x400) MX[B]
    [14] -1    0    0xfebffc00 - 0xfebfffff (0x400) MX[B]
    [15] -1    0    0xf0000000 - 0xefffffff (0x0) MX[B]O
    [16] -1    0    0xea7fe000 - 0xea7fefff (0x1000) MX[B](B)
    [17] -1    0    0xfc9e0000 - 0xfc9fffff (0x20000) MX[B](B)
    [18] -1    0    0xd0000000 - 0xd7ffffff (0x8000000) MX[B](B)
    [19] -1    0    0xfb000000 - 0xfbffffff (0x1000000) MX[B](B)
    [20] 0    0    0x000a0000 - 0x000affff (0x10000) MS[B](OprD)
    [21] 0    0    0x000b0000 - 0x000b7fff (0x8000) MS[B](OprD)
    [22] 0    0    0x000b8000 - 0x000bffff (0x8000) MS[B](OprD)
    [23] 1    0    0x000a0000 - 0x000affff (0x10000) MS[B](OprD)
    [24] 1    0    0x000b0000 - 0x000b7fff (0x8000) MS[B](OprD)
    [25] 1    0    0x000b8000 - 0x000bffff (0x8000) MS[B](OprD)
    [26] -1    0    0x0000ffff - 0x0000ffff (0x1) IX[B]
    [27] -1    0    0x00000000 - 0x000000ff (0x100) IX[B]
    [28] -1    0    0x0000b000 - 0x0000b007 (0x8) IX[B]
    [29] -1    0    0x0000b400 - 0x0000b4ff (0x100) IX[B]
    [30] -1    0    0x0000bc00 - 0x0000bc07 (0x8) IX[B]
    [31] -1    0    0x0000b800 - 0x0000b81f (0x20) IX[B]
    [32] -1    0    0x0000c800 - 0x0000c81f (0x20) IX[B]
    [33] -1    0    0x0000dc00 - 0x0000dc0f (0x10) IX[B]
    [34] -1    0    0x0000e000 - 0x0000e003 (0x4) IX[B]
    [35] -1    0    0x0000e400 - 0x0000e407 (0x8) IX[B]
    [36] -1    0    0x0000e800 - 0x0000e803 (0x4) IX[B]
    [37] -1    0    0x0000ec00 - 0x0000ec07 (0x8) IX[B]
    [38] -1    0    0x0000ffa0 - 0x0000ffaf (0x10) IX[B]
    [39] -1    0    0x0000d800 - 0x0000d81f (0x20) IX[B]
    [40] -1    0    0x0000d400 - 0x0000d41f (0x20) IX[B]
    [41] -1    0    0x0000d000 - 0x0000d01f (0x20) IX[B]
    [42] -1    0    0x0000cc00 - 0x0000cc1f (0x20) IX[B]
    [43] 0    0    0x000003b0 - 0x000003bb (0xc) IS[B](OprU)
    [44] 0    0    0x000003c0 - 0x000003df (0x20) IS[B](OprU)
    [45] 1    0    0x000003b0 - 0x000003bb (0xc) IS[B](OprU)
    [46] 1    0    0x000003c0 - 0x000003df (0x20) IS[B](OprU)
(II) NVIDIA(0): Setting mode "1280x960"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(II) Loading extension NV-CONTROL
(EE) NVIDIA(0): Failed to load GLX
(==) RandR enabled
(==) NV(1): Write-combining range (0xe0000000,0x4000000)
(II) NV(1): Using XFree86 Acceleration Architecture (XAA)
    Screen to screen bit blits
    Solid filled rectangles
    8x8 mono pattern filled rectangles
    Indirect CPU to Screen color expansion
    Solid Lines
    Scanline Image Writes
    Offscreen Pixmaps
    Setting up tile and stipple cache:
        32 128x128 slots
        32 256x256 slots
        16 512x512 slots
(==) NV(1): Backing store disabled
(==) NV(1): Silken mouse enabled
(WW) NV(1): Option "RenderAccel" is not used
(==) RandR enabled
(II) Entity 0 shares no resources
(II) Entity 1 shares no resources
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(**) Option "Protocol" "IMPS/2"
(**) Mouse1: Device: "/dev/psaux"
(**) Mouse1: Protocol: "IMPS/2"
(**) Option "CorePointer"
(**) Mouse1: Core Pointer
(**) Option "Device" "/dev/psaux"
(**) Option "Emulate3Buttons"
(**) Mouse1: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Mouse1: ZAxisMapping: buttons 4 and 5
(**) Mouse1: Buttons: 5
(**) Option "CoreKeyboard"
(**) Keyboard1: Core Keyboard
(**) Option "Protocol" "standard"
(**) Keyboard1: Protocol: standard
(**) Option "XkbRules" "xorg"
(**) Keyboard1: XkbRules: "xorg"
(**) Option "XkbModel" "pc101"
(**) Keyboard1: XkbModel: "pc101"
(**) Option "XkbLayout" "us"
(**) Keyboard1: XkbLayout: "us"
(**) Option "CustomKeycodes" "off"
(**) Keyboard1: CustomKeycodes disabled
(II) XINPUT: Adding extended input device "Keyboard1" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
(II) Mouse1: ps2EnableDataReporting: succeeded
Could not init font path element /usr/X11R6/lib/X11/fonts/local/, removing from list!
GetModeLine - scrn: 0 clock: 148500
GetModeLine - hdsp: 1280 hbeg: 1344 hend: 1504 httl: 1728
              vdsp: 960 vbeg: 961 vend: 964 vttl: 1011 flags: 5
GetModeLine - scrn: 0 clock: 148500
GetModeLine - hdsp: 1280 hbeg: 1344 hend: 1504 httl: 1728
              vdsp: 960 vbeg: 961 vend: 964 vttl: 1011 flags: 5
GetModeLine - scrn: 0 clock: 148500
GetModeLine - hdsp: 1280 hbeg: 1344 hend: 1504 httl: 1728
              vdsp: 960 vbeg: 961 vend: 964 vttl: 1011 flags: 5
GetModeLine - scrn: 0 clock: 148500
GetModeLine - hdsp: 1280 hbeg: 1344 hend: 1504 httl: 1728
              vdsp: 960 vbeg: 961 vend: 964 vttl: 1011 flags: 5
GetModeLine - scrn: 0 clock: 148500
GetModeLine - hdsp: 1280 hbeg: 1344 hend: 1504 httl: 1728
              vdsp: 960 vbeg: 961 vend: 964 vttl: 1011 flags: 5
SwitchToMode - scrn: 0 clock: 74250
               hdsp: 640 hbeg: 672 hend: 752 httl: 864
               vdsp: 480 vbeg: 480 vend: 482 vttl: 505 flags: 37
Checking against clock: 148500 (148500)
                 hdsp: 1280 hbeg: 1344 hend: 1504 httl: 1728
                 vdsp: 960 vbeg: 961 vend: 964 vttl: 1011 flags: 5
Checking against clock: 94500 (94500)
                 hdsp: 1024 hbeg: 1072 hend: 1168 httl: 1376
                 vdsp: 768 vbeg: 769 vend: 772 vttl: 808 flags: 5
Checking against clock: 56300 (56300)
                 hdsp: 800 hbeg: 832 hend: 896 httl: 1048
                 vdsp: 600 vbeg: 601 vend: 604 vttl: 631 flags: 5
Checking against clock: 74250 (74250)
                 hdsp: 640 hbeg: 672 hend: 752 httl: 864
                 vdsp: 480 vbeg: 480 vend: 482 vttl: 505 flags: 37
(II) Screen 0 shares mem & io resources
(II) Screen 1 shares mem & io resources
(II) NVIDIA(0): Setting mode "640x480"
(II) Entity 0 shares no resources
(II) Entity 1 shares no resources
SwitchToMode - Succeeded
GetModeLine - scrn: 0 clock: 74250
GetModeLine - hdsp: 640 hbeg: 672 hend: 752 httl: 864
              vdsp: 480 vbeg: 480 vend: 482 vttl: 505 flags: 37
GetModeLine - scrn: 0 clock: 74250
GetModeLine - hdsp: 640 hbeg: 672 hend: 752 httl: 864
              vdsp: 480 vbeg: 480 vend: 482 vttl: 505 flags: 37
SwitchToMode - scrn: 0 clock: 148500
               hdsp: 1280 hbeg: 1344 hend: 1504 httl: 1728
               vdsp: 960 vbeg: 961 vend: 964 vttl: 1011 flags: 5
Checking against clock: 148500 (148500)
                 hdsp: 1280 hbeg: 1344 hend: 1504 httl: 1728
                 vdsp: 960 vbeg: 961 vend: 964 vttl: 1011 flags: 5
(II) Screen 0 shares mem & io resources
(II) Screen 1 shares mem & io resources
(II) NVIDIA(0): Setting mode "1280x960"
(II) Entity 0 shares no resources
(II) Entity 1 shares no resources
SwitchToMode - Succeeded
(II) Screen 0 shares mem & io resources
(II) Screen 1 shares mem & io resources
(II) Screen 0 shares mem & io resources
(II) Screen 1 shares mem & io resources
FreeFontPath: FPE "/usr/X11R6/lib/X11/fonts/misc/" refcount is 2, should be 1; fixing.

Offline

#9 2004-09-19 20:10:06

beniro
Member
From: St. Petersburg, FL, USA
Registered: 2002-12-31
Posts: 312

Re: 3d Acceleration on two monitors with nvidia?

Here is my xorg.conf.  The only difference between this (which is a working) and the "both monitors go black" config is the use of "nv" instead of "nvidia" at the driver on the second card.

Section "Module"

    Load        "dbe"      # Double buffer extension

    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection


    Load        "type1"
    Load        "speedo"
    Load        "freetype"

EndSection


Section "Files"

    RgbPath    "/usr/X11R6/lib/X11/rgb"

    FontPath   "/usr/X11R6/lib/X11/fonts/local/"
    FontPath   "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath   "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath   "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/"

    FontPath   "/usr/X11R6/lib/X11/fonts/artwiz-fonts/"
    FontPAth   "/usr/X11R6/lib/X11/fonts/TTF/"
    
EndSection


Section "Extensions"

     Option   "Composite"  "Enable"
     Option   "RENDER"     "Enable"
     
EndSection


Section "ServerFlags"

EndSection


Section "InputDevice"

    Identifier    "Keyboard1"
    Driver    "keyboard"

    Option "AutoRepeat" "500 30"

    Option "XkbRules"    "xorg"
    Option "XkbModel"    "pc101"
    Option "XkbLayout"    "us"

EndSection


Section "InputDevice"

    Identifier    "Mouse1"
    Driver    "mouse"
    Option "Protocol"    "IMPS/2"
    Option "Device"      "/dev/psaux"
    Option "ZAxisMapping" "4 5"

    Option "Emulate3Buttons"

EndSection


Section "Monitor"

    Identifier  "Monitor0"
    HorizSync   30-95
    VertRefresh 50-160

EndSection

Section "Monitor"
     Identifier  "Monitor1"
     HorizSync   30-69
     VertRefresh 50-120
EndSection


Section "Device"
    Identifier    "Standard VGA"
    VendorName    "Unknown"
    BoardName    "Unknown"

#    Chipset    "generic"

    Driver     "vga"

EndSection


Section "Device"
    Identifier  "VideoCard0"
    Driver      "nvidia"
    Option      "NvAgp" "1"
    Option      "RenderAccel" "1"
    BusID       "PCI:1:0:0"
    #Driver      "nv"
    #VideoRam    131072
    # Insert Clocks lines here if appropriate
EndSection

Section "Device"
    Identifier  "VideoCard1"
    #Driver      "nvidia"
    Option      "NvAgp" "1"
    Option      "RenderAccel" "1"
    Driver      "nv"
    BusID       "PCI:2:4:0"
EndSection


Section "Screen"
    Identifier  "Screen 1"
    Device      "VideoCard0"
    Monitor     "Monitor0"
    DefaultDepth 24

    Subsection "Display"
        Depth       8
        Modes       "1280x960" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1280x960" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1280x960" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
EndSection

Section "Screen"
    Identifier  "Screen 2"
    Device      "VideoCard1"
    Monitor     "Monitor1"
    DefaultDepth 24

    Subsection "Display"
        Depth       8
        Modes       "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
EndSection


Section "ServerLayout"

    Identifier  "Simple Layout"

    Screen 0 "Screen 1"
    Screen 1 "Screen 2" Rightof "Screen 1"
 
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"

EndSection

I've been looking through the nvidia docs, but I can't find anything that applies directly to my situation.  Twinview is only for one card driving two monitors, it seems.  Is this true?

Garsh.  I'm still exploring.  Thanks in advance.  If you've read down this far (or skimmed), you will be receiving karma points in the mail.  smile

Offline

#10 2004-09-19 21:05:38

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: 3d Acceleration on two monitors with nvidia?

Generally I don't see anything wrong in your config especially that it works when you use different modules.
Here's what I found in the nvidia readme file that can affect your configuration:

Multicard, Multimonitor
        In some cases, the secondary card is not initialized correctly
        by the NVIDIA kernel module. You can work around this by enabling
        the XFree86 Int10 module to soft-boot all secondary cards. See
        "APPENDIX D: X CONFIG OPTIONS" for details.

and

Option "UseInt10Module" "boolean"
                Enable use of the X Int10 module to soft-boot all
                secondary cards, rather than POSTing the cards through
                the NVIDIA kernel module.  Default: off (POSTing is done
                through the NVIDIA kernel module).

You should now try to add

Option "UseInt10Module" "true"

to

They may be specified either in the Screen or Device sections of the X
config file.

I'm not sure which place is better and if you have to place it in both device sections. I guess you have to try all possibilities :-)
And I think you will also need

Load "int10"

in your module section to make this work.

Offline

Board footer

Powered by FluxBB