You are not logged in.

#1 2004-09-16 15:23:00

infernova
Member
Registered: 2004-04-09
Posts: 61

aRts problem?

I've recently upgraded all my packages, including KDE. After rebooting, my computer practically has no sound. if I play music using aRTS or eSD, it will simply tell "couldn't open audio....."
or no sound coming out using ALSA.

I didn't make any changes, and the entries on my "lsmod", and "rc.conf" still remain the same, meaning the sound module should be loaded automatically everytime the machine restarts.

one thing that confuses me is when i run "artsd", this output came out

artsd: error while loading shared libraries: libjack.so.0: cannot open shared object file: No such file or directory

I'll give you my lsmod entry

Module                  Size  Used by
nvidia               4816660  10
snd_pcm_oss            57384  0
snd_mixer_oss          20992  1 snd_pcm_oss
snd_maestro3           26664  2
snd_ac97_codec         71684  1 snd_maestro3
snd_pcm               104708  2 snd_pcm_oss,snd_maestro3
snd_page_alloc         12168  1 snd_pcm
snd_timer              28164  1 snd_pcm
snd                    60260  10 snd_pcm_oss,snd_mixer_oss,snd_maestro3,snd_ac97_codec,snd_pcm,snd_timer
soundcore              11104  1 snd
eepro100               31756  0
mii                     5888  1 eepro100
ide_scsi               18180  0
usbserial              30312  0
rtc                    14408  0
tsdev                   7808  0
joydev                 10560  0
evdev                  10112  0

and here's my rc.conf modules

MODULES=(usbserial ide-scsi eepro100 snd-maestro3 snd_pcm_oss nvidia)
DAEMONS=(!syslog-ng !syslogd !klogd !hotplug !pcmcia network netfs crond)

As you can see I'm using "ESS Technology ES1983S Maestro-3i PCI Audio Accelerator" as my audio card.

Is this aRTS bug related? or i miss some crucial settings for audio...

Pls help me as I'm starting to pull my hair out here.......

Much Thanks ahead!

Offline

#2 2004-09-16 16:14:55

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: aRts problem?

please install jack-audio-connection-kit
and look if your problem is solved
else a udev upgrade was done last night perhaps your permissions now wrong set

Offline

#3 2004-09-16 16:51:01

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: aRts problem?

arts updated to -3 should install jack for you
by the way try restart your udev
/etc/./start_udev perhaps it helps for the sound issue
if you use udev of course

Offline

#4 2004-09-16 17:19:14

infernova
Member
Registered: 2004-04-09
Posts: 61

Re: aRts problem?

Well, i did install jack-audio, and my xmms can play without error, or any multimedia apps.
the thing is, the sound still doesn't come out.

when you mention permission, what do you mean by it? i did remember few mths ago, i upgraded module-init-tools, and the entry along with permission are different from the original, and lucky for me, i had a backup, and everything was fine. this only relates to running certain applications however.

the other thing is udev. i'm quite a newbie, so i don't understand what this udev thing is.
i do however run this find / -name "start_udev*", and it doesn't return anything, so i'm pretty sure i'm not using udev.

now since this jack package runs as daemon, do i need to add certain entry in my rc.conf (the daemons part)? and when i tried to run it, it returns error however.
i suppose it tries to open up ALSA, and it looks for this path "/dev/snd/seq", which i don't have.

anyway, back to the topic, any idea to go about this sound issue?

Thanks

Offline

#5 2004-09-16 17:22:43

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: aRts problem?

no you don't need to run it as daemon
if you don't need it
the programs need the library that's all

Offline

#6 2004-09-16 17:28:32

infernova
Member
Registered: 2004-04-09
Posts: 61

Re: aRts problem?

Now, here's the funny thing....if i login as root, i could have the sound up and running...
how could this possibly be? so what am i supposed to do if i want to have the sound out and login as normal user?

Offline

#7 2004-09-16 17:38:10

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: aRts problem?

that sounds really after a permission problem
sorry have no time right now
you can have a look at http://wiki.archlinux.org
or search the forum

Offline

#8 2004-09-17 15:07:34

infernova
Member
Registered: 2004-04-09
Posts: 61

Re: aRts problem?

Thanks so much for your input!, I finally got it up and running.

The only minor problem is, everytime i reboot the machine, and login, the KMix is dead, and i have to manually "on" it...is there anyway to automate the process?

it's like when you logout and login again, the previous volume setting remains the same. that's no longer the case though.

Offline

#9 2004-09-17 15:12:06

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: aRts problem?

you tried the alsasound daemon file from the wiki
add alsasound  to your rc.conf daemons list
it looks like this alsasound:
#!/bin/bash

. /etc/rc.conf
. /etc/rc.d/functions

case "$1" in
    start)
    stat_busy "Restoring Alsa mixer volumes"
    alsactl restore
    if [ $? -gt 0 ]; then
stat_fail
    else
add_daemon alsasound
stat_done
    fi 
    ;;
    stop)
    stat_busy "Storing Alsa mixer volumes"
    alsactl store
    if [ $? -gt 0 ]; then
stat_fail
    else
rm_daemon alsasound
stat_done
    fi
    ;;
    restart)
    $0 stop
    sleep 1
    $0 start
    ;;
    *)
    echo "Usage $0 {start|stop|restart}"
    ;;
esac

Offline

Board footer

Powered by FluxBB