You are not logged in.

#1 2004-09-12 19:01:10

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,436
Website

xmms crashing?

is anyone having probs with xmms crashing?  i had a serious corruption on my home partition today which may have something to do with it - but when ever i try to play a file it just locks up - it also does it if i run as root tho sad

Offline

#2 2004-09-12 22:41:48

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: xmms crashing?

I'm using xmms 1.2.10-2 and I have no problem. Have you tried playing your files with another player?  Maybe the file got corrupted.

Offline

#3 2004-09-12 23:06:59

LavaPunk
Member
Registered: 2004-03-05
Posts: 129

Re: xmms crashing?

No problems here with xmms.

Offline

#4 2004-09-13 08:24:04

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,436
Website

Re: xmms crashing?

well i have tried playing several files - i'll try some more - alsaplayer works fine

xmms will open the song and start scrolling the title etc but as soon as you click on play it freezes - i tried reinstalling it but no good sad

Offline

#5 2004-09-15 11:43:02

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,436
Website

Re: xmms crashing?

what output plugin you guys using?

Offline

#6 2004-09-15 20:21:02

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: xmms crashing?

I'm using alsa output plugin and it works fine in xmms and bmp-cvs too. Maybe you should try bmp? Or maybe it's some device/file permissions problem? If you have any visualisation plugins turned on you shold probably turn them off too.

Offline

#7 2004-09-15 21:13:17

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: xmms crashing?

it's xorg R6.8.0

i was not able to reproduce this xmms crashing, but now, as i'm using R6.8.0, it crashes on start always with this:

Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 2651 error_code 8 request_code 72 minor_code 0
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 2652 error_code 8 request_code 72 minor_code 0

The impossible missions are the only ones which succeed.

Offline

#8 2004-09-15 21:22:45

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: xmms crashing?

rebuilding against new xorg do NOT help - still the same

what helps: removing ~/.xmms makes it at least start and play music again, but e.g. if you hit [ctrl]-D to make it double-size, it crashes again the same way

i think, it's a xmms bug itself


The impossible missions are the only ones which succeed.

Offline

#9 2004-09-15 22:07:00

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,436
Website

Re: xmms crashing?

i think it was arts related - i googled for the error and found related bugs in the xmms dbase.  it was all to do with arts - so i looked into how i was supposed to have my sound set up cos i botched it a bit the first time.  i am now fully alsa output compliant with no arts at all and no xmms crash.  i even have sound from both speakers!  i have not upgraded to xorg 6.8 and i don't think i will as it does not seem worth it - i can't see any benefit so far!

Offline

#10 2004-09-16 23:28:21

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,436
Website

Re: xmms crashing?

hmmmmm - more weirdness - the alsa set up is working fine - but some of my mp3's - all from a specific album for example and some others - seem to cause my cpu trouble!  when i play them the cpu jumps up to around 50%!  all my others it happily sits at 0% - any suggestions as to why?  different encoding i guess - but i can i improve playback with tweaking?

Offline

#11 2004-09-18 06:41:12

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: xmms crashing?

I'm also having xmms crashes with xorg 6.8. It had worked fine till now. It crashes on song changes.


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#12 2004-09-18 09:47:14

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: xmms crashing?

kakabaratruskia wrote:

I'm also having xmms crashes with xorg 6.8. It had worked fine till now. It crashes on song changes.

as workaround (for elementar functions) i removed the ~/.xmms dir (moved it to other place - to backup my settings) - then xmms was at least able to play things (double-size and other things still make it crash)


The impossible missions are the only ones which succeed.

Offline

#13 2004-09-18 18:11:06

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: xmms crashing?

Thanks dp, but I just decided to go back to 6.7 that has worked much better for me.


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#14 2004-09-18 20:25:29

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: xmms crashing?

kakabaratruskia wrote:

Thanks dp, but I just decided to go back to 6.7 that has worked much better for me.

yes, that's a better solution, if you can --- i have amarok and hope that soon, this will be fixed (i tracked it down to gtk1 or some dep to it to be rebuilt, but not sure and also no time -- exams are more important now ;-) )


The impossible missions are the only ones which succeed.

Offline

#15 2004-09-18 21:34:07

RedShift
Member
From: Belgium
Registered: 2004-07-16
Posts: 230

Re: xmms crashing?

try bmp, (pacman -S bmp), it's a GTK2 port of xxmms


:?

Offline

#16 2004-09-18 22:17:44

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,436
Website

Re: xmms crashing?

my thread has been hijacked!

Offline

#17 2004-09-18 22:49:28

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,436
Website

Re: xmms crashing?

i found a patch for gkrellmms that makes it for bmp!

http://www.kip.iis.toyama-u.ac.jp/~dai/ … 0809.patch

but i can't get it to work - maybe it is against cvs?

Offline

Board footer

Powered by FluxBB