You are not logged in.

#1 2004-09-19 15:40:07

RedShift
Member
From: Belgium
Registered: 2004-07-16
Posts: 230

HCL for X.org 6.8.0

Hello all,
I've decided to keep a hardware compatability list for x.org 6.8.0. Please posts your results so I can extend this list:

X.org version; Graphics Chipset; Driver; Issues

·

· X.org Version: 6.8.1
· Chipset: nVidia GeForce 3 Ti 500;
· Driver: NVIDIA-Linux-x86-1.0-6111 from nvidia.com
· Issues/Remarks: When composite is enabled, all windows overlap gnome-panels. Transparency doesn't always work.


·

· X.org Version: 6.8.1
· Chipset: Matrox G400 Dual Head
· Driver: Stock X.org driver
· Issues/Remarks: When composite is enabled, all windows overlap gnome-panels. Transparency always work


·

· X.org Version: 6.8.1
· Chipset: nVidia GeForce FX 5200
· Driver: NVIDIA-Linux-x86-1.0-6111 from nvidia.com
· Issues/Remarks: Works perfectly as intended.

·

· X.org Version: 6.8.1
· Chipset: ATi Radeon 9100
· Driver: radeon in xorg.conf
· Issues/Remarks: Updating to 6.8.1 gave me a black screen for about a minute and then a weired looking text-console; after downgrading to 6.7 everything works flawlessly again.


·

· X.org Version: 6.8.1
· Chipset: nVidia GeForce FX 5600
· Driver: nVidia 1.0-6111 from nVidia.com
· Issues/Remarks: Works perfectly as intended: shadows, fade in/out, WM: XFCE4


:?

Offline

#2 2004-09-20 01:59:56

ganlu
Member
From: ChongQing, China
Registered: 2004-01-04
Posts: 336

Re: HCL for X.org 6.8.0

X.org version; Graphics Chipset; Driver; Issues

6.8.1; nVidia GeForce 3 Ti 500; NVIDIA-Linux-x86-1.0-6111 from nvidia.com; When composite is enabled, all windows overlap gnome-panels. Transparency doesn't always work.

6.8.1; G400 Dual Head; xorg driver, When composite is enabled, all windows overlap gnome-panels. Transparency always work

Offline

#3 2004-09-20 02:16:55

aCoder
Member
From: Medina, OH
Registered: 2004-03-07
Posts: 359
Website

Re: HCL for X.org 6.8.0

When composite is enabled, all windows overlap gnome-panels.

Did you try starting xcompmgr in your session?  It fixed this problem for me.

6.8.1; geForce FX 5200; NVIDIA-Linux-x86-1.0-6111 from nvidia.com; none here!


If you develop an ear for sounds that are musical it is like developing an ego. You begin to refuse sounds that are not musical and that way cut yourself off from a good deal of experience.
  - John Cage

Offline

#4 2004-09-21 01:09:40

skoal
Member
From: Frequent Flyer Underworld
Registered: 2004-03-23
Posts: 612
Website

Re: HCL for X.org 6.8.0

NVIDIA Ti-4600, 6111, xfce-4

* Everything works flawlessly, but here are some of my observations since using xorg 6.8.1 with xcompmgr.

All issues below are only apparent with "composite" enabled, and some issues are independent of whether or not i even use xcompmgr.

1. I definitely need to see the environment variable XLIB_SKIP_ARGB_VISUALS=1, otherwise firefox crashes on plenty of websites, whether they use flash or not i don't know.

2. No need to use the Option "RENDER" "Enable" in my xorg.conf.  Just setting "COMPOSITE" to "enable" loads the render extension.  I don't know why most posts i google concerning this show you need to insert this line in your config.  I do set my Option "RenderAccel" "True" for my NVIDIA card, so I don't know if that is why the render extension is loaded in absence of me inserting the Xorg line or not.

3. When I scroll back in Firefox or even an xterm using the mouse, sometimes the text is garbled.  I do not notice that when i manually drag the slider bar.

4. When I am scrolling through some code (or any text file) with vi (in an xterm), my keyboard repeat rate scrolls smoothly but at times will slow down at about a 1/4 the speed setting, then it will accelerate back up.

5. When I was playing with the transset feature (for translucent windows), I made the mistake of using 0.  There is no way to kill (or see) that app again.  Only a manual "kill" for that process will remove it.

6. Even though I launch xcompmgr and send it to the background in an xterm, sometimes the process will stay alive and sometimes die when i close out the xterm (parent process) that owned it.

7. I wish there were a better way of using transset.  I wish you could make a global setting on Xorg initialization which would apply to all new windows, instead of having to manually set each window.  Also, when using mutliple workspaces, if you try to click to another workspace after launching transset, it will make your taskbar translucent.  I have to use the keyboard shortcut ctrl-alt-arrow and then click on the window.

8. This one is annoying. When i try to resize a application window, the contents of the window are not shown while i am resizing it, only the cursor. Then, when I release the button, the window is re-drawn.  It gets hard to precisely resize the windows as you want them.

* Outside of that, using my nvidia and 6111, I see no noticeable slow down when i do not use the "composite"/xcompmgr feature (except where noted above when scrolling).

Offline

#5 2004-09-21 02:19:04

hyp0luxa
Member
From: Miami, FL
Registered: 2004-07-10
Posts: 70

Re: HCL for X.org 6.8.0

xorg 6.8.1
cvs xcompmgr and transset (more stable)
nVidia GeForce FX 5200
nVidia 1.0.6111-2 arch package

no problems whatsoever. xcompmgr used to crash on me from time to time with the arch xapps package, but since i built the latest cvs, not one crash!
and i'm running kde as well.

Offline

#6 2004-09-21 05:53:23

morphus
Member
From: Braunschweig
Registered: 2003-08-06
Posts: 145

Re: HCL for X.org 6.8.0

updating to 6.8.1 gave me a black screen for about a minute and then a weired looking text-console; after downgrading to 6.7 everything works flawlessly again.

Athlon 2500+, Ati radeon 9100 using "radeon" driver in xorg.conf


When I find some free time I will try to find the failure, but since then:

IgnorePKG = xorg

Offline

#7 2004-09-22 00:07:19

steveed
Member
From: State College, PA USA
Registered: 2004-07-25
Posts: 25

Re: HCL for X.org 6.8.0

xorg 6.8.1
xcompmgr and transset
nVidia GeForce FX5600
nVidia 1.0-6111 drivers from nvidia.com
no issues at all
using transperancy, shadows, fade in/out, using xfce4

Offline

#8 2004-09-22 06:29:05

oscar
Member
From: Linköping, Sweden
Registered: 2004-08-13
Posts: 457

Re: HCL for X.org 6.8.0

geforce3 ti500
nvidia 1-6111
no issues at all - nice speed, nice shadows, everything is nice smile
xcompmgr does crash sometimes, but it isn't the hardware doing that.


To err is human... to really foul up requires the root password.

Offline

Board footer

Powered by FluxBB