You are not logged in.

#1 2004-06-15 21:09:46

mr_ed
Member
From: Ottawa, ON, Canada
Registered: 2004-04-13
Posts: 72

Any way to slow my clock down?

For some reason, my clock goes extremely fast.  When I switched to XFCE from KDE/GNOME yesterday, it started going even faster.  :?

For example:  I set my Windows box (hey, I'm at work..) and my Arch laptop to the time at time.nrc.ca at roughly 4:50PM EDT.
My work machine now says 5:09PM, and my laptop says 5:15.

I started up ntpd hoping to alleviate it...

Any ideas?

Offline

#2 2004-06-15 22:30:22

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: Any way to slow my clock down?

hmm ... i have the experience that the 2.6.x kernel slows down my clock by about 200 to 400s / day or so .... and before telling i see ghosts, i made as root an alias:

alias zeit='ntpdate 193.5.216.14'

to update the clock

any ideas why this happens? in windows or older 2.4. kernels i did not realized this

here the latest synch from some min ago

[root@Asteraceae /]# zeit
Looking for host 193.5.216.14 and service ntp
host found : metasweb01.admin.ch
16 Jun 00:29:52 ntpdate[1634]: step time server 193.5.216.14 offset 132.515055 sec

The impossible missions are the only ones which succeed.

Offline

#3 2004-06-15 23:05:50

Egil.B
Member
From: Universitas Osloensis
Registered: 2004-02-14
Posts: 116

Re: Any way to slow my clock down?

make it a cronjob wink

Offline

#4 2004-09-21 21:20:06

mr_ed
Member
From: Ottawa, ON, Canada
Registered: 2004-04-13
Posts: 72

Re: Any way to slow my clock down?

Turns out I'm not the only one with this problem.  This was reported on the kernel Bugzilla.
In the original poster's case, he is also using an HP laptop.

Anyone else out there with an HP laptop running kernel 2.6.6 or later who doesn't have this problem?

Offline

#5 2004-09-23 12:35:17

Iolo
Member
Registered: 2004-06-03
Posts: 38

Re: Any way to slow my clock down?

I had this problem when I had my system clock set to UTC. Changing it to reflect my local time  alleviated the problem for me.

Offline

#6 2004-09-25 01:15:32

kpiche
Forum Fellow
From: Ottawa, ON, Canada
Registered: 2004-03-30
Posts: 246
Website

Re: Any way to slow my clock down?

You could use adjtimex to slow your clock down.  There's an option that estimates the error and then you give this result to adjtimex in /etc/rc.local.  I can't remember how it goes so check the manpage.  Or use ntpd.  smile

Offline

#7 2005-03-25 16:10:07

antesoft
Member
From: France - Bretagne (Brittany)
Registered: 2005-03-16
Posts: 11
Website

Re: Any way to slow my clock down?

I have this problem too. My computer is an athlon xp 1800+ on an abit mothercard. But I only have this problem on Arch Linux.
I switched to Arch 2 weeks ago. Before this, I was using Debian and I never had the problem. Is this because they path their kernel ?


Philippe BERNERY
http://www.antesoft.org

Offline

#8 2005-03-25 17:25:10

InfernalH
Member
From: Lithuania/Klaipeda-Vilnius
Registered: 2005-02-08
Posts: 101
Website

Re: Any way to slow my clock down?

how to set timezone for this "zeit" alias?

Offline

#9 2005-03-25 19:04:47

thegnu
Member
From: Brooklyn, NY
Registered: 2004-05-04
Posts: 280
Website

Re: Any way to slow my clock down?

antesoft wrote:

I have this problem too. My computer is an athlon xp 1800+ on an abit mothercard.

I think if you go into the BIOS and set FSB Spread and AGP Spread to Disable, it will fix this.  I don't know why.  It's associated with some Nforce2 boards.


fffft!

Offline

Board footer

Powered by FluxBB