You are not logged in.

#1 2004-09-25 15:06:23

dcbdbis
Member
From: Aurora, Colorado
Registered: 2004-09-10
Posts: 215

Gnome Startup and xkb

Hello Folks,


I usually use xfce or kde...I want to be objective so I decided to give Gnome a spin.

Gnome 2.6* and the new 2.8* (from testing) both throw up errors that they cannot initialize xkb on startup.

None of the other WM's that I've installed, including kde, are having any issues.

I'm calling it (from the appropriate .xinitrc files) with "exec gnome-session".

Either as a user, or as root, same errors.

Gnome appears to still operate, but 2.8 throws up multiple and repeated xkb initialization complaints, where 2.6 throws only two before proceeding.

Suggestions?


Thanks!

Dave....

Offline

#2 2004-09-25 15:50:05

patrix
Member
Registered: 2004-08-27
Posts: 51

Re: Gnome Startup and xkb

This bug is everywhere on the internet - has to do with x.org. Go to your xorg.conf file and remove the line in the keyboard section that mentions "xfree86" (not sure I remember, google or the archlinux bugs database can tell you).

Unfortunately the above solution was not enough for me, since certain keyboard layouts (like canadian french) still cause this error, while others like US English and dvorak are ok.

Offline

#3 2004-09-25 16:12:32

dcbdbis
Member
From: Aurora, Colorado
Registered: 2004-09-10
Posts: 215

Re: Gnome Startup and xkb

Thanks for the reply. I  was already under the impression that x.org has a probolem with this, and not Arch itself.

However, I did not port from xfree, rather I did a clean install to my system, and pacman'd in xorg in leiu of xfree. The section doesn't exist.

I've copied in the relavent section of my xorg.conf file. There is no mention of xfree. I also did a text serach using nano, and also found no other references to xfree...

Seeing that it is a widespread issue, and I'm sure folks out there are scrambling to fix it, then I have a question:

Can I just ignore it, knowing that a fix will eventually come? Will Gnome operate correctly, so I can give it a fair evaluation?
Or do you think I should wait to evaluate Gnome, until a fix is obtained?

Thanks!


Dave.....................


# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"

    Identifier "Keyboard1"
    Driver "kbd"

# For most OSs the protocol can be omitted (it defaults to "Standard").
# When using XQUEUE (only for SVR3 and SVR4, but not Solaris),
# uncomment the following line.

#    Option     "Protocol"      "Xqueue"

    Option "AutoRepeat" "250 30"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#    Option "Xleds"      "1 2 3"

#    Option "LeftAlt"     "Meta"
#    Option "RightAlt"    "ModeShift"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#    Option "XkbModel"    "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#    Option "XkbModel"    "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#    Option "XkbLayout"   "de"
# or:
#    Option "XkbLayout"   "de"
#    Option "XkbVariant"  "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#    Option "XkbOptions"  "ctrl:swapcaps"

# These are the default XKB settings for Xorg
#    Option "XkbRules"    "xorg"
#    Option "XkbModel"    "pc101"
#    Option "XkbLayout"   "us"
#    Option "XkbVariant"  ""
#    Option "XkbOptions"  ""

#    Option "XkbDisable"

    Option "XkbRules" "xorg"
    Option "XkbModel" "pc101"
    Option "XkbLayout" "us"
    Option "XkbVariant" "US"

EndSection


# **********************************************************************

Offline

#4 2004-09-25 16:20:27

patrix
Member
Registered: 2004-08-27
Posts: 51

Re: Gnome Startup and xkb

This is my keyboard section, and it worked fine in gnome last week when I last used gnome.

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc104"
        Option          "XkbLayout"     "us,dvorak"
EndSection


only diff I can see is I have pc104 keyboard model and no XkbVariant.

Offline

#5 2004-09-25 16:45:33

dcbdbis
Member
From: Aurora, Colorado
Registered: 2004-09-10
Posts: 215

Re: Gnome Startup and xkb

I tried both, and no change in Gnome's behavior.

After I work through all of the erros, is Gnome properly operating so I can give it a fair evaluation?

Or should I wait until a fix is available to evaluate Gnome?

Thanks for the help!


Dave....................

Offline

Board footer

Powered by FluxBB