You are not logged in.

#1 2004-09-26 00:13:09

Iolo
Member
Registered: 2004-06-03
Posts: 38

Gentoo File Manager Question

I just pulled the new gentoo package from the repositories. So far, it appears to work, but I keep on getting the followign msgs printed to the console whenever I run it:

** WARNING **: Couldn't initialize mount data - automounting won't work

** WARNING **: FAM open failed, error 0--FAM will not be used

What do these msgs mean and how do I rectify them? I'm running gentoo  on fluxbox stable w/  xorg.

Offline

#2 2004-09-26 00:26:16

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: Gentoo File Manager Question

I think the FAM problem is because you must have fam running.
Try;
#/etc/rc.d/fam start


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#3 2004-09-26 02:32:30

Iolo
Member
Registered: 2004-06-03
Posts: 38

Re: Gentoo File Manager Question

Well I think the mount error comes from the fact my user account doesn't have the rights to mount removable devices. I've fixed this behavior by simply telling gentoo never to mount anything.

As for the fam error, starting fam seems to help, but for some reason I need to start fam every time I want to start gentoo. Is this suppose to work this way?

Offline

#4 2004-09-26 02:42:29

aCoder
Member
From: Medina, OH
Registered: 2004-03-07
Posts: 359
Website

Re: Gentoo File Manager Question

You can add portmap and fam to the 'daemons' field in /etc/rc.conf to start it at boot.


If you develop an ear for sounds that are musical it is like developing an ego. You begin to refuse sounds that are not musical and that way cut yourself off from a good deal of experience.
  - John Cage

Offline

#5 2004-09-26 03:59:35

Iolo
Member
Registered: 2004-06-03
Posts: 38

Re: Gentoo File Manager Question

I've added fam to the Daemon array in rc.conf. This appears to prevent error msgs for a short while (eg for  few starts and stops of gentoo). The error however, reoccurs after opening and closing gentoo a few times.

Offline

#6 2004-09-26 04:16:46

aCoder
Member
From: Medina, OH
Registered: 2004-03-07
Posts: 359
Website

Re: Gentoo File Manager Question

This occurs because fam can shut itself down if inactive connection-wise for 5 seconds, or so the default settings say.  You can edit your /etc/fam/fam.conf to set a timeout of 0, which tells fam to sit around indefinitely.


If you develop an ear for sounds that are musical it is like developing an ego. You begin to refuse sounds that are not musical and that way cut yourself off from a good deal of experience.
  - John Cage

Offline

#7 2004-09-26 04:18:19

rasat
Forum Fellow
From: Finland, working in Romania
Registered: 2002-12-27
Posts: 2,176
Website

Re: Gentoo File Manager Question

Iolo wrote:

The error however, reoccurs after opening and closing gentoo a few times.

Edit /etc/fam/fam.conf. Untag and change idel time to 0.

idle_timeout = 0

Offline

#8 2004-09-26 04:24:26

Iolo
Member
Registered: 2004-06-03
Posts: 38

Re: Gentoo File Manager Question

Okay, changing the idle time appears to have fixed it.

Thanks for all your help.

Offline

Board footer

Powered by FluxBB