You are not logged in.

#1 2004-10-04 01:00:27

Registered: 2004-09-03
Posts: 17

usb devices

I'm totally stuck and have no idea what to do...

/dev/sd* doesn't exist, I've scoured the forums and tried a lot, and even the wiki doesn't seem to have anything that makes mine work.

I've modprobe'd usb_storage, I've removed the ! from !ide-scsi in rc.conf, sd-mod doesn't exist, I've modprobe'd sg...  I don't know what else to try.

Plugging in / taking out the device does nothing in dmesg... but the usb hubs seem to be there...

(dmesg output)
Initializing USB Mass Storage driver...
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
ts: Compaq touchscreen protocol output
ohci_hcd: 2004 Feb 02 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ohci_hcd: block sizes: ed 64 td 64
ACPI: PCI interrupt 0000:00:02.0[A] -> GSI 22 (level, high) -> IRQ 22
ohci_hcd 0000:00:02.0: nVidia Corporation nForce2 USB Controller
PCI: Setting latency timer of device 0000:00:02.0 to 64
ohci_hcd 0000:00:02.0: irq 22, pci mem e0fe4000
ohci_hcd 0000:00:02.0: new USB bus registered, assigned bus number 2
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 3 ports detected
ACPI: PCI interrupt 0000:00:02.1[B] -> GSI 21 (level, high) -> IRQ 21
ohci_hcd 0000:00:02.1: nVidia Corporation nForce2 USB Controller (#2)
PCI: Setting latency timer of device 0000:00:02.1 to 64
ohci_hcd 0000:00:02.1: irq 21, pci mem e0fe6000
ohci_hcd 0000:00:02.1: new USB bus registered, assigned bus number 3
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 3 ports detected

I've tried restarting hotplug too.

/proc/bus/usb exists also with 001, 002, 003, and devices...

Any help would be much appreciated. Thanks.


#2 2004-10-04 01:33:14

Registered: 2004-03-04
Posts: 155

Re: usb devices

Hi jochu.

1. You shouldn't be seeing anything in dmesg about the /dev/sd* devices.

2. Take a look in /proc/bus/usb/devices:

cat /proc/bus/usb/devices

after you've plugged in your USB external storage device. You should see information about your device (but you might need to wait a little bit to see it appear).

3. Take a look at the /dev directory:

ls /dev

You should probably see at least one /dev/sda* node.

That's the node you should be mounting. Try, for example, as root:

mount -t vfat /dev/sda1 /mnt/usb-device

You'll need to have a directory in your /mnt directory for this to work.

If your device is not formatted for FAT16 or FAT32, you'll have to use a different -t option (e.g., 'ext2', 'reiserfs', or whatever).

You'll also need to set up proper permissions in /etc/fstab so that you can access this other than as root. For example:

/dev/sda1 /mnt/usb-device vfat defaults,user,noauto,gid=users 0 0

This allows you to mount the usb-device as a regular user and read/write files as a member of the users group.

Take a look at the Arch Linux Wiki concerning mount a USB stick. That's basically the procedure you should be using.

I hope this is helpful.



#3 2004-10-04 01:42:33

Registered: 2004-09-03
Posts: 17

Re: usb devices

I'm retarded! I forgot to turn the thing on. My fault. >:|


Board footer

Powered by FluxBB