You are not logged in.

#1 2003-07-20 15:31:16

iKevin
Member
From: Ann Arbor, MI
Registered: 2003-07-20
Posts: 130

scsi controller not recognized during ftp install

Hi all,

As you can tell, this is my first post and my first attemp to install arch.  I downloaded the latest ftp install floppies "Arch Linux 0.5 (Nova)" and  I am trying to install arch on a PII system with and Adaptec 2940UW controller and no cdrom.  I can boot from Tom's recue disk:

http://www.toms.net/rb/

and the controller is recognized and I can use fdisk to partition the drive.

However, when I boot from the arch install floppies, the controller is not recognized.  When I manually load the module for the controller, ie. aic7xxx, lsmod shows it as unused.

After looking at the boot log using dmesg, I noticed the following, which I don't understand:

kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno=2

Is this a kernel issue and does anyone have any pointers for me?

Thanks
Kevin

PS: I tried my best to search for a related topic.

Offline

#2 2003-07-20 15:56:25

Moritz
Member
From: Cologne, NRW, Germany
Registered: 2002-10-12
Posts: 166

Re: scsi controller not recognized during ftp install

Hey Kevin!

I've got an Adaptec 29160N, which most be very simular to yours.
This is the way I installed Arch:
Download Nova (;)) and the modules.img (could be found on the ftp server)
- Install with the CD
- Insert the modules floppy disk
- #loadmods /dev/floppy/0
- modprobe aic7xxx
that may take some time!
and then hardisks were present at /dev/discs/*

I would try your way, but I've to wait till I can reboot that system (and that could take a while). But maybe this answer allready helps you!

Regards,
Moritz

Offline

#3 2003-07-20 17:59:54

iKevin
Member
From: Ann Arbor, MI
Registered: 2003-07-20
Posts: 130

Re: scsi controller not recognized during ftp install

Thanks for the reply.  It still doesn't work for me. 

I noticed that the floppy images have been updated -- the md5sum's have changed.  I will give them a try.

As an aside, the listed md5sum's for the new images don't match the downloads.  I downloaded from several mirrors and I get the same sums, which don't match the sums listed.

$ md5sum *.img
99683b5a119e6332cd8f2185a24083cf  boot.img
d2501030749fa2629582de1f02846056  modules.img
97fb96d7b1d858cb260ea8b1005e071b  root.img

$ cat md5sums
2d172ab879f1487f0a381cf432173c26  boot.img
ce6408f0e4051656ddf9c2df3356f1f8  modules.img
97fb96d7b1d858cb260ea8b1005e071b  root.img

Thanks
Kevin

Offline

#4 2003-07-20 21:04:13

iKevin
Member
From: Ann Arbor, MI
Registered: 2003-07-20
Posts: 130

Re: scsi controller not recognized during ftp install

Well, I got the same results with the newer floppy images but I figured things out.  I assume basic scsi support was compiled in the kernel.  I had to do a

modprobe sd_mod

for scsi support.  I could then load the 2940 driver

modprobe aic7xxx

and get /dev/discs....

Thanks again for your help
Kevin

Offline

#5 2003-07-21 08:31:57

Moritz
Member
From: Cologne, NRW, Germany
Registered: 2002-10-12
Posts: 166

Re: scsi controller not recognized during ftp install

ohhh..... :oops:

Sorry! I forgot that! Shame on me! lol

Offline

Board footer

Powered by FluxBB