You are not logged in.

#1 2009-01-11 15:20:10

pano
Member
From: Stuttgart, Germany
Registered: 2008-09-08
Posts: 118

[Solved]Strange issues after upgrading to 2.6.28

Hi,

Yesterday I updated my Kernel to the version from testing (2.6.28-3) with the help of ABS and klibc and mkinitcpio through pacmans testing repo.
I also had compiled xorg-server (1.5.3-2) and xf86-video-intel (2.4.3-1) through the PKGBUILDs from [extra].
I didn't modify the PKGBUILDs at all, I left them as they were.
After istalling the kernel with pacman -U I also installed the other two packages (xorg-server and xf86-video-intel).

Then after rebooting I also installed the package madwifi-newhal-svn from the AUR (I had to modify the PKGBUILD this time to change the kernelversion).

Now I have the following problem:

When I try to press ALT + F1-F10 my laptop switches to a VT (virtual console). When I press CTRL +C the X Server is restarted and I land in front of the kdm, where logging in isn't workin (no matter what you enter or which user you choose, the screen will return to the KDM instantly)

I switched to a VT and killed the X server but I still had the issue with the Keyboard, so that may be an issue of the kernel.

Another thing I noticed:
The Magic SysRQ keys are working since updating the kernel...
With Kernel 2.6.27 and xorg-server 1.5.3 I couldn't get them working...

I hope someone can help me solve this issue...

Thanks in advance

pano

Last edited by pano (2009-01-12 17:21:50)

Offline

#2 2009-01-11 15:32:29

schuay
Trusted User (TU)
From: Austria
Registered: 2008-08-19
Posts: 564

Re: [Solved]Strange issues after upgrading to 2.6.28

maybe this can help you find a solution:

http://bugs.archlinux.org/task/12372

Offline

#3 2009-01-11 22:25:02

pano
Member
From: Stuttgart, Germany
Registered: 2008-09-08
Posts: 118

Re: [Solved]Strange issues after upgrading to 2.6.28

I recompiled xorg-server and xf86-video-intel and now the issue is gone...
*weird*

thanks for the answer though

Offline

Board footer

Powered by FluxBB