You are not logged in.

#1 2009-01-13 11:28:54

alessandro_ufms
Member
From: Campo Grande, MS - Brazil
Registered: 2008-06-25
Posts: 153

[solved] Pacman error on nvidia 180.22 update

When I try update to nvidia 180.22-1 on testing appears the following error:

:: klibc-extras: needs klibc-jfflyAahxqaliwAofrf_fdf5upI
:: klibc-kbd: needs klibc-jfflyAahxqaliwAofrf_fdf5upI
:: klibc-module-init-tools: needs klibc-jfflyAahxqaliwAofrf_fdf5upI
:: klibc-udev: needs klibc-jfflyAahxqaliwAofrf_fdf5upI

I don't know why this appears. Is a pacman bug?

Last edited by alessandro_ufms (2009-01-15 11:34:35)

Offline

#2 2009-01-14 02:57:58

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: [solved] Pacman error on nvidia 180.22 update

It looks like your system is not fully up-to-date.

Offline

#3 2009-01-14 11:22:06

alessandro_ufms
Member
From: Campo Grande, MS - Brazil
Registered: 2008-06-25
Posts: 153

Re: [solved] Pacman error on nvidia 180.22 update

It's updated. I run now "-Sy" and try download the package with "-Sw testing/nvidia" and still appears that.

On PKGBUILD of klibc-extras on testing (http://repos.archlinux.org/viewvc.cgi/k … LD?view=co) there is the line:
depends=('klibc' $(basename /lib/klibc-*.so .so))

the command returns "klibc-jfflyAahxqaliwAofrf_fdf5upI"

pacman -Ql | grep /lib/klibc-jfflyAahxqaliwAofrf_fdf5upI.so
klibc /lib/klibc-jfflyAahxqaliwAofrf_fdf5upI.so

Last edited by alessandro_ufms (2009-01-14 11:29:54)

Offline

#4 2009-01-14 11:38:07

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [solved] Pacman error on nvidia 180.22 update

that's not fully updated. that's fully synced smile.
pacman -Syu is fully updated


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#5 2009-01-14 13:57:40

alessandro_ufms
Member
From: Campo Grande, MS - Brazil
Registered: 2008-06-25
Posts: 153

Re: [solved] Pacman error on nvidia 180.22 update

I'm sorry, I'm updated (pacman -Syu) too.

Offline

#6 2009-01-14 14:39:09

shining
Pacman Developer
Registered: 2006-05-10
Posts: 2,043

Re: [solved] Pacman error on nvidia 180.22 update

alessandro_ufms wrote:

When I try update to nvidia 180.22-1 on testing appears the following error:

:: klibc-extras: needs klibc-jfflyAahxqaliwAofrf_fdf5upI
:: klibc-kbd: needs klibc-jfflyAahxqaliwAofrf_fdf5upI
:: klibc-module-init-tools: needs klibc-jfflyAahxqaliwAofrf_fdf5upI
:: klibc-udev: needs klibc-jfflyAahxqaliwAofrf_fdf5upI

I don't know why this appears. Is a pacman bug?

pacman apparently wants to upgrade klibc but does not want to upgrade all the other klibc-* packages. But all the klibc packages need to stay in sync, so pacman errors out.

Since everything works perfectly for everyone else, and there is no problems with the packages, I still think it's a problem either with you or your system.
If -Su does not work, what does  sudo pacman -S $(pacman -Qsq klibc) do?
And pacman -Q $(pacman -Qsq klibc) ?


pacman roulette : pacman -S $(pacman -Slq | LANG=C sort -R | head -n $((RANDOM % 10)))

Offline

#7 2009-01-14 16:30:18

alessandro_ufms
Member
From: Campo Grande, MS - Brazil
Registered: 2008-06-25
Posts: 153

Re: [solved] Pacman error on nvidia 180.22 update

-Su works for me. I only trying download/install testing/nvidia, but this errors happens.

On my system, there is the following klibc*:
klibc 1.5.14-1
klibc-extras 2.5-1
klibc-kbd 1.15.20080312-7
klibc-module-init-tools 3.4-2
klibc-udev 135-1

pacman -Qi klibc shows that its provides klibc-jfflyAahxqaliwAofrf_fdf5upI

Last edited by alessandro_ufms (2009-01-14 16:41:11)

Offline

#8 2009-01-14 16:34:18

shining
Pacman Developer
Registered: 2006-05-10
Posts: 2,043

Re: [solved] Pacman error on nvidia 180.22 update

alessandro_ufms wrote:

-Su works for me. I only trying download/install testing/nvidia, but this errors happens.

On my system, there is the following klibc*:
klibc 1.5.14-1
klibc-extras 2.5-1
klibc-kbd 1.15.20080312-7
klibc-module-init-tools 3.4-2
klibc-udev 135-1

pacman -Qi klibc shows that its provides klibc-jfflyAahxqaliwAofrf_fdf5upI

The basic idea is : if you are not skilled enough to find out which subset of packages in testing you can cherry-pick, you just don't.
And if you are not skilled at all, you shouldn't use testing at all.
If you are able to troubleshoots things yourself a bit, then you can enable the testing repo fully.


pacman roulette : pacman -S $(pacman -Slq | LANG=C sort -R | head -n $((RANDOM % 10)))

Offline

#9 2009-01-14 16:43:22

alessandro_ufms
Member
From: Campo Grande, MS - Brazil
Registered: 2008-06-25
Posts: 153

Re: [solved] Pacman error on nvidia 180.22 update

I notice testing/nvidia -> testing/kernel26 -> testing/mkinitcpio. If I try donwload testing/mkinitcpio show the same error. I don't knew which the testing/nvidia depends of kernel>=2.6.28.

But, if testing/mkinitcpio depends of new versions of klibc, why the pacman don't update these package too?

Last edited by alessandro_ufms (2009-01-14 16:45:55)

Offline

#10 2009-01-14 17:02:14

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [solved] Pacman error on nvidia 180.22 update

is the last time when i say. Don't pick packages from testing. Enable testing and do pacman -Syu.
Is the safest way to do that.


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#11 2009-01-14 18:14:34

shining
Pacman Developer
Registered: 2006-05-10
Posts: 2,043

Re: [solved] Pacman error on nvidia 180.22 update

alessandro_ufms wrote:

I notice testing/nvidia -> testing/kernel26 -> testing/mkinitcpio. If I try donwload testing/mkinitcpio show the same error. I don't knew which the testing/nvidia depends of kernel>=2.6.28.

But, if testing/mkinitcpio depends of new versions of klibc, why the pacman don't update these package too?

It does! And that's the problem! pacman needs to pull the new klibc because of mkinitcpio.
But pacman does not need to pull the klibc-* packages because the newer versions of these packages are not going to solve any dependencies (from pacman POV).
However, all the old klibc-* packages depend on the old klibc, and the new klibc would break them, so pacman prints these errors, as expected.
You never asked pacman to do anything about the klibc-* packages.
So it's just the way pacman works, and there is nothing wrong about it. Let's focus on the real problem here which is your wrong usage of testing.


pacman roulette : pacman -S $(pacman -Slq | LANG=C sort -R | head -n $((RANDOM % 10)))

Offline

#12 2009-01-14 19:24:39

Plazmic
Member
From: Tampa, FL
Registered: 2009-01-14
Posts: 2

Re: [solved] Pacman error on nvidia 180.22 update

As stated above, pacman is operating the way it is supposed to. If you are in a dire need and cannot wait for 180.22 to make it from testing to stable, install the nvidia-beta package on the AUR before potentially breaking your system.

Offline

#13 2009-01-14 21:12:35

alessandro_ufms
Member
From: Campo Grande, MS - Brazil
Registered: 2008-06-25
Posts: 153

Re: [solved] Pacman error on nvidia 180.22 update

I don't see any problems to use testing at last priority, so I update to testing only programs which I want testing (and your dependences).

I think which the problem is on testing/mkinitcpio dependences.

Because, if it depends klibc>=1.5.14-2 then mkiitcpio also depends  klibc-extras>=2.5-2, klibc-udev>=135-2, klibc-module-init-tools>=3.5-1 and klibc-udev>=135-2. On current PKGBUILD (http://repos.archlinux.org/viewvc.cgi/m … iew=markup) the stable versions of klibc-* are dependences.

I know when this packages gone to core this problem is disappears because of the update all packages klibc together. But I think which if the version dependences were implemented, this error wouldn't appears.

Thank you guys for support.

Last edited by alessandro_ufms (2009-01-14 21:13:49)

Offline

#14 2009-01-14 21:56:05

shining
Pacman Developer
Registered: 2006-05-10
Posts: 2,043

Re: [solved] Pacman error on nvidia 180.22 update

alessandro_ufms wrote:

I don't see any problems to use testing at last priority, so I update to testing only programs which I want testing (and your dependences).

I think which the problem is on testing/mkinitcpio dependences.

Because, if it depends klibc>=1.5.14-2 then mkiitcpio also depends  klibc-extras>=2.5-2, klibc-udev>=135-2, klibc-module-init-tools>=3.5-1 and klibc-udev>=135-2. On current PKGBUILD (http://repos.archlinux.org/viewvc.cgi/m … iew=markup) the stable versions of klibc-* are dependences.

I know when this packages gone to core this problem is disappears because of the update all packages klibc together. But I think which if the version dependences were implemented, this error wouldn't appears.

Thank you guys for support.

YES, changing the dependencies of mkinitcpio could workaround your problem. BUT
1) The current dependencies are fine and are NOT wrong. They just don't support perfectly the partial usage of testing, but as I said previously : PARTIAL USAGE OF TESTING IS NOT SUPPORTED
2) This is not a show stopper. If you knew what you were doing, you could solve the issue yourself without changing any dependencies.
3) Plazmic made a fine suggestion : if your goal is only getting the latest nvidia driver, it would be much better to simply use nvidia-beta on AUR, rather than trying to use testing partially without knowing what you are doing and bothering everyone here.


pacman roulette : pacman -S $(pacman -Slq | LANG=C sort -R | head -n $((RANDOM % 10)))

Offline

#15 2009-01-15 11:34:13

alessandro_ufms
Member
From: Campo Grande, MS - Brazil
Registered: 2008-06-25
Posts: 153

Re: [solved] Pacman error on nvidia 180.22 update

I'm currently using nvidia-beta from AUR. My point did test nvidia on testing repository, no more.

If I offended somebody, it didn't my intention. I'm sorry for my silliness.

That question is resolved for me.

Thank you for all support.

Last edited by alessandro_ufms (2009-01-15 11:35:22)

Offline

#16 2009-01-15 17:05:34

test1000
Member
Registered: 2005-04-03
Posts: 834

Re: [solved] Pacman error on nvidia 180.22 update

just for future reference it might be good to read the pacman manpage

smile


KISS = "It can scarcely be denied that the supreme goal of all theory is to make the irreducible basic elements as simple and as few as possible without having to surrender the adequate representation of a single datum of experience." - Albert Einstein

Offline

Board footer

Powered by FluxBB