You are not logged in.

#1 2003-07-27 19:35:59

Arielext
Member
From: Amersfoort, the Netherlands
Registered: 2002-08-12
Posts: 362
Website

gnome2 troubles

I've installed arch again and synced everything, but I'm getting these kinds of problems while running any sort of gnome2/gtk2 programs

(giFToxic:31293): GdkPixbuf-WARNING **: Can not open pixbuf loader module file '/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

(giFToxic:31293): GdkPixbuf-WARNING **: Can not open pixbuf loader module file '/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

** (giFToxic:31293): WARNING **: No builtin or dynamically loaded modules
were found. Pango will not work correctly. This probably means
there was an error in the creation of:
  '/usr/etc/pango/pango.modules'
You may be able to recreate this file by running pango-querymodules.

How can I solve this?


apt-get install arch

Offline

#2 2003-07-27 21:19:52

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: gnome2 troubles

Arielext wrote:

I've installed arch again and synced everything, but I'm getting these kinds of problems while running any sort of gnome2/gtk2 programs

<snipping code>This probably means
there was an error in the creation of:
  '/usr/etc/pango/pango.modules'
You may be able to recreate this file by running pango-querymodules.

does this file exist at all, or is it not there. If not, this might help:
http://bbs.archlinux.org/viewtopic.php?t=254
note, that the actual command is

pango-querymodules > /usr/etc/pango/pango.modules

btw. I reinstalled arch0.5, too, and everything is fine here. The problem
you mentioned actually occured only with version 0.4.

Can you make sure, there havent been old packages, may be some stuff
on old partitions?

bye neri

Offline

#3 2003-07-28 08:49:16

Arielext
Member
From: Amersfoort, the Netherlands
Registered: 2002-08-12
Posts: 362
Website

Re: gnome2 troubles

That solved half the problem, at least some programs start now! (without graphics, just nicely antialiased text smile)

(gkrellm:334): GdkPixbuf-WARNING **: Error loading XPM image loader: Image type 'xpm' is not supported
  Cannot load xpm: (null)

And I've upgraded everything with pacman, so I don't think thatś the problem ... my old arch install lasted from 0.2 to 0.5 and I've never seen these problems before neutral


apt-get install arch

Offline

#4 2003-07-28 09:21:20

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: gnome2 troubles

Arielext wrote:

That solved half the problem, at least some programs start now! (without graphics, just nicely antialiased text smile)

(gkrellm:334): GdkPixbuf-WARNING **: Error loading XPM image loader: Image type 'xpm' is not supported
  Cannot load xpm: (null)

And I've upgraded everything with pacman, so I don't think thatś the problem ... my old arch install lasted from 0.2 to 0.5 and I've never seen these problems before neutral

Hm, it seems gdk-pixbuf has its own xpm loader, so there is no other lib re-
quired. I also can't find some (pacman -Ss xpm is empty). Maybe there is a
configuration missing on gdk-pixbuf. Either you ask google, or you try rebuild-
ing gdk-pixbuf with makepkg. I know this is not very helpful, maybe
someone else can lend a hand?

bye neri

bye neri

Offline

#5 2003-07-28 19:30:29

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: gnome2 troubles

Hi,

I found something while I tried to recompile gtk2 with the shadow-patch.
The gtk2 install file creates a file called "etc/gtk-2.0/gdk-pixbuf.loaders"

can have a look if it is there? If not, two things:
usr/bin/gdk-pixbuf-query-loaders > etc/gtk-2.0/gdk-pixbuf.loaders
and
/me think, there is somethink broken in your gtk2 installation incl. dependencies

bye neri

Offline

Board footer

Powered by FluxBB