You are not logged in.

#1 2009-01-22 00:08:16

quarkup
Member
From: Portugal
Registered: 2008-09-07
Posts: 497

[SOLVED] CLI and the nvidia's driver

Hello !

  I got a very serious trouble:
          I cannot use the CLI to work while using the proprietary nvidia's driver (the one which allows the 3D acceleration).

If Im using the 'nv' driver I can use the CLI terminal (just like pressing the Ctrl+Alt+F1), otherwise - if im using the 'nvidia' driver I cannot access (or read) the screen, as the lines appear to be scrambled.


hardware:
using a PCI-Express nvidia 6800 go (256m), on a fujitsu-siemens with a 17'' wide-screen (1440x900)
driver version:
nvidia-173 (installed from pacman repo's)


my /etc/X11/xorg.conf is this file:

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Mouse[1]" "AlwaysCore"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
#    RgbPath         "/usr/share/X11/rgb" # deprecated
    ModulePath      "/usr/lib/xorg/modules"
    FontPath        "/usr/share/fonts/misc"
    FontPath        "/usr/share/fonts/100dpi:unscaled"
    FontPath        "/usr/share/fonts/75dpi:unscaled"
    FontPath        "/usr/share/fonts/TTF"
#    FontPath        "/usr/share/fonts/Type1"
EndSection

Section "Module"
#    Load       "GLcore" # disabled (archwiki)
    Load           "extmod"
    Load           "xtrap"
    Load           "glx"
#    Load           "record"        ## error! (read Xorg.0.log)
#    Load       "dri" # disabled (archwiki)
    Load           "dbe"
    Load           "freetype"
    Load       "synaptics"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection

Section "InputDevice"
        Driver          "synaptics"
        Identifier      "Mouse[1]"
        Option          "Device"           "/dev/psaux"
        Option          "Protocol"         "auto-dev"
        Option          "LeftEdge"         "1700"
        Option          "RightEdge"        "5300"
        Option          "TopEdge"          "1700"
        Option          "BottomEdge"       "4200"
        Option          "FingerLow"        "25"
        Option          "FingerHigh"       "30"
        Option          "MaxTapTime"       "180"
        Option          "MaxTapMove"       "220"
        Option          "VertScrollDelta"  "100"
        Option          "MinSpeed"         "0.06"
        Option          "MaxSpeed"         "0.12"
        Option          "AccelFactor"      "0.0010"
        Option          "SHMConfig"        "on"
#       Option          "Repeater"         "/dev/ps2mouse"
EndSection

Section "Monitor"
# Safe for LCD's
# Safe for LCD's and most CRT's.
    Identifier     "Monitor0"
    VendorName     "Monitor Vendor"
    ModelName      "Monitor Model"
    HorizSync       30.0 - 130.0
    VertRefresh     50.0 - 100.0
    Option "DPMS" "True"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"               # [<bool>]
        #Option     "HWcursor"               # [<bool>]
        #Option     "NoAccel"                # [<bool>]
        #Option     "ShadowFB"               # [<bool>]
        #Option     "UseFBDev"               # [<bool>]
        #Option     "Rotate"                 # [<str>]
        #Option     "VideoKey"               # <i>
        #Option     "FlatPanel"              # [<bool>]
        #Option     "FPDither"               # [<bool>]
        #Option     "CrtcNumber"             # <i>
        #Option     "FPScale"                # [<bool>]
        #Option     "FPTweak"                # <i>
        #Option     "DualHead"               # [<bool>]
    #Option        "AIGLX"            # [<bool>]

    Identifier  "Card0"

    Option        "TripleBuffer"     "True"
    Option        "DamageEvents"     "True"

     # PowerMizer - force Powermizer to a certain level at all times
      # level 0x1 = highest
      # level 0x2 = med
      # level 0x3 = lowest
    Option        "RegistryDwords"    "PowerMizerLevelAC=0x1"
    Option        "RegistryDwords"    "PowerMizerLevel=0x2"

     # gpu's automatic performance
    Option        "RegistryDwords"    "PerfLevelSrc=0x3333"

     # disable vblank interrupts
    Option        "OnDemandVBlankInterrupts"    "True"

     # allow overclocking from nvidia-settings
    Option        "Coolbits"        "1"

##    Driver      [nv | nvidia (3d acceleration)]
#    Driver      "nv"
    Driver        "nvidia"
    VendorName  "nVidia Corporation"
    BoardName   "NV41.8 [GeForce Go 6800]"
    BusID       "PCI:3:0:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Viewport    0 0
        Depth       1
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       4
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       8
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       15
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
        Modes      "1440x900" "1024x768" "800x600"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection

#Section "ServerFlags"
#    Option "AutoAddDevices" "False"
#EndSection

 ~$ lspci | grep nVidia
03:00.0 VGA compatible controller: nVidia Corporation NV41.8 [GeForce Go 6800] (rev a2)
 ~$ lsmod | grep nvidia
nvidiafb               45696  0
fb_ddc                  3968  1 nvidiafb
i2c_algo_bit            7556  1 nvidiafb
vgastate               11136  1 nvidiafb
nvidia               7096900  0
agpgart                31572  2 intel_agp,nvidia
i2c_core               22804  5 i2c_i801,nvidiafb,fb_ddc,i2c_algo_bit,nvidia

Thanks in advance..

Last edited by quarkup (2009-01-22 15:47:38)


If people do not believe that mathematics is simple, it is only because they do not realize how complicated life is.
Simplicity is the ultimate sophistication.

Offline

#2 2009-01-22 00:34:50

somedrew
Member
From: Canada
Registered: 2007-05-14
Posts: 140

Re: [SOLVED] CLI and the nvidia's driver

Using nvidiafb along with the nivida blob could be causing the problem. Does using vesafb instead solve the frambuffer issue when using the nivida binary?

Offline

#3 2009-01-22 09:54:24

quarkup
Member
From: Portugal
Registered: 2008-09-07
Posts: 497

Re: [SOLVED] CLI and the nvidia's driver

somedrew wrote:

Using nvidiafb along with the nivida blob could be causing the problem. Does using vesafb instead solve the frambuffer issue when using the nivida binary?

how can I use (install) vesafb?

   I have tried uvesafb (from wiki: http://wiki.archlinux.org/index.php/Uvesafb) and I got the same issue, this only changes my framebuffer resolution.
   Im using vga=792 for grub, tested other vga modes but this is just fine.

btw:
    installed fbgrab, and it prints the CLI 1 juts fine (with the login).
  when I press Ctrl+Alt+F1 i get the screen with colorful lines all scrambled up, but I tested I can use the terminal, the only bug is the video..



my /var/log/Xorg.0.log file

X.Org X Server 1.5.3
Release Date: 5 November 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.27-ARCH i686 
Current Operating System: Linux supernova 2.6.28-ARCH #1 SMP PREEMPT Sun Jan 18 20:17:17 UTC 2009 i686
Build Date: 17 December 2008  08:20:05PM
 
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Jan 22 10:18:15 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "X.org Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Mouse[1]"
(**) |-->Input Device "Keyboard0"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) Including the default font path /usr/share/fonts/misc,/usr/share/fonts/100dpi:unscaled,/usr/share/fonts/75dpi:unscaled,/usr/share/fonts/TTF,/usr/share/fonts/Type1.
(**) FontPath set to:
    /usr/share/fonts/misc,
    /usr/share/fonts/100dpi:unscaled,
    /usr/share/fonts/75dpi:unscaled,
    /usr/share/fonts/TTF,
    /usr/share/fonts/misc,
    /usr/share/fonts/100dpi:unscaled,
    /usr/share/fonts/75dpi:unscaled,
    /usr/share/fonts/TTF,
    /usr/share/fonts/Type1
(**) ModulePath set to "/usr/lib/xorg/modules"
(**) Extension "Composite" is enabled
(WW) AllowEmptyInput is on, devices using drivers 'kbd' or 'mouse' will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) No APM support in BIOS or kernel
(II) Loader magic: 0x81d5fe0
(II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 4.1
    X.Org XInput driver : 2.1
    X.Org Server Extension : 1.1
    X.Org Font Renderer : 0.6
(II) Loader running on linux
(++) using VT number 7

(--) PCI:*(0@3:0:0) nVidia Corporation NV41.8 [GeForce Go 6800] rev 162, Mem @ 0xfd000000/0, 0xc0000000/0, 0xfc000000/0, BIOS @ 0x????????/131072
(II) System resource ranges:
    [0] -1    0    0xffffffff - 0xffffffff (0x1) MX[b]
    [1] -1    0    0x000f0000 - 0x000fffff (0x10000) MX[b]
    [2] -1    0    0x000c0000 - 0x000effff (0x30000) MX[b]
    [3] -1    0    0x00000000 - 0x0009ffff (0xa0000) MX[b]
    [4] -1    0    0x0000ffff - 0x0000ffff (0x1) IX[b]
    [5] -1    0    0x00000000 - 0x00000000 (0x1) IX[b]
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "freetype" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri" will be loaded by default.
(II) LoadModule: "extmod"

(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
    compiled for 1.5.3, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 1.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "xtrap"

(II) Loading /usr/lib/xorg/modules/extensions//libxtrap.so
(II) Module xtrap: vendor="X.Org Foundation"
    compiled for 1.5.3, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 1.1
(II) Loading extension DEC-XTRAP
(II) LoadModule: "glx"

(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: X.Org Server Extension
(II) NVIDIA GLX Module  173.14.12  Thu Jul 17 18:36:35 PDT 2008
(II) Loading extension GLX
(II) LoadModule: "dbe"

(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
    compiled for 1.5.3, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 1.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "freetype"

(II) Loading /usr/lib/xorg/modules/fonts//libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
    compiled for 1.5.3, module version = 2.1.0
    Module class: X.Org Font Renderer
    ABI class: X.Org Font Renderer, version 0.6
(II) Loading font FreeType
(II) LoadModule: "synaptics"

(II) Loading /usr/lib/xorg/modules/input//synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
    compiled for 1.5.3, module version = 0.99.3
    Module class: X.Org XInput Driver
    ABI class: X.Org XInput driver, version 2.1
(II) LoadModule: "dri"

(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
    compiled for 1.5.3, module version = 1.0.0
    ABI class: X.Org Server Extension, version 1.1
(II) Loading extension XFree86-DRI
(II) LoadModule: "nvidia"

(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: X.Org Video Driver
(II) LoadModule: "synaptics"

(II) Reloading /usr/lib/xorg/modules/input//synaptics_drv.so
(II) NVIDIA dlloader X Driver  173.14.12  Thu Jul 17 18:15:54 PDT 2008
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 03@00:00:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"

(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
    compiled for 1.5.3, module version = 1.0.0
    ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"

(II) Loading /usr/lib/xorg/modules//libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
    compiled for 1.5.3, module version = 1.0.0
    ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(II) resource ranges after probing:
    [0] -1    0    0xffffffff - 0xffffffff (0x1) MX[b]
    [1] -1    0    0x000f0000 - 0x000fffff (0x10000) MX[b]
    [2] -1    0    0x000c0000 - 0x000effff (0x30000) MX[b]
    [3] -1    0    0x00000000 - 0x0009ffff (0xa0000) MX[b]
    [4] -1    0    0x0000ffff - 0x0000ffff (0x1) IX[b]
    [5] -1    0    0x00000000 - 0x00000000 (0x1) IX[b]
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "RegistryDwords" "PowerMizerLevelAC=0x1"
(**) NVIDIA(0): Option "Coolbits" "1"
(**) NVIDIA(0): Option "TripleBuffer" "True"
(**) NVIDIA(0): Option "DamageEvents" "True"
(**) NVIDIA(0): Option "OnDemandVBlankInterrupts" "True"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):     enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce Go 6800 (NV41) at PCI:3:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 262144 kBytes
(--) NVIDIA(0): VideoBIOS: 05.41.02.39.49
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce Go 6800 at PCI:3:0:0:
(--) NVIDIA(0):     AUO (DFP-0)
(--) NVIDIA(0): AUO (DFP-0): 310.0 MHz maximum pixel clock
(--) NVIDIA(0): AUO (DFP-0): Internal Dual Link LVDS
(II) NVIDIA(0): Assigned Display Device: DFP-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "1440x900"
(II) NVIDIA(0):     "1024x768"
(II) NVIDIA(0):     "800x600"
(II) NVIDIA(0): Virtual screen size determined to be 1440 x 900
(--) NVIDIA(0): DPI set to (98, 99); computed from "UseEdidDpi" X config
(--) NVIDIA(0):     option
(==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:
    [0] -1    0    0xffffffff - 0xffffffff (0x1) MX[b]
    [1] -1    0    0x000f0000 - 0x000fffff (0x10000) MX[b]
    [2] -1    0    0x000c0000 - 0x000effff (0x30000) MX[b]
    [3] -1    0    0x00000000 - 0x0009ffff (0xa0000) MX[b]
    [4] -1    0    0x0000ffff - 0x0000ffff (0x1) IX[b]
    [5] -1    0    0x00000000 - 0x00000000 (0x1) IX[b]
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Unable to connect to the ACPI daemon; the ACPI daemon may not
(II) NVIDIA(0):     be running or the "AcpidSocketPath" X configuration option
(II) NVIDIA(0):     may not be set correctly.  When the ACPI daemon is
(II) NVIDIA(0):     available, the NVIDIA X driver can use it to receive ACPI
(II) NVIDIA(0):     events.  For details, please see the "ConnectToAcpid" and
(II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
(II) NVIDIA(0):     Config Options in the README.
(II) NVIDIA(0): ACPI display change hotkey events enabled: the X server is new
(II) NVIDIA(0):     enough to receive ACPI display change hotkey events.
(II) NVIDIA(0): Setting mode "1440x900"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms" "True"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
(II) Synaptics touchpad driver version 0.99.3
Mouse[1] no synaptics event device found
(**) Option "Device" "/dev/psaux"
(**) Option "SHMConfig" "on"
(**) Option "LeftEdge" "1700"
(**) Option "RightEdge" "5300"
(**) Option "TopEdge" "1700"
(**) Option "BottomEdge" "4200"
(**) Option "FingerLow" "25"
(**) Option "FingerHigh" "30"
(**) Option "MaxTapTime" "180"
(**) Option "MaxTapMove" "220"
(**) Option "VertScrollDelta" "100"
Query no Synaptics: 6003C8
(--) Mouse[1]: no supported touchpad found
(**) Option "AlwaysCore"
(**) Mouse[1]: always reports core events
(II) evaluating device (Mouse[1])
(II) XINPUT: Adding extended input device "Mouse[1]" (type: TOUCHPAD)
Mouse[1] no synaptics event device found
Query no Synaptics: 6003C8
(--) Mouse[1]: no supported touchpad found
(II) config/hal: Adding input device 5 button optical mouse with scroll wheel 5 button optical mouse with scroll wheel
(II) LoadModule: "evdev"

(II) Loading /usr/lib/xorg/modules/input//evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
    compiled for 1.5.3, module version = 2.1.0
    Module class: X.Org XInput Driver
    ABI class: X.Org XInput driver, version 2.1
(**) 5 button optical mouse with scroll wheel 5 button optical mouse with scroll wheel: always reports core events
(**) 5 button optical mouse with scroll wheel 5 button optical mouse with scroll wheel: Device: "/dev/input/event8"
(II) 5 button optical mouse with scroll wheel 5 button optical mouse with scroll wheel: Found 5 mouse buttons
(II) 5 button optical mouse with scroll wheel 5 button optical mouse with scroll wheel: Found x and y relative axes
(II) 5 button optical mouse with scroll wheel 5 button optical mouse with scroll wheel: Configuring as mouse
(**) 5 button optical mouse with scroll wheel 5 button optical mouse with scroll wheel: YAxisMapping: buttons 4 and 5
(**) 5 button optical mouse with scroll wheel 5 button optical mouse with scroll wheel: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "5 button optical mouse with scroll wheel 5 button optical mouse with scroll wheel" (type: MOUSE)
(II) config/hal: Adding input device Video Bus
(**) Video Bus: always reports core events
(**) Video Bus: Device: "/dev/input/event6"
(II) Video Bus: Found keys
(II) Video Bus: Configuring as keyboard
(II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Video Bus: xkb_rules: "evdev"
(**) Option "xkb_model" "evdev"
(**) Video Bus: xkb_model: "evdev"
(**) Option "xkb_layout" "us"
(**) Video Bus: xkb_layout: "us"
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event1"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) AT Translated Set 2 keyboard: xkb_rules: "evdev"
(**) Option "xkb_model" "evdev"
(**) AT Translated Set 2 keyboard: xkb_model: "evdev"
(**) Option "xkb_layout" "us"
(**) AT Translated Set 2 keyboard: xkb_layout: "us"
(II) config/hal: Adding input device Macintosh mouse button emulation
(**) Macintosh mouse button emulation: always reports core events
(**) Macintosh mouse button emulation: Device: "/dev/input/event0"
(II) Macintosh mouse button emulation: Found 3 mouse buttons
(II) Macintosh mouse button emulation: Found x and y relative axes
(II) Macintosh mouse button emulation: Configuring as mouse
(**) Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
(**) Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE)
Query no Synaptics: 6003C8

Last edited by quarkup (2009-01-22 13:05:16)


If people do not believe that mathematics is simple, it is only because they do not realize how complicated life is.
Simplicity is the ultimate sophistication.

Offline

#4 2009-01-22 13:28:51

somedrew
Member
From: Canada
Registered: 2007-05-14
Posts: 140

Re: [SOLVED] CLI and the nvidia's driver

quarkup wrote:

how can I use (install) vesafb?

If you're running the stock arch kernel config it's built as a module. You can just load it instead of nvidiafb.

quarkup wrote:

I have tried uvesafb (from wiki: http://wiki.archlinux.org/index.php/Uvesafb) and I got the same issue, this only changes my framebuffer resolution.
   Im using vga=792 for grub, tested other vga modes but this is just fine.

Probably not related to using nvidiafb then. If it sounds related to: http://www.nvnews.net/vbulletin/showthread.php?t=81256 then creating a file in /etc/modprobe.d/ with

 options nvidia NVreg_UseVBios=0

should clear it up.

cheers.

Offline

#5 2009-01-22 15:47:06

quarkup
Member
From: Portugal
Registered: 2008-09-07
Posts: 497

Re: [SOLVED] CLI and the nvidia's driver

Thank you very much,
it's fine now big_smile


If people do not believe that mathematics is simple, it is only because they do not realize how complicated life is.
Simplicity is the ultimate sophistication.

Offline

Board footer

Powered by FluxBB