You are not logged in.

#1 2009-01-21 04:18:49

mindfall
Member
From: berlin
Registered: 2007-07-03
Posts: 57

KDE 4.1.96 painting errors

I just installed the 4.2 release candidate and noticed some painting issues. It might have to do with Nvidia driver, but on the other hand the issue is new since KDE 4.2.

The strangeness in kmenu's selection happenes every time and makes the menu unusable. The other shot shows a tiny error on the scrollbar; Not an issue, but the only reproducable glitch I found. The other glitches are shy and only happen when I have no snapshot app open smile

Is this a bug in KDE or in Nvidia?

http://www.pictureupload.de/pictures/21 … owcase.png
http://www.pictureupload.de/pictures/21 … wcase2.png

Last edited by mindfall (2009-01-21 04:23:48)

Offline

#2 2009-01-21 06:16:25

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: KDE 4.1.96 painting errors

Could you try it with a new user (profile). Do you use the 180.xx driver?

Offline

#3 2009-01-21 07:05:22

mindfall
Member
From: berlin
Registered: 2007-07-03
Posts: 57

Re: KDE 4.1.96 painting errors

Also in einem frischen Profil sind die Fehler beim Menu nicht mehr da. Seltsam.
Hab auch sonst keinerlei Grafikfehler ausmachen können.
Ich hab eine GeForce4 mit 96xx Treibern.

Offline

#4 2009-01-21 08:22:50

mindfall
Member
From: berlin
Registered: 2007-07-03
Posts: 57

Re: KDE 4.1.96 painting errors

Sorry I have to correct myself: The glitches are on a new profile too.
I'm convinced now it's a bug. The painting errors in KMenu only happen when the widget is put on the desktop. When it is in the panel and pops up, there are no glitches. Weird.

Offline

#5 2009-01-21 09:48:28

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: KDE 4.1.96 painting errors

Try the nv driver. Afaik the 96.xx is driver is in beta state and has some problems. The sad things is that nvidia onl provides updates for newer cards atm.

Offline

#6 2009-01-23 02:47:41

mindfall
Member
From: berlin
Registered: 2007-07-03
Posts: 57

Re: KDE 4.1.96 painting errors

Strangely I couldn't get the nv driver to work any more, module not found.
Anyways, the glitches thing has proved to not be a problem over the last days, it looked like a worse issue when I posted this.  It's just not possible to put the kicker menu straight on the desktop.

Offline

#7 2009-01-23 13:56:41

Slammer64
Member
From: Ozark Mountains of Missouri
Registered: 2007-07-28
Posts: 113

Re: KDE 4.1.96 painting errors

Have you installed the nv module? Try pacman -S xf86-video-nv?


Somewhere, just out of sight, the Penguins are gathering!

Offline

#8 2009-01-24 01:07:05

mindfall
Member
From: berlin
Registered: 2007-07-03
Posts: 57

Re: KDE 4.1.96 painting errors

D'oh! I did a pacman search for "nvidia" and only got the binary blobs, so I quickly concluded nv is delivered together with the core xorg package hmm
Thanks smile

Offline

Board footer

Powered by FluxBB