You are not logged in.

#1 2009-01-23 01:02:10

moljac024
Member
From: Serbia
Registered: 2008-01-29
Posts: 2,676

[SOLVED]Problems with touchpad

Recently my touchpad has started acting up. Tapping and vertical scrolling no longer work.
I have had Xorg 7.4 since the day it came into extra and I have just noticed this today. I don't use the touchpad much but I do occasionally and I would have noticed if tapping didn't work. Must have been a recent update but looking at the pacman logs I can't seem to point my finger at it.
Now, I tried creating the synaptic fdi file for hal, and following the wiki but it doesn't seem to do anything. Tapping nor vertical scrolling just won't work anymore.

snippet from "cat /proc/bus/input/devices" :

I: Bus=0011 Vendor=0002 Product=000e Version=0000
N: Name="ETPS/2 Elantech Touchpad"
P: Phys=isa0060/serio2/input0
S: Sysfs=/class/input/input9
U: Uniq=
H: Handlers=mouse2 event9 
B: EV=f
B: KEY=6420 0 70000 0 0 0 0 0 0 0 0
B: REL=3
B: ABS=3

It seems my touchpad isn't a synaptic one, so no synaptic.fdi file could help me.

Also, one other thing that I've noticed is that when a second user logs on and then logs out, the touchpad no longer works for the first user.
I'm using GDM to have both users logged into an X session when needed. Also, this didn't happen before.
Any help with this will be appreciated.

Last edited by moljac024 (2009-01-23 11:09:07)


The day Microsoft makes a product that doesn't suck, is the day they make a vacuum cleaner.
--------------------------------------------------------------------------------------------------------------
But if they tell you that I've lost my mind, maybe it's not gone just a little hard to find...

Offline

#2 2009-01-23 01:28:12

Wittfella
Member
From: Australia
Registered: 2008-05-27
Posts: 462

Re: [SOLVED]Problems with touchpad

Check 'lshal' ouput.  Make sure its loading the synaptic driver and not falling back to evdev.

Offline

#3 2009-01-23 10:20:41

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 668

Re: [SOLVED]Problems with touchpad

I had a similar problem with hal and my touchpad, maybe you can check my thread:

http://bbs.archlinux.org/viewtopic.php?id=63189

Hope you'll find something useful there.

Offline

#4 2009-01-23 11:08:51

moljac024
Member
From: Serbia
Registered: 2008-01-29
Posts: 2,676

Re: [SOLVED]Problems with touchpad

lshal indeed showed that it was loading the evdev driver.
This is a fdi file that works, you can see what I needed to change:

<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.mouse">
      <match key="input.product" contains="Elantech Touchpad">
        <!-- Arbitrary options can be passed to the driver using
             the input.x11_options property since xorg-server-1.5. -->
        <!-- EXAMPLE:
        <merge key="input.x11_options.LeftEdge" type="string">120</merge>
        -->
  <merge key="input.x11_driver" type="string">synaptics</merge>
  <merge key="input.x11_options.AlwaysCore" type="string">true</merge>
  <merge key="input.x11_options.VertEdgeScroll" type="string">true</merge>
  <merge key="input.x11_options.HorizEdgeScroll" type="string">true</merge>
  <merge key="input.x11_options.TapButton1" type="string">1</merge>
  <merge key="input.x11_options.TapButton2" type="string">2</merge>
  <merge key="input.x11_options.TapButton3" type="string">3</merge>
</match>
</match>
  </device>
</deviceinfo>

Thanks!

EDIT: Also, the problem with the touchpad not working for a user after another one logs out is gone as well. Must have been an issue with evdev, I guess..

Last edited by moljac024 (2009-01-23 11:54:05)


The day Microsoft makes a product that doesn't suck, is the day they make a vacuum cleaner.
--------------------------------------------------------------------------------------------------------------
But if they tell you that I've lost my mind, maybe it's not gone just a little hard to find...

Offline

Board footer

Powered by FluxBB