You are not logged in.

#1 2009-01-23 19:09:44

Slammer64
Member
From: Ozark Mountains of Missouri
Registered: 2007-07-28
Posts: 113

KDE 4.2 Error

I decided to make an exception and try the testing repo for once since it had KDE 4.2 recently added to it, here's my observations so far. I did a clean install, and only used testing to install KDE 4.2 and it's associated dependencies. Running on a BFG nVidia 8800GT OC with 512 meg ram I noticed that upon logging in for about the 6th time (I dual boot a lot) I got a KWIN crash, tried to generate a backtrace,since I have gdb installed, no good. Looked at some of the earlier posts and tried disabling VSYNC and that set off another round of errors. Ctrl-Alt-Backspace and then tried to disable composite, did ok, but when trying to re-enable more KWIN crashes. I can post my xorg.conf here on request, it's not very big. I know this is testing and crashes are to be expected, but I'm making this report to help the dev's. Any info you need, just ask. I'm running without composite enable in my xorg.conf right now and the only thing I notice is the main menu blanking to a white space on logout/restart/shutdown.


Somewhere, just out of sight, the Penguins are gathering!

Offline

#2 2009-01-23 20:30:22

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,571
Website

Re: KDE 4.2 Error

I randomly get KWIN crashes at KDE startup, but everything works fine. I got this on 4.1 as well. nVidia 8400, 180.22 drivers, latest kernel, etc.


Matt

"It is very difficult to educate the educated."

Offline

#3 2009-01-23 20:40:57

Slammer64
Member
From: Ozark Mountains of Missouri
Registered: 2007-07-28
Posts: 113

Re: KDE 4.2 Error

I forgot to mention that I was running the 2.6.28.1 kernel for x86_64 and using the stock repo nvidia drivers: 180.22.


Somewhere, just out of sight, the Penguins are gathering!

Offline

#4 2009-01-24 02:32:17

Ranguvar
Member
From: Our collective subconscious
Registered: 2008-08-12
Posts: 2,515
Website

Re: KDE 4.2 Error

A lot of people are having trouble with the new NVIDIA drivers. Have you tried the old version, just in case it's having a problem with KDE 4.2?

Offline

#5 2009-01-24 02:50:58

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,571
Website

Re: KDE 4.2 Error

I haven't myself. For no other reasons than 1) Eveny though I am likeing KDE, going back to Gnome wouldn't bother me, and 2) I just don't want to go through all the trouble of downgrading the kernel as well.


Matt

"It is very difficult to educate the educated."

Offline

#6 2009-01-24 13:29:54

Slammer64
Member
From: Ozark Mountains of Missouri
Registered: 2007-07-28
Posts: 113

Re: KDE 4.2 Error

I'm checking to see if the latest updates to testing fix the problem, seems to be working now, but I don't really need compositing as it interfere's with certain of my games (namely Alpha Centauri).


Somewhere, just out of sight, the Penguins are gathering!

Offline

#7 2009-01-24 14:16:10

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,571
Website

Re: KDE 4.2 Error

Well, trying to fight another problem forced my to try downgrading the kernel and nvidia to 2.6.27 and 177.82 respectively. I've just booted once since then, but no KWin crash. It didn't happen all the time with 2.6.28 + 180.22, though, so one run is not enough to get excited about. Depending on how long these versions of kernel +  nvidia stay around, I'll try to keep an eye on it.


Matt

"It is very difficult to educate the educated."

Offline

Board footer

Powered by FluxBB