You are not logged in.

#1 2009-01-26 21:45:47

krigun
Member
From: Norway
Registered: 2005-06-06
Posts: 122
Website

KDE 4.2 is SMOOTH

Hi,

Just wanted to say that I have been running KDE 4.2 from the [testing] repo on my system, and I must admit that it looks and feels amazing. It's sad to read all the negative publicity around KDE 4.0/4.1 (Linus abandoning KDE and all), but 4.2 seems to be config/functionality wise where 3.5 left off. And it looks very nice.

The only "problem" I have had with it, is that the default fonts look like SIHT, both for QT and GTK apps. Perhaps thats a system config problem on my end (so that GTK and QT choose the UGLIEST font they can find), but after a small round of config replacing all with the Monaco font, its all good.

Respect to the developers and package maintainers!

Offline

#2 2009-01-26 22:03:31

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: KDE 4.2 is SMOOTH

Did you install ttf-dejavu? If anything is strange, it often helps to start with an empty config (move .kde4 or try a new user).

Offline

#3 2009-01-26 22:11:19

Maki
Member
From: Skopje, Macedonia
Registered: 2007-10-16
Posts: 345
Website

Re: KDE 4.2 is SMOOTH

What graphic card do you have?
On Ati Radeon + free driver it was sluggish when i tried it a month ago


If it ain't broke, broke it then fix it.

Offline

#4 2009-01-26 22:47:29

AdeBe
Member
From: Warsaw
Registered: 2008-12-28
Posts: 8

Re: KDE 4.2 is SMOOTH

I've got intel gma945 and I also experienced some sluggishness of 4.2 (where 4.1 was smooth). It happens only if desktop effects are enabled, at beginning everything is ok, but after some time desktop is slowing down (not only effects, but it also takes seconds or even minutes between *click* and action). I don't know if this is smth with my intel card, but as I said 4.1 was ok.

Offline

#5 2009-01-26 23:09:09

krigun
Member
From: Norway
Registered: 2005-06-06
Posts: 122
Website

Re: KDE 4.2 is SMOOTH

Pierre wrote:

Did you install ttf-dejavu? If anything is strange, it often helps to start with an empty config (move .kde4 or try a new user).

Hi,
Yes, ttf-dejavu is installed, and I always remove .kde/ .kde4/ and .kderc when I see a major KDE update, but it may just be that I'm spoiled with my favourite font of all time, Monaco (Yes, the apple font):

eclipse-textmate-snippet.png

And my system is not sluggish at all, KDE 4.2 is smoooth smile (XPS M1710, GeForce 7900GS).

I've got intel gma945 and I also experienced some sluggishness of 4.2..

Well, a graphics dev from my work summed up the Intel GMA pretty well: "It would be better to have no graphics accelerator at all" big_smile
But strange that KDE 4.1 worked fine for you then.. But my glxgears FPS slices in half when I enable desktop effects, so both QT and KWin are using a fair amount of GPU, no doubt about that.

Peace

Offline

#6 2009-01-27 12:52:46

toad
Member
From: if only I knew
Registered: 2008-12-22
Posts: 1,775
Website

Re: KDE 4.2 is SMOOTH

Do a

pacman -Ss font

for available fonts - there is a bit and then some smile

My system looks nice with ttf-ms-fonts ttf-bitstream-vera ttf-freefont installed.

HTH

Last edited by toad (2009-01-27 12:53:06)


never trust a toad...
::Grateful ArchDonor::
::Grateful Wikipedia Donor::

Offline

Board footer

Powered by FluxBB