You are not logged in.

#1 2009-02-20 12:15:05

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,271

[SOLVED] irregular de/en keyboard layout in thunderbird/firefox

Since some recent upgrade I experience some weird keybord layout problems with thunderbird and firefox.

In thunderbird, when replying to a mail, the keymap appears to be set to english instead of the usual de-latin1 set up for my system. However, this changes back to de-latin1 as soon as I close the mail editor and just only restart another reply session. (Correction: I have to restart thunderbird immediately after closing the mail editor to have the keyboard layout switched. Hence it may be caused by some initialization glitch.)

Similar case in firefox. Sometimes e.g. using the "Quick post" entry field on Arch Forum pages only english input will be possible. Appears to be irregular, however, yesterday and the day before only english was possible, today it is german again. Could be mozilla dependent, I just answered a letter in thunderbird immediately before starting up firefox.

I experience this problem in Arch only, so some recent upgrade may have caused it. But before digging deeper -- does anybody else see such behaviour as well?

BTW: This in an IceWM environment. Might be dependent on this as well.

Last edited by bernarcher (2009-02-22 17:40:09)


To know or not to know ...
... the questions remain forever.

Online

#2 2009-02-22 17:39:48

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,271

Re: [SOLVED] irregular de/en keyboard layout in thunderbird/firefox

This behaviour did not show up again the last days, thus it might have been caused by some update glitch only.

Sorry for the noise,
bernacher


To know or not to know ...
... the questions remain forever.

Online

#3 2009-02-28 13:22:37

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,271

Re: [SOLVED] irregular de/en keyboard layout in thunderbird/firefox

Well, it took a while to really solve this one. For details you may want follow this thread on the German forum:
http://forum.archlinux.de/?page=Posting … read=11645

Essentially the irregular behaviour was caused by the Xorg configuration.
- Install the xf86-input-evdev package if not done already.
- Make sure the hal daemon is started as early as possible in the DAEMONS array in rc.conf.
- Set up your keyboard layout properly:

cp /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi /etc/hal/fdi/policy/10-keymap.fdi

And there edit these lines

<merge key="input.xkb.layout" type="string">(your_layout_designator)</merge>
<merge key="input.xkb.variant" type="string">(your_keyboard_variant)</merge>

- Finally make sure Xorg adds the input devices by its own

Section "ServerFlags"
     Option "AutoAddDevices" "True"
EndSection

Or better yet, remove the AutoAddDevices line altogether.

It is all working flawlessly now.

Last edited by bernarcher (2009-02-28 13:23:27)


To know or not to know ...
... the questions remain forever.

Online

Board footer

Powered by FluxBB