You are not logged in.

#1 2009-02-08 10:54:42

Soc
Member
Registered: 2009-02-08
Posts: 2

[SOLVED] Sound only from headphones on hp pavillion dv4-1028us

Hello.
I'm looking for solution of my problem from long time, I was searching for days and tried various tips.
My problem started when I was using Arch 32, but on older kernels I needed to put "irqpoll" option at grub's menu.lst to avoid looping/scratching of music.
After kernel upgrade I lost sound at all. I have tried many things, even installing other distibutions - most was not able to get sound from my card. And while one was able, sound was terrific - looping, once faster, one slower.
Now I'm running Arch64 bit due to my 4gb of ram. I was trying fallowing steps:
- Searching for similar problems on web and trying to find solution for owners of my card
- Editing modprobe.conf with all various settings of models
- Compiling new alsa with snd-hde-intel options
- Reinstalling alsa
- Checking 100x if channels are unmuted tongue
- Searching and searching again... No tips helped, most of them was about adding specific line to modprobe.conf

So let's present my my hardware.
At first, my sound card is :

 Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

And kernel:

  2.6.28-ARCH x86_64

I keep my arch up to date, not using testing or experimental repositories.
Running kdemod 4.2.

You can find more output informations there:

http://www.alsa-project.org/db/?f=a05a3ac78bac812ba70bd4adb9b0ac6c0c1c773c

It's log of alsa-info.sh script, created to gather informations about sound hardware.

I succed on soud quality - by modprobe.conf options, I'm able now to listen music, but it's not possible to make my build-in speakers to work.
If you got any idea how could I do this, or questions - please, reply.

                                                                                                                                                                                                                                    Thank you for reading, Soc.

Last edited by Soc (2009-02-20 20:25:55)

Offline

#2 2009-02-08 17:05:31

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,734

Re: [SOLVED] Sound only from headphones on hp pavillion dv4-1028us

Maybe you need to add an option to your modprobe file, search the forum for similar problems with alsa, I'm sure you will find plenty of similar problems.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#3 2009-02-20 20:49:22

Soc
Member
Registered: 2009-02-08
Posts: 2

Re: [SOLVED] Sound only from headphones on hp pavillion dv4-1028us

Hello again.
After a few days of research I found a solution, and I want to share with you.

For all people having problems with intel-hda.

At first, you must specify your version of card, and what's more important - codecs.
Even if you have same soundcard but different model of laptop (let's say hp pavillion dv7 comparing to hp pavillion dv4 or whatever else) you got other codecs. Mostly solution prepared for dv7 WILL NOT WORK for dv4.
It should be similar situation with any other laptops.

bash-3.2# lspci |grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

How to know what's ur codec?

bash-3.2# cat /proc/asound/card0/codec#* |grep Codec
Codec: IDT 92HD71B7X
Codec: LSI ID 1040
Codec: Generic 8086 ID 2802

Now try to google similar problem that you have, but this time using your codec information. On the forums, there was link to ubuntu thread with information what can you write into modprobe.conf as options model=XXX, comparing to codec that you have, sadly, there were no newer codecs aviable in the list, so there was no use of it.

All people who got same codecs like me - there is solution for you.
Just clear all your /etc/modprobe.conf // /etc/modprobe.d/alsa-base // /etc/modprobe.d/sound from entries that was dedicated to your snd modules. Now creat pure /etc/modprobe.d/sound and fill it with this.

options snd slots=snd-hda-intel
options snd-hda-intel model=hp-m4
# u1Nb.nVqf9RDT4C3:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

Now, just reboot.
Check alsamixer, unmute and raise channels and test your sound. If you hear looping or scratching, you can add

enable_msi=1

option, after model=hp-m4

Cheers.

Offline

#4 2009-03-22 17:01:26

dhmejia
Member
Registered: 2009-03-21
Posts: 13

Re: [SOLVED] Sound only from headphones on hp pavillion dv4-1028us

hello everybody, first one sorry for my bad english.

My laptop is a dv4-1125nr, the output of codec is:

[diego@diego_laptop ~]$ cat /proc/asound/card0/codec#* |grep Codec
Codec: IDT 92HD71B7X
Codec: LSI ID 1040
Codec: Generic 8086 ID 2802

audio device is:

[diego@diego_laptop ~]$ lspci |grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

Soc's solution doesn't work for me, I try with model=laptop but nothing.

The light indicator of sound changes from orange to white, but the sound doesn't work.

Any idea?

Offline

#5 2009-12-24 15:09:23

mfpuente
Member
From: La Rioja - Argentina
Registered: 2009-06-04
Posts: 11

Re: [SOLVED] Sound only from headphones on hp pavillion dv4-1028us

Soc wrote:

Hello again.
After a few days of research I found a solution, and I want to share with you.

For all people having problems with intel-hda.

At first, you must specify your version of card, and what's more important - codecs.
Even if you have same soundcard but different model of laptop (let's say hp pavillion dv7 comparing to hp pavillion dv4 or whatever else) you got other codecs. Mostly solution prepared for dv7 WILL NOT WORK for dv4.
It should be similar situation with any other laptops.

bash-3.2# lspci |grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

How to know what's ur codec?

bash-3.2# cat /proc/asound/card0/codec#* |grep Codec
Codec: IDT 92HD71B7X
Codec: LSI ID 1040
Codec: Generic 8086 ID 2802

Now try to google similar problem that you have, but this time using your codec information. On the forums, there was link to ubuntu thread with information what can you write into modprobe.conf as options model=XXX, comparing to codec that you have, sadly, there were no newer codecs aviable in the list, so there was no use of it.

All people who got same codecs like me - there is solution for you.
Just clear all your /etc/modprobe.conf // /etc/modprobe.d/alsa-base // /etc/modprobe.d/sound from entries that was dedicated to your snd modules. Now creat pure /etc/modprobe.d/sound and fill it with this.

options snd slots=snd-hda-intel
options snd-hda-intel model=hp-m4
# u1Nb.nVqf9RDT4C3:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

Now, just reboot.
Check alsamixer, unmute and raise channels and test your sound. If you hear looping or scratching, you can add

enable_msi=1

option, after model=hp-m4

Cheers.

This solution work also for a HP Pavilion dv4-2016

Thank you very much Soc!

Offline

Board footer

Powered by FluxBB